Updated package devel/pcre-ocaml to version 7.3.4.
Changes include a build system switch (to jbuilder and topkg), and bugfixes and performance improvements.
This commit is contained in:
parent
2a06ea4618
commit
e7f7a1d4ac
5 changed files with 34 additions and 41 deletions
|
@ -1,19 +1,22 @@
|
|||
# $NetBSD: Makefile,v 1.30 2017/09/08 09:51:23 jaapb Exp $
|
||||
# $NetBSD: Makefile,v 1.31 2018/01/10 16:21:20 jaapb Exp $
|
||||
|
||||
DISTNAME= pcre-ocaml-7.2.3
|
||||
VERSION= 7.3.4
|
||||
DISTNAME= pcre-${VERSION}
|
||||
PKGNAME= pcre-ocaml-${VERSION}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=mmottl/}
|
||||
GITHUB_RELEASE= v${PKGVERSION_NOREV}
|
||||
|
||||
MAINTAINER= jaapb@NetBSD.org
|
||||
HOMEPAGE= https://github.com/mmottl/pcre-ocaml
|
||||
COMMENT= Perl compatible regular expressions for OCaml
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
|
||||
OCAML_USE_OASIS= yes
|
||||
WRKSRC= ${WRKDIR}/pcre-ocaml-${VERSION}
|
||||
|
||||
OCAML_USE_JBUILDER= yes
|
||||
OPAM_INSTALL_FILES= pcre
|
||||
USE_TOOLS= pax
|
||||
MAKE_JOBS_SAFE= no
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.include "../../mk/ocaml.mk"
|
||||
|
@ -25,5 +28,8 @@ OCAML_FINDLIB_DIRS= pcre
|
|||
post-install:
|
||||
cd ${WRKSRC}/examples && pax -rw -pm . ${DESTDIR}${EGDIR}
|
||||
|
||||
.include "../../devel/ocaml-base/buildlink3.mk"
|
||||
.include "../../devel/ocaml-configurator/buildlink3.mk"
|
||||
.include "../../devel/ocaml-stdio/buildlink3.mk"
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,23 +1,24 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2016/06/25 14:30:31 jaapb Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2018/01/10 16:21:20 jaapb Exp $
|
||||
${OCAML_SITELIB}/pcre/META
|
||||
${OCAML_SITELIB}/pcre/dllpcre_stubs.so
|
||||
${OCAML_SITELIB}/pcre/libpcre_stubs.a
|
||||
${OCAML_SITELIB}/pcre/opam
|
||||
${PLIST.ocaml-opt}${OCAML_SITELIB}/pcre/pcre.a
|
||||
${OCAML_SITELIB}/pcre/pcre.cma
|
||||
${PLIST.ocaml-opt}${OCAML_SITELIB}/pcre/pcre.cmx
|
||||
${PLIST.ocaml-opt}${OCAML_SITELIB}/pcre/pcre.cmxa
|
||||
${PLIST.ocaml-opt}${OCAML_SITELIB}/pcre/pcre.cmxs
|
||||
${OCAML_SITELIB}/pcre/pcre.annot
|
||||
${OCAML_SITELIB}/pcre/pcre.cmi
|
||||
${OCAML_SITELIB}/pcre/pcre.cmt
|
||||
${OCAML_SITELIB}/pcre/pcre.cmti
|
||||
${PLIST.ocaml-opt}${OCAML_SITELIB}/pcre/pcre.cmx
|
||||
${PLIST.ocaml-opt}${OCAML_SITELIB}/pcre/pcre.cmxa
|
||||
${PLIST.ocaml-opt}${OCAML_SITELIB}/pcre/pcre.cmxs
|
||||
${OCAML_SITELIB}/pcre/pcre.mli
|
||||
${PLIST.ocaml-opt}${OCAML_SITELIB}/pcre/pcre_compat.cmx
|
||||
share/examples/pcre-ocaml/cloc/README.md
|
||||
share/examples/pcre-ocaml/cloc/cloc.ml
|
||||
share/examples/pcre-ocaml/count_hash/README.md
|
||||
share/examples/pcre-ocaml/count_hash/count_hash.ml
|
||||
share/examples/pcre-ocaml/pcregrep/README.md
|
||||
share/examples/pcre-ocaml/pcregrep/pcregrep.ml
|
||||
share/examples/pcre-ocaml/subst/README.md
|
||||
share/examples/pcre-ocaml/subst/subst.ml
|
||||
${OCAML_SITELIB}/stublibs/dllpcre_stubs.so
|
||||
share/doc/pcre/CHANGES.md
|
||||
share/doc/pcre/LICENSE.md
|
||||
share/doc/pcre/README.md
|
||||
share/examples/pcre-ocaml/Makefile
|
||||
share/examples/pcre-ocaml/README.md
|
||||
share/examples/pcre-ocaml/cloc.ml
|
||||
share/examples/pcre-ocaml/count_hash.ml
|
||||
share/examples/pcre-ocaml/jbuild
|
||||
share/examples/pcre-ocaml/pcregrep.ml
|
||||
share/examples/pcre-ocaml/subst.ml
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.5 2017/07/11 12:31:37 jaapb Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.6 2018/01/10 16:21:20 jaapb Exp $
|
||||
|
||||
BUILDLINK_TREE+= pcre-ocaml
|
||||
|
||||
|
@ -6,7 +6,7 @@ BUILDLINK_TREE+= pcre-ocaml
|
|||
PCRE_OCAML_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.pcre-ocaml+= pcre-ocaml>=5.10.3nb1
|
||||
BUILDLINK_ABI_DEPENDS.pcre-ocaml+= pcre-ocaml>=7.2.3
|
||||
BUILDLINK_ABI_DEPENDS.pcre-ocaml+= pcre-ocaml>=7.3.4
|
||||
BUILDLINK_PKGSRCDIR.pcre-ocaml?= ../../devel/pcre-ocaml
|
||||
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.12 2017/07/11 12:31:37 jaapb Exp $
|
||||
$NetBSD: distinfo,v 1.13 2018/01/10 16:21:20 jaapb Exp $
|
||||
|
||||
SHA1 (pcre-ocaml-7.2.3.tar.gz) = 5d52637e87def713190f213375bd3cc66504ff91
|
||||
RMD160 (pcre-ocaml-7.2.3.tar.gz) = c19a9b646f21a6f41728e0b2930fa1b658b49e71
|
||||
SHA512 (pcre-ocaml-7.2.3.tar.gz) = 3df4bdbbed5e1ecf4bdf15fc461f2ea65e1556af9c1683e194c8824e21da5274dd80c22c1f6676fca203305ec4244d47e09f0ef8c601bfa95f7237bb07c1ee65
|
||||
Size (pcre-ocaml-7.2.3.tar.gz) = 88307 bytes
|
||||
SHA1 (patch-myocamlbuild.ml) = ede5646b1a69ad0a60c706dee82d8aa52923cb57
|
||||
SHA1 (pcre-7.3.4.tar.gz) = 4971469cc943a85c1a44254ad1b823d6ae6e9574
|
||||
RMD160 (pcre-7.3.4.tar.gz) = fed14ea19988e50335bf892f1e6928f75c7ed677
|
||||
SHA512 (pcre-7.3.4.tar.gz) = 4ea38a8cb655da8c36e020a74b293ae4d959db9c1b040d76475222e129458f87801709053a39593d0c3fae3e085190088fa7b06311cae6bb1cec62a8b78df663
|
||||
Size (pcre-7.3.4.tar.gz) = 44657 bytes
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-myocamlbuild.ml,v 1.2 2015/01/20 14:31:09 jaapb Exp $
|
||||
|
||||
Use pkgsrc-runtime flag for proper building
|
||||
--- myocamlbuild.ml.orig 2014-12-12 02:37:43.000000000 +0000
|
||||
+++ myocamlbuild.ml
|
||||
@@ -420,6 +420,7 @@ module MyOCamlbuildFindlib = struct
|
||||
flag ["ocaml"; "package(threads)"; "doc"] (S[A "-I"; A "+threads"]);
|
||||
flag ["ocaml"; "package(threads)"; "link"] (S[A "-thread"]);
|
||||
flag ["ocaml"; "package(threads)"; "infer_interface"] (S[A "-thread"]);
|
||||
+ flag ["ocaml"; "link"; "native"] (S[A "-passopt"; A "-pkgsrc-runtime"]);
|
||||
|
||||
| _ ->
|
||||
()
|
Loading…
Reference in a new issue