Update cairo to 0.2.0. Changes include:

New license: LGPL/MPL
---------------------
The most significant news with this release is that the license of
cairo has changed. It is now dual-licensed under the LGPL and the
MPL. For details see the COPYING file as well as COPYING-LGPL-2.1 and
COPYING-MPL-1.1.

I express my thanks to everyone involved in the license change process
for their patience and support!

New font and glyph internals
----------------------------
Graydon Hoare has put a tremendous amount of work into new internals
for handling fonts and glyphs, including caches where appropriate.
This work has no impact on the user-level API, but should result in
great performance improvements for applications using text.

New test suite
--------------
This snapshot of cairo includes a (small) test suite in
cairo/test. The tests can be run with "make check". The test suite was
designed to make it very easy to add new tests, and we hope to see
many contributions here. As you find bugs, please try adding a minimal
test case to the suite, and submit it with the bug report to the
cairo@cairographics.org mailing list. This will make it much easier
for us to track progress in fixing bugs.

New name for glitz backend
--------------------------
The gl backend has now been renamed to the glitz backend. This means
that the following names have changed:

        CAIRO_HAS_GL_SURFACE    -> CAIRO_HAS_GLITZ_SURFACE
        cairo_set_target_gl     -> cairo_set_target_glitz
        cairo_gl_surface_create -> cairo_glitz_surface_create

This change obviously breaks backwards compatibility for applications
using the old gl backend.

Up-to-date with latest glitz snapshots
--------------------------------------
This snapshot of cairo is now up to date with the latest glitz
snapshot, (currently 0.2.3). We know that the latest cairo and glitz
snapshots have been incompatible for a very long time. We've finally
fixed that now and we're determined to not let that happen again.

Revert some tessellation regression bugs

Miscellaneous changes
---------------------
Changed CAIRO_FILTER_DEFAULT to CAIRO_FILTER_BEST to make gradients
easier.

Track XCB API change regarding iterators.

Various bug fixes
-----------------
Fix calculation of required number of vertices for pen.

Fix to avoid zero-dimensioned pixmaps.

Fix broken sort of pen vertices.

Fix bug when cairo_show_text called with a NULL string.

Fix clipping bugs.

Fix bug in computing image length with XCB.

Fix infinite loop bug in cairo_arc.

Fix memory management interactions with libpixman.
This commit is contained in:
rh 2004-11-15 03:59:49 +00:00
parent 818f1a56e4
commit e8082de913
3 changed files with 5 additions and 30 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.12 2004/10/03 00:14:49 tv Exp $
# $NetBSD: Makefile,v 1.13 2004/11/15 03:59:49 rh Exp $
DISTNAME= cairo-0.1.23
PKGREVISION= 2
DISTNAME= cairo-0.2.0
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/snapshots/

View file

@ -1,5 +1,4 @@
$NetBSD: distinfo,v 1.5 2004/07/03 23:01:36 recht Exp $
$NetBSD: distinfo,v 1.6 2004/11/15 03:59:49 rh Exp $
SHA1 (cairo-0.1.23.tar.gz) = ed0bea8a6f1382803989c047631f3d6d82c864c3
Size (cairo-0.1.23.tar.gz) = 393051 bytes
SHA1 (patch-aa) = 0c9aba36a2c9a114e9b0da08ea0df0bf3f336e52
SHA1 (cairo-0.2.0.tar.gz) = 451ad7bd1f3dfe1aa46de721450d9f34dc9af1ee
Size (cairo-0.2.0.tar.gz) = 462216 bytes

View file

@ -1,23 +0,0 @@
$NetBSD: patch-aa,v 1.1 2004/07/03 23:01:36 recht Exp $
--- src/cairo_image_surface.c.orig 2004-04-14 03:06:15.000000000 +0200
+++ src/cairo_image_surface.c
@@ -462,7 +462,17 @@ cairo_int_status_t
_cairo_image_surface_set_clip_region (cairo_image_surface_t *surface,
pixman_region16_t *region)
{
- pixman_image_set_clip_region (surface->pixman_image, region);
+ if (region) {
+ pixman_region16_t *rcopy;
+
+ rcopy = pixman_region_create();
+ /* pixman_image_set_clip_region expects to take ownership of the
+ * passed-in region, so we create a copy to give it. */
+ pixman_region_copy (rcopy, region);
+ pixman_image_set_clip_region (surface->pixman_image, rcopy);
+ } else {
+ pixman_image_set_clip_region (surface->pixman_image, region);
+ }
return CAIRO_STATUS_SUCCESS;
}