Rename "locale_t" to not conflict with locale.h.
This commit is contained in:
parent
53ce92d266
commit
e80e06e3f6
2 changed files with 27 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.5 2013/01/26 23:13:47 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.6 2013/05/11 21:38:22 joerg Exp $
|
||||
|
||||
SHA1 (tvtime-1.0.2.tar.gz) = ea609876084b2d627a84a1f77bf81cc2175ee58e
|
||||
RMD160 (tvtime-1.0.2.tar.gz) = e7d9621054edba5833f4ea002be8979983fbf3dc
|
||||
|
@ -15,3 +15,4 @@ SHA1 (patch-ai) = 4a97047148528d37245899cc396cbf0b7926350a
|
|||
SHA1 (patch-aj) = 4200e919df91d2a29e577459a9056203b2074254
|
||||
SHA1 (patch-ak) = 1b0bc021387b6ab31ff32b173b6897364dc7fa4c
|
||||
SHA1 (patch-al) = b183822cff1f5b022e0509b33299f7b99ab57442
|
||||
SHA1 (patch-src_xmltv.c) = ba107c28eacb6967918cb074a23354eb6c2d2ea6
|
||||
|
|
25
multimedia/tvtime/patches/patch-src_xmltv.c
Normal file
25
multimedia/tvtime/patches/patch-src_xmltv.c
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-src_xmltv.c,v 1.1 2013/05/11 21:38:22 joerg Exp $
|
||||
|
||||
--- src/xmltv.c.orig 2013-05-10 14:43:03.000000000 +0000
|
||||
+++ src/xmltv.c
|
||||
@@ -118,9 +118,9 @@ const int num_timezones = sizeof( date_m
|
||||
typedef struct {
|
||||
const char *code;
|
||||
const char *name;
|
||||
-} locale_t;
|
||||
+} my_locale_t;
|
||||
|
||||
-static locale_t locale_table[] = {
|
||||
+static my_locale_t locale_table[] = {
|
||||
{"AA", "Afar"}, {"AB", "Abkhazian"}, {"AF", "Afrikaans"},
|
||||
{"AM", "Amharic"}, {"AR", "Arabic"}, {"AS", "Assamese"},
|
||||
{"AY", "Aymara"}, {"AZ", "Azerbaijani"}, {"BA", "Bashkir"},
|
||||
@@ -168,7 +168,7 @@ static locale_t locale_table[] = {
|
||||
{"XH", "Xhosa"}, {"YO", "Yoruba"}, {"ZH", "Chinese"},
|
||||
{"ZU", "Zulu"} };
|
||||
|
||||
-const int num_locales = sizeof( locale_table ) / sizeof( locale_t );
|
||||
+const int num_locales = sizeof( locale_table ) / sizeof( *locale_table );
|
||||
|
||||
/**
|
||||
* Timezone parsing code based loosely on the algorithm in
|
Loading…
Reference in a new issue