Update to 1.1.4, provided by OBATA Akio in PR 33058:

2006-03-03  Mikio Hirabayashi

* estraier.c (est_cond_set_skip, est_cond_skip): new functions.
* estraier.c (est_memory_usage): new function.
* estraier.c (est_deflate, est_inflate): "mode" parameter was added.
* estnode.c (est_node_set_skip): removed.
* estcmd.c (doputdoc, procextkeys): finishing was to occur when
the RAM runs out.
* estmaster.c (communicate, sendnodecmdsearchui): gzip encoding
was added.
* estcall.c (runsearch, procsearch): "-vu" option was added.
- Java API was to support deflated transfer.
- Release: 1.1.4

2006-01-01  Mikio Hirabayashi

* estraier.c (est_db_open): tuning parameters of perfect N-gram
mode were modified.
* estraier.c (est_db_open): compression with LZO and BZIP2 was
added.
* estraier.c (est_set_vnumbuf, est_read_vnumbuf): new functions.
* estmaster.c (dispatch): preemption during synchronization was
implemented.
* estmaster.c (sendmasterdata): "backup" was added.
* estmaster.c (backupdb): new function.
* estmaster.c (searchlocal, searchremote): minimum number to retrieve
was to be set.
* estmaster.c (sendnodecmdsearch): "skip" parameter was added.
* estcmd.c (runwords, procwords): "-kt" option was added.
* estcall.c (runsearch, procsearch): "-sk" option was added.
* estcmd.c (runsearch, procsezrch): "-sn" option was added.
* mymorth.c (est_mecab_analyze): MeCab 0.90 was supported.
- Release: 1.1.3
This commit is contained in:
wiz 2006-03-11 14:24:58 +00:00
parent 3d92aafa7b
commit e84196bfa9
4 changed files with 30 additions and 22 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.3 2006/01/11 18:26:59 wiz Exp $
# $NetBSD: Makefile,v 1.4 2006/03/11 14:24:58 wiz Exp $
DISTNAME= hyperestraier-1.1.2
DISTNAME= hyperestraier-1.1.4
CATEGORIES= japanese textproc www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=hyperestraier/}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2006/01/11 18:26:59 wiz Exp $
@comment $NetBSD: PLIST,v 1.4 2006/03/11 14:24:58 wiz Exp $
bin/estcall
bin/estcmd
bin/estconfig
@ -12,9 +12,15 @@ include/estraier.h
lib/libestraier.a
lib/libestraier.so
lib/libestraier.so.8
lib/libestraier.so.8.1.0
lib/libestraier.so.8.3.0
lib/pkgconfig/hyperestraier.pc
libexec/estseek.cgi
man/man1/estcall.1
man/man1/estcmd.1
man/man1/estconfig.1
man/man1/estmaster.1
man/man3/estnode.3
man/man3/estraier.3
share/hyperestraier/COPYING
share/hyperestraier/ChangeLog
share/hyperestraier/THANKS
@ -79,6 +85,7 @@ share/hyperestraier/doc/rubynativeapi/classes/Estraier/Condition.src/M000030.htm
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Condition.src/M000031.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Condition.src/M000032.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Condition.src/M000033.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Condition.src/M000034.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Database.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Database.src/M000001.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Database.src/M000002.html
@ -103,7 +110,6 @@ share/hyperestraier/doc/rubynativeapi/classes/Estraier/Database.src/M000020.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Database.src/M000021.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Database.src/M000022.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000034.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000035.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000036.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000037.html
@ -114,6 +120,9 @@ share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000041.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000042.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000043.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000044.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000045.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000046.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Document.src/M000047.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Result.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Result.src/M000023.html
share/hyperestraier/doc/rubynativeapi/classes/Estraier/Result.src/M000024.html
@ -139,9 +148,9 @@ share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Condition.src/M000044.h
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Condition.src/M000045.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Condition.src/M000046.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Condition.src/M000047.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Condition.src/M000048.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Condition.src/M000049.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000048.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000049.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000050.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000051.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000052.html
@ -150,6 +159,10 @@ share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000054.ht
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000055.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000056.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000057.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000058.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000059.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000060.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Document.src/M000061.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Node.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Node.src/M000001.html
share/hyperestraier/doc/rubypureapi/classes/EstraierPure/Node.src/M000002.html
@ -207,18 +220,13 @@ share/hyperestraier/filter/estfxasis
share/hyperestraier/filter/estfxmantotxt
share/hyperestraier/filter/estfxmsotohtml
share/hyperestraier/filter/estfxpdftohtml
share/hyperestraier/filter/estfxxdwtotxt
share/hyperestraier/filter/estwnetxpnd
share/hyperestraier/increm/estseek-form.html
share/hyperestraier/increm/estseek-frame.html
share/hyperestraier/locale/ja/estseek.conf
share/hyperestraier/locale/ja/estseek.tmpl
share/hyperestraier/locale/ja/estseek.top
man/man1/estcall.1
man/man1/estcmd.1
man/man1/estconfig.1
man/man1/estmaster.1
man/man3/estnode.3
man/man3/estraier.3
@dirrm share/hyperestraier/locale/ja
@dirrm share/hyperestraier/locale
@dirrm share/hyperestraier/increm

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.3 2006/01/11 18:26:59 wiz Exp $
$NetBSD: distinfo,v 1.4 2006/03/11 14:24:58 wiz Exp $
SHA1 (hyperestraier-1.1.2.tar.gz) = 9c49418ff1c5d6fba4e6286297df3d4540219041
RMD160 (hyperestraier-1.1.2.tar.gz) = 2133f6191e86b2a37fe4fde7a62d94b7e4df5ba4
Size (hyperestraier-1.1.2.tar.gz) = 735801 bytes
SHA1 (patch-aa) = 4505be918c6ee0c59c7331a09adbe5dc320d76c3
SHA1 (hyperestraier-1.1.4.tar.gz) = 02dadabfeab4eb593e91758e0c68c9fbd77f42b2
RMD160 (hyperestraier-1.1.4.tar.gz) = c144968653fb1ebbf0eaf246e1b169846911f5fd
Size (hyperestraier-1.1.4.tar.gz) = 753053 bytes
SHA1 (patch-aa) = 87dbcfd75617d7fcf6d7c66644bb09dd7abc4c72
SHA1 (patch-ab) = 6c862f34f0cc0343877ddc44464f5e3bb1892785

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.2 2006/01/11 18:26:59 wiz Exp $
$NetBSD: patch-aa,v 1.3 2006/03/11 14:24:58 wiz Exp $
--- configure.orig 2005-12-16 11:48:26.000000000 +0900
--- configure.orig 2006-03-09 00:22:14.000000000 +0900
+++ configure
@@ -2743,7 +2743,7 @@ if test "${ac_cv_lib_pthread_main+set}"
@@ -2914,7 +2914,7 @@ if test "${ac_cv_lib_pthread_main+set}"
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
@ -11,7 +11,7 @@ $NetBSD: patch-aa,v 1.2 2006/01/11 18:26:59 wiz Exp $
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -2796,7 +2796,9 @@ fi
@@ -2967,7 +2967,9 @@ fi
echo "$as_me:$LINENO: result: $ac_cv_lib_pthread_main" >&5
echo "${ECHO_T}$ac_cv_lib_pthread_main" >&6
if test $ac_cv_lib_pthread_main = yes; then