Update to 0.46.

- 0.46 | 2013-03-14

  - bugfix: handle connection options w/o "backup" env var

	Previously, ‘pg-conndefaults’ expected every option to have a
	backup env var (e.g., option ‘#:host’ and env var ‘PGHOST’).
	For later versions of PostgreSQL which no longer maintain this
	1:1 correspondance, Guile-PG would segfault.

	Now, in such cases, the value associated w/ the key ‘#:envvar’
	in the alist returned by ‘pg-conndefaults’ is ‘#f’.

  - planned retirement
    - procedure ‘(database postgres) pg-getline’
    - procedure ‘(database postgres) pg-getlineasync’
    - procedure ‘(database postgres) pg-putline’
    - procedure ‘(database postgres) pg-endcopy’

	These procedures are obsoleted by ‘pg-get-copy-data’ and
	‘pg-put-copy-data’.  They WILL BE REMOVED by 2013-12-31.

	Actually, the first two were originally -- in Guile-PG 0.41
	(2011-09-29) -- planned to be removed by 2012-12-31.
	Support has been extended for solidarity w/ the latter two.

  - bootstrap tools upgraded
    - GNU Texinfo 5.1

Copyright (C) 2002-2013 Thien-Thi Nguyen

Copying and distribution of this file, with or without modification,
are permitted provided the copyright notice and this notice are preserved.
This commit is contained in:
gdt 2013-05-03 15:23:35 +00:00
parent b8bfb35ec4
commit e845c97404
3 changed files with 6 additions and 28 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.46 2013/03/13 23:30:42 gdt Exp $
# $NetBSD: Makefile,v 1.47 2013/05/03 15:23:35 gdt Exp $
#
DISTNAME= guile-pg-0.45
DISTNAME= guile-pg-0.46
CATEGORIES= databases
MASTER_SITES= http://download.savannah.nongnu.org/releases/guile-pg/
EXTRACT_SUFX= .tar.xz

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.12 2013/03/13 23:30:42 gdt Exp $
$NetBSD: distinfo,v 1.13 2013/05/03 15:23:35 gdt Exp $
SHA1 (guile-pg-0.45.tar.xz) = 40f885d25fb8364fb038b5b83fd3d7f2a0582df8
RMD160 (guile-pg-0.45.tar.xz) = ef7d82b8847cbac042836daecfd0fd2df198e60f
Size (guile-pg-0.45.tar.xz) = 514144 bytes
SHA1 (patch-src_libpq.c) = 078666d3cc7788a278d7455a700b81fbd8973b2c
SHA1 (guile-pg-0.46.tar.xz) = 43ca4ca581b5885265eb9f6787eb80578443670e
RMD160 (guile-pg-0.46.tar.xz) = a5d5891718154e3e44abb880e0222f7ef9f8589a
Size (guile-pg-0.46.tar.xz) = 514484 bytes

View file

@ -1,21 +0,0 @@
$NetBSD: patch-src_libpq.c,v 1.1 2013/03/13 23:30:42 gdt Exp $
Patch from upstream author to address segfault when a member of
PQconndefaults() does not have an envvar. Expected in next upstream
release.
--- src/libpq.c.orig 2012-04-29 11:50:08.000000000 +0000
+++ src/libpq.c
@@ -1174,11 +1174,11 @@ presenting this option in the first plac
for (head = opt = PQconndefaults (); opt && opt->keyword; opt++)
rv = CONS
(PCHAIN (scm_c_make_keyword (opt->keyword),
- PAIRX (envvar, STRING (opt->envvar)),
+ PAIRM (envvar, STRING (opt->envvar)),
PAIRM (compiled, STRING (opt->compiled)),
PAIRM (val, STRING (opt->val)),
PAIRM (label, STRING (opt->label)),
PAIRM (dispchar, CHARACTER (opt->dispchar[0])),
PAIRX (dispsize, NUM_INT (opt->dispsize))),
rv);