Fix build with gcc 4.6

This commit is contained in:
hans 2011-11-01 16:01:34 +00:00
parent 8168ab3a6c
commit e84cac683f
2 changed files with 24 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.5 2011/09/14 17:56:08 hans Exp $
$NetBSD: distinfo,v 1.6 2011/11/01 16:01:34 hans Exp $
SHA1 (libunique-1.1.6.tar.gz) = ff9a50781291212d97df0d21ac4bbdbd8443d210
RMD160 (libunique-1.1.6.tar.gz) = 15ae8cc81f978554395fcb194ecb11c7bc6a1938
Size (libunique-1.1.6.tar.gz) = 450569 bytes
SHA1 (patch-aa) = 03304df00cc8a793c4937f32daa4cd0719d7e8c0
SHA1 (patch-unique_dbus_uniquebackend-dbus.c) = 4599bba61aa6ff585016330a89b506cac72a03e9

View file

@ -0,0 +1,22 @@
$NetBSD: patch-unique_dbus_uniquebackend-dbus.c,v 1.1 2011/11/01 16:01:34 hans Exp $
--- unique/dbus/uniquebackend-dbus.c.orig 2009-11-01 20:15:26.000000000 +0100
+++ unique/dbus/uniquebackend-dbus.c 2011-10-20 14:18:38.936534307 +0200
@@ -84,7 +84,7 @@ unique_backend_dbus_register_proxy (Uniq
static gboolean
unique_backend_dbus_request_name (UniqueBackend *backend)
{
- UniqueBackendDBus *backend_dbus;
+ UniqueBackendDBus __attribute__((__unused__)) *backend_dbus;
const gchar *name;
DBusGConnection *connection;
DBusGProxy *proxy;
@@ -186,7 +186,7 @@ unique_backend_dbus_send_message (Unique
GValueArray *data;
gchar *cmd;
gchar *resp;
- gboolean res;
+ gboolean __attribute__((__unused__)) res;
GError *error;
UniqueResponse response;