Fix build with Clang using upstream patch.

This commit is contained in:
joerg 2012-04-19 21:08:04 +00:00
parent 1a910242dc
commit e8655a71c5
2 changed files with 24 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.46 2012/02/20 14:34:33 hans Exp $
$NetBSD: distinfo,v 1.47 2012/04/19 21:08:04 joerg Exp $
SHA1 (webkit-1.6.3.tar.xz) = 7df69608ef2ce9dd7328353b4ee34f69271cd43b
RMD160 (webkit-1.6.3.tar.xz) = cc319ffe4c2810663ae05b90e69d9495f5c3f0aa
@ -7,6 +7,7 @@ SHA1 (patch-Source_JavaScriptCore_heap_MachineStackMarker.cpp) = a19c152025d16b3
SHA1 (patch-Source_JavaScriptCore_jit_JITStubs.cpp) = 87ff59a80fb8bc436ee0b7093b4e26dc515de984
SHA1 (patch-Source_JavaScriptCore_wtf_MathExtras.h) = 17295aa1eacf1e5847e460bc99e70118f2f3f13b
SHA1 (patch-Source_JavaScriptCore_wtf_Threading.h) = f056b8f08c68d44e1b9dfd2bcf60cb788b05f38f
SHA1 (patch-Source_WebCore_plugins_gtk_PluginViewGtk.cpp) = df947af4c58e455c3adcbcb9ea27cab4d36f236c
SHA1 (patch-ag) = 220a9925ba1eb4288d334997fda24f41595de1c8
SHA1 (patch-ah) = de2e719f67534bf64fb5968b457888e9bd824a3d
SHA1 (patch-ai) = 8998dbb783922a866dcd00e14f33086d7edecdef

View file

@ -0,0 +1,22 @@
$NetBSD: patch-Source_WebCore_plugins_gtk_PluginViewGtk.cpp,v 1.1 2012/04/19 21:08:04 joerg Exp $
- Changeset 97591: Fix clang build
--- Source/WebCore/plugins/gtk/PluginViewGtk.cpp.orig 2012-01-31 01:20:09.000000000 +0000
+++ Source/WebCore/plugins/gtk/PluginViewGtk.cpp
@@ -71,6 +71,7 @@
#include <gtk/gtk.h>
#if defined(XP_UNIX)
+#define String XtStringType
#include "RefPtrCairo.h"
#include "gtk2xtbin.h"
#define Bool int // this got undefined somewhere
@@ -81,6 +82,7 @@
#elif defined(GDK_WINDOWING_WIN32)
#include "PluginMessageThrottlerWin.h"
#include <gdk/gdkwin32.h>
+#undef String
#endif
using JSC::ExecState;