Newer zlib is stricter about typing, adjust.

This commit is contained in:
joerg 2017-02-18 14:01:22 +00:00
parent f3f1528350
commit e86cdb25e4
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.12 2015/11/03 20:57:03 agc Exp $
$NetBSD: distinfo,v 1.13 2017/02/18 14:01:22 joerg Exp $
SHA1 (quakeforge-0.5.5.tar.gz) = 3ceb229b3d777b6c5e0cb1530b4547b20737f402
RMD160 (quakeforge-0.5.5.tar.gz) = d22b29498e950bfdf96169bafee6409fca1a8e11
@ -32,4 +32,5 @@ SHA1 (patch-include_QF_mathlib.h) = d867387c23ebfc2542711af655cb27cb3dab261d
SHA1 (patch-include_r__dynamic.h) = e37cd1d4e242db48793c29c2b78aa78eb14d138d
SHA1 (patch-include_r__local.h) = 7bb3b46ea3835489a20609739bd7a8dc79b36c96
SHA1 (patch-libs_util_llist.c) = d41fdac88ac1c9dbccd1bffd512f7e34ae381860
SHA1 (patch-libs_util_quakeio.c) = fd2810a21507d1a2faae313edb260efdfde9a9a8
SHA1 (patch-qw_source_master.c) = 8f42fec4b36c24daa8205f342318e91611b8b5df

View file

@ -0,0 +1,13 @@
$NetBSD: patch-libs_util_quakeio.c,v 1.1 2017/02/18 14:01:22 joerg Exp $
--- libs/util/quakeio.c.orig 2017-02-18 02:03:20.448822400 +0000
+++ libs/util/quakeio.c
@@ -72,7 +72,7 @@ static __attribute__ ((unused)) const ch
struct QFile_s {
FILE *file;
#ifdef HAVE_ZLIB
- gzFile *gzfile;
+ gzFile gzfile;
#endif
off_t size;
off_t start;