Avoid redefining local symbols. Fix namespace lookup issues.
This commit is contained in:
parent
1e3d8b22e0
commit
e894312966
3 changed files with 98 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.4 2011/02/06 17:06:48 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.5 2012/10/26 20:38:24 joerg Exp $
|
||||
|
||||
SHA1 (kipi-plugins-0.1.7.tar.bz2) = 520b6b9d36a8c5b8893c3a6b5a1a14f6b9cbd216
|
||||
RMD160 (kipi-plugins-0.1.7.tar.bz2) = f66473c11e66f9e06aa6772c7952b640b565def9
|
||||
|
@ -8,4 +8,6 @@ SHA1 (patch-ab) = 777834238d49c0b02c7e1d5c63dbdf0d27f13e24
|
|||
SHA1 (patch-ac) = 0022166061696e3db820c97be64e2780a63e8b4c
|
||||
SHA1 (patch-ad) = b33efd502e1bd305242debe0e9837903ab34021f
|
||||
SHA1 (patch-ae) = 6e12d87f6169d3ba1687eaa202c2edb1ac5ec7a4
|
||||
SHA1 (patch-kipi-plugins_flickrexport_imageslist.cpp) = 43b3a56f1b686253e94eab921670447822c1695b
|
||||
SHA1 (patch-kipi-plugins_imageviewer_viewerwidget.cpp) = 173a70306d89fec21e27bb3cf6a14198b4eeffca
|
||||
SHA1 (patch-kipi-plugins_rawconverter_rawdecodingiface.cpp) = 2105ef9bee4f4c64f1205ff40431fec2ef1517a5
|
||||
|
|
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-kipi-plugins_flickrexport_imageslist.cpp,v 1.1 2012/10/26 20:38:24 joerg Exp $
|
||||
|
||||
--- kipi-plugins/flickrexport/imageslist.cpp.orig 2012-10-26 17:28:12.000000000 +0000
|
||||
+++ kipi-plugins/flickrexport/imageslist.cpp
|
||||
@@ -228,15 +228,12 @@ void ImagesList::slotAddImages(const KUR
|
||||
|
||||
bool find = false;
|
||||
|
||||
- QListViewItemIterator it(d->listView);
|
||||
- while (it.current())
|
||||
+ for (QListViewItemIterator it2(d->listView); it2.current(); ++it2)
|
||||
{
|
||||
- ImagesListViewItem* item = dynamic_cast<ImagesListViewItem*>(*it);
|
||||
+ ImagesListViewItem* item = dynamic_cast<ImagesListViewItem*>(*it2);
|
||||
|
||||
if (item->url() == imageUrl)
|
||||
find = true;
|
||||
-
|
||||
- ++it;
|
||||
}
|
||||
|
||||
if (!find)
|
|
@ -0,0 +1,73 @@
|
|||
$NetBSD: patch-kipi-plugins_imageviewer_viewerwidget.cpp,v 1.1 2012/10/26 20:38:24 joerg Exp $
|
||||
|
||||
--- kipi-plugins/imageviewer/viewerwidget.cpp.orig 2008-12-13 11:20:05.000000000 +0000
|
||||
+++ kipi-plugins/imageviewer/viewerwidget.cpp
|
||||
@@ -59,16 +59,16 @@ ViewerWidget::ViewerWidget(KIPI::Interfa
|
||||
file_idx=0; //index of picture to be displayed
|
||||
|
||||
if ( selection.images().count()==0 ) {
|
||||
- kdDebug(51000) << "no image selected, load entire album" << endl;
|
||||
+ kdDebug(51000) << "no image selected, load entire album" << ::endl;
|
||||
myfiles = album.images();
|
||||
}
|
||||
else if ( selection.images().count()==1 ) {
|
||||
- kdDebug(51000) << "one image selected, load entire album and start with selected image" << endl;
|
||||
+ kdDebug(51000) << "one image selected, load entire album and start with selected image" << ::endl;
|
||||
selectedImage = selection.images().first().path();
|
||||
myfiles = album.images();
|
||||
}
|
||||
else if ( selection.images().count()>1 ) {
|
||||
- kdDebug(51000) << "load " << selection.images().count() << " selected images" << endl;
|
||||
+ kdDebug(51000) << "load " << selection.images().count() << " selected images" << ::endl;
|
||||
myfiles = selection.images();
|
||||
}
|
||||
|
||||
@@ -79,7 +79,7 @@ ViewerWidget::ViewerWidget(KIPI::Interfa
|
||||
// in case one image was selected and the entire album was loaded
|
||||
QString s = (*it).path();
|
||||
if ( s==selectedImage ) {
|
||||
- kdDebug(51000) << "selected img " << selectedImage << " has idx=" << foundNumber << endl;
|
||||
+ kdDebug(51000) << "selected img " << selectedImage << " has idx=" << foundNumber << ::endl;
|
||||
file_idx=foundNumber;
|
||||
}
|
||||
|
||||
@@ -90,12 +90,12 @@ ViewerWidget::ViewerWidget(KIPI::Interfa
|
||||
if ( isImage ) {
|
||||
files.append(s);
|
||||
foundNumber++; //counter for searching the start image in case one image is selected
|
||||
- kdDebug(51000) << s << " type=" << type->name() << endl;
|
||||
+ kdDebug(51000) << s << " type=" << type->name() << ::endl;
|
||||
}
|
||||
}
|
||||
|
||||
firstImage=true;
|
||||
- kdDebug(51000) << files.count() << "images loaded" << endl;
|
||||
+ kdDebug(51000) << files.count() << "images loaded" << ::endl;
|
||||
|
||||
// initialize cache
|
||||
for(int i=0;i<CACHESIZE;i++) {
|
||||
@@ -220,7 +220,7 @@ void ViewerWidget::resizeGL(int w, int h
|
||||
*/
|
||||
void ViewerWidget::drawImage(Texture * texture)
|
||||
{
|
||||
-// cout << "enter drawImage: target=" << texture->texnr() << " dim=" << texture->height() << " " << texture->width() << endl;
|
||||
+// cout << "enter drawImage: target=" << texture->texnr() << " dim=" << texture->height() << " " << texture->width() << ::endl;
|
||||
glBindTexture(GL_TEXTURE_RECTANGLE_NV, texture->texnr());
|
||||
glBegin(GL_QUADS);
|
||||
glTexCoord2f(0, 0);
|
||||
@@ -418,13 +418,13 @@ Texture * ViewerWidget::loadImage(int fi
|
||||
|
||||
if (cache[imod].file_index==file_index){
|
||||
//image is already cached
|
||||
- kdDebug(51000) << "image " << file_index << " is already in cache@" << imod << endl;
|
||||
+ kdDebug(51000) << "image " << file_index << " is already in cache@" << imod << ::endl;
|
||||
return cache[imod].texture;
|
||||
|
||||
} else {
|
||||
// image is net yet loaded
|
||||
QString f = files[file_index];
|
||||
- kdDebug(51000) << "loading image " << f << "(idx=" << file_index << ") to cache@" << imod << endl;
|
||||
+ kdDebug(51000) << "loading image " << f << "(idx=" << file_index << ") to cache@" << imod << ::endl;
|
||||
cache[imod].file_index=file_index;
|
||||
|
||||
// handle non-loadable images
|
Loading…
Reference in a new issue