Fix least privileges support on recent (snv_140+) OpenSolaris versions.

Bump PKGREVISION
This commit is contained in:
fhajny 2011-05-09 11:11:11 +00:00
parent ed8a4217f4
commit e898a3f781
3 changed files with 18 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.9 2011/04/01 18:59:41 zafer Exp $
# $NetBSD: Makefile,v 1.10 2011/05/09 11:11:11 fhajny Exp $
#
DISTNAME= varnish-2.1.5
PKGREVISION= 1
CATEGORIES= www
MASTER_SITES= http://repo.varnish-cache.org/source/

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.7 2011/04/01 18:59:41 zafer Exp $
$NetBSD: distinfo,v 1.8 2011/05/09 11:11:11 fhajny Exp $
SHA1 (varnish-2.1.5.tar.gz) = 5c413ee7c4267d9fd4713fbff059d1be5fbba60f
RMD160 (varnish-2.1.5.tar.gz) = 4619d4be920504388325f06afdbea9b40f5a806a
Size (varnish-2.1.5.tar.gz) = 1530856 bytes
SHA1 (patch-aa) = d0bce82fc6bc0bb7e078f61461a21172bb658d4a
SHA1 (patch-ab) = 30a64ce77354df3f2e0e830f60f4c6d98ef3099c
SHA1 (patch-bin__varnishd__mgt_child.c) = f715b65a945147794b71c427c6067b6218392eb3

View file

@ -0,0 +1,14 @@
$NetBSD: patch-bin__varnishd__mgt_child.c,v 1.1 2011/05/09 11:11:11 fhajny Exp $
Patch varnishd to run on recent (snv_140+) versions of OpenSolaris.
See http://www.varnish-cache.org/trac/ticket/912
--- bin/varnishd/mgt_child.c.orig 2010-10-21 08:57:22.000000000 +0000
+++ bin/varnishd/mgt_child.c
@@ -298,6 +298,7 @@ waive_privileges(void)
/* new privilege, silently ignore any errors if it doesn't exist */
priv_addset(minimal, "net_access");
+ priv_addset(minimal, "file_read");
#define SETPPRIV(which, set) \
if (setppriv(PRIV_SET, which, set)) \