Update to 0.99.16, provided by Joerg Klemenz in PR 18937.

Changes:
Changes since B0.99-15
1. lib/edt.sl: Hard-coded escape sequences \e= and \e> were swapped.
   This affected the use of the application keypad on systems that did
   not have terminfo entries specifying these strings.
2. src/file.c: if write failed, report errno and num failed bytes.
3. src/screen.c: Unlock buffer files when exiting as a result of a
   fatal error.
4. lib/cmode.sl: c_indent_line would auto-insert // even when
   configured not to do so by the user.
5. lib/site.sl: Collapse multiple occurances of / characters in
   filenames that appear on the command line.
6. src/ledit.c: If a file to be loaded really a directory, then skip it.
7. src/*.c: use _SLvsnprintf instead of vprintf to
   avoid buffer overflows.  Also use safe_strcpy instead of strcpy.
8. src/sysdep.c: tweak to expand_filename to deal with very large
   filenames (much larger than OS permits).
9. lib/compress.sl: avoid using a regexp to get extname.
10. src/pty.c: tweaked for compiling with CYGWIN--- Requires slang
    1.4.5 if you intend to build a cygwin version.
11. src/main.c: If jed-script is symlinked to jed, then the result is
    equivalent to running jed with the -script option.  This is useful
    for using jed in an executable script, e.g.,

         #!/usr/bin/env jed-script
	 vmessage ("Script name: %s", __argv[0]);
	 quit_jed ();

    Also, if the script defines a function called "jedscript_main",
    then that function will get called after the file is loaded.

12. doc/rtl/keys.tm: get_key_binding documentation corrected by
    Guenter Milde
13. lib/filter.sl: filter_region function was not working.
14. src/menu.c: New function: menu_select_menu.  This enables a menu
    item to be executed from a function call, e.g.,

       menu_select_menu ("Global.W&indows.&Color Schemes");

    will popup the color-schemes menu.
15. src/ledit.c: bug-fix involving loading files such as xxx-1.0.sl
    when loaded as ()=evalfile("xxx-1.0").
16. src/colors.c: new intrinsics: get_color, add_color_object.  The
    idea behind these was conceived by Francesc Rocher.  A
    "custom_color" function analogous to "custom_variable" was also
    added.
17. src/wterm.c: patch from Paul Shirley
    to have ALT keys return scancodes instead of win32 virtual keycodes.
18. doc/tm/rtl/*.tm: Fixed synopsis lines and various other
    documentation improvments (Guenter Milde)
19. src/indent.c: New intrinsic: what_syntax_table returns the name of
    the current syntax table.
20. src/unix.c: fixed a problem in the filename expansion routines
    that affects older systems that do not have glob.h.
21. lib/site.sl: If Tab_Always_Insert_Tabs is non-zero, the pressing
    the tab key will cause a tab to be inserted.  The default value is
    0.
22. When objects (files or buffers) are loaded, they are given the
    full path name.  This means that the slang pseudo-variable
    __FILE__ will expand to the full pathname of the file being loaded.
23. lib/cmode.sl: treat formfeeds like whitespace
24. lib/comments.sl: Add support for java comments (Nathan Smith)
25. lib/os.sl: x_*_selection functions aliased to x_*_cutbuffer if
    undefined.  This permitted #ifdefs to be removed from lib/mouse.sl
    to avoid problems with mouse.sl byte-compiled with jed but used
    with xjed.
26. src/xterm.c: Handle selection events while waiting for keyboard
    input.  This allows, e.g., x_insert_selection to be bound to a key.
27. src/indent.c: Added support for a second string character to the
    syntax tables.  This improves the highlighting of, e.g., python
    code which uses two string characters.
28. lib/pymode.sl: minor cleanups.
29. src/wterm.c, w32cons.c: make NumLock return ESC O P when
    NUMLOCK_IS_GOLD is set.  Hopefully EDT emulation will now work
    properly on win32 systems.
30. src/menu.c: Ctrl-G causes abortion of menu mode.
31. src/wterm.c: drag/drop functionality for wjed ("John Skilleter")
32. lib/html.sl: updated to support euro, etc.  (Kees Serier)
33. src/win32.c:w32_pclose: add a work-around to what may be a Borland
    compiler bug. ("John Skilleter")
34. src/xterm.c: internal border width of the of xjed window is now
    configurable via -ib xjed option (Jim Clifton)
35. lib/krconv.sl: respect the value of C_BRA_NEWLINE
    (Ulrich Bernert)
36. src/buffer.c,ledit.c: If a file is read through a symbolic link,
    set the name of the buffer to the name of the symlink and not the
    actual file.  This is allows e.g., foo.c --> /dev/c/0013
    to be interpreted as a C file.
37. src/win32.c: differentiate between (shift|alt|ctrl)-backspace
    (John Skilleter)
38. src/cmisc.sl: Make c_end_of_function symmetric with
    c_top_of_function.  (Reuben Thomas)
39. src/wterm.c: fix problem with calculation of font-height for wjed.
    Also added new intrinsic for setting the font: w32_select_font
    (John Skilleter)
40. New internal hooks added: _jed_before_key_hooks, _jed_after_key_hooks
41. lib/wmark.sl: rewritten to use _jed_before/after_key hooks.  The
    result is that one is now able to use the regions with menu and
    minibuffer commands.
42. lib/popups.sl: Edit menu enhanced with more region functions.
    Register functions moved to region functions popup.
43. src/menu.c: disabled access to the menus from the minibuffer
44. lib/cmode.sl: added mode-specific menu entries to list all
    functions and macros defined by the file.  This affects C mode and
    SLang mode.
45. New intrinsics: exit, _exit.  These are useful in jed scripts to
    return an exit value to the shell.  exit is like exit_jed and
    _exit is like quit_jed except an argument is required.
46. lib/tmmode.sl: This file implements the tm_mode for editing
    text-macro files.  In addition, the text-macro processing code
    (textmac.sl) was removed from the jed distribution as well as
    lib/tm/*.  Instead, the text-macro processing code and macros will
    be made available as a separate package.
47. src/sig.c: Changed the way SIGHUP and SIGTERM are handled to avoid
    a possible race condition.
48. lib/latex.sl,ltx-math.sl: If another tex file was loaded while
    latex math mode was active, then latex_math_mode would cease to
    work in the first buffer.  This has been fixed.
49. lib/perl.sl: Updated to Mark Olesen's latest version.  See
    lib/perl.sl for details.
50. lib/sccs.sl: New file supporting SCCS revision control (Philip
    Brown).
51. src/intrin.c: New intrinsic function: run_program.  This plays the
    same role as the "system" function except jed resets the display
    first, if run in a terminal.  For X, it runs the specified program
    in another xterm, or the terminal set by the XTerm_Pgm variable.

    *** Note: This function needs to be fixed to work asynchronously
              on win32.  Any volunteers??

52. src/xterm.c: Added Charl Botha's XRENDER patch to Xjed.
53. lib/ide.sl: Remove references to ide_function_help (Guido Gonzato).
54. lib/site.sl: save_buffer was not calling read_file_from_mini
    without a prompt string <klaus.schmid at kdt.de>
55. doc/tm/*.tm: removed docs for obsolete functions <klaus.schmid at kdt.de>
56. lib/mouse.sl: wheel mouse was not ignoring hidden lines
     <klaus.schmid at kdt.de>
57. lib/f90.sl: Merged fix and free formats into the same file.  In
    addition to f90_mode, there is now f90_fixed_format_mode and
    f90_free_format_mode.  The default format for f90_mode is "free",
    which may be set via the F90_Default_Format variable.
58. lib/registers.sl: rewritten to allow registers to be given
    meaningful names by the user.  Also, fixed limit of 95 registers
    removed.
59. lib/folding.sl: Fixed endless loop during a call to
    fold_whole_buffer when a fold-start mark is at the end of the
    buffer.  Several other tweaks aimed at preserving the current
    position when closing folds (klaus.schmid at kdt.de)
60. lib/edt.sl: multiple definition of exit corrected
      (joukj at hrem.stm.tudelft.nl (Jacob (=Jouk) Jansen))
61. lib/search.sl,isearch.sl: If the search string contains any upper case
    characters then a case-sensitive search will be performed.
62. src/mkfiles/makefile.all: Add CFLAGS macro to MINGW32/CYGWIN32
    section. Miquel Garriga <miquel at icmab.es>
63. src/screen.c: Make the [EOB] line read-only. Miquel Garriga <miquel at icmab.es>
64. src/version.c: Use __MINGW32_VERSION if defined to get the
    compiler version. Miquel Garriga <miquel at icmab.es>
65. lib/os.sl: make sure W32shell_Perform_Globbing is declared. Miquel Garriga <miquel at icmab.es>
66. lib/cal.sl: avoid interpretation of 08 in dates as octal. Miquel Garriga <miquel at icmab.es>
67. src/screen.c: %F may be used to specify complete pathname on the
    mode-line. (John Skilleter).
68. doc/tm/keys.tm: get_key_binding documentation corrected. (Klaus
    Schmid <klaus.schmid at kdt.de>)
69. src/mkfiles/makefile.all: Make sure CFLAGS defines JED. Also add
    support for creating wjed in cygwin environment (Paul
    Shirley).
70. New intrinsic: expand_symlink expands symbolic links
This commit is contained in:
wiz 2003-04-05 20:29:40 +00:00
parent 6265d3d9ab
commit e8a1dfdb6c
5 changed files with 54 additions and 78 deletions

View file

@ -1,7 +1,18 @@
===========================================================================
$NetBSD: MESSAGE,v 1.2 2002/09/24 12:29:57 wiz Exp $
$NetBSD: MESSAGE,v 1.3 2003/04/05 20:29:40 wiz Exp $
You might want to have a look at ${PREFIX}/share/jed/lib/* and
install a file defaults.sl for site defaults there.
Optional but highly recommended: preparse the S-Lang files. This
is done by running JED as:
# (cd ${PREFIX}/share/jed/lib; jed -batch -n -l preparse.sl)
This creates pre-parsed *.slc files that load quicker than *.sl
files. Note that the bytecodes that are stored in the preparsed
files (*.slc) may depend upon the version of the slang library that
was used. This is particularly relevant if jed is dynamically
linked to the slang library and for some reason you upgrade the
library. If you do this, then immediately after installing a new
version of the slang library, run the command 'touch *.sl' on all
the .sl files in the ${PREFIX}/share/jed/lib/lib directory.
===========================================================================

View file

@ -1,29 +1,33 @@
# $NetBSD: Makefile,v 1.20 2003/03/29 12:40:42 jmmv Exp $
# $NetBSD: Makefile,v 1.21 2003/04/05 20:29:41 wiz Exp $
#
DISTNAME= jed-B0.99-15
PKGNAME= jed-0.99.15
WRKSRC= ${WRKDIR}/jed-B0.99-15
DISTNAME= jed-0.99-16
PKGNAME= jed-0.99.16
CATEGORIES= editors
MASTER_SITES= ftp://space.mit.edu/pub/davis/jed/v0.99/ \
ftp://ftp.uni-stuttgart.de/pub/unix/misc/slang/jed/
MASTER_SITES= ftp://ftp.jedsoft.org/pub/davis/jed/v0.99/ \
ftp://ftp.fu-berlin.de/pub/unix/editors/jed/v0.99/ \
ftp://ftp.ntua.gr/pub/lang/slang/jed/v0.99/ \
ftp://ftp.bay.net.au/pub/jed/v0.99/ \
ftp://ftp.uni-stuttgart.de/pub/unix/misc/slang/jed/v0.99/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://space.mit.edu/~davis/jed.html
COMMENT= Text editor with many features, extensible through S-Lang functions
MAINTAINER= joerg@gmx.net
HOMEPAGE= http://www.jedsoft.org/jed/
COMMENT= Extensible folding editor with Emacs/WordStar/EDT emulations
USE_BUILDLINK2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --without-X
post-install:
@cd ${WRKSRC}; \
for dir in lib info doc; do \
${ECHO} "Installing $$dir files"; \
${PAX} -rwpe $$dir ${PREFIX}/share/jed; \
done
${RM} -f ${PREFIX}/share/jed/doc/jed.1 ${PREFIX}/share/jed/doc/rgrep.1
${RMDIR} ${PREFIX}/share/jed/bin
EGDIR= ${PREFIX}/share/examples/jed
CONF_FILES= ${EGDIR}/jed.conf ${PREFIX}/etc/jed.conf
post-install:
${RMDIR} ${PREFIX}/share/jed/bin
${RMDIR} ${PREFIX}/share/jed/lib/tm
${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/lib/jed.conf ${EGDIR}
.include "../../mk/bsd.pkg.install.mk"
.include "../../devel/libslang/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,45 +1,12 @@
@comment $NetBSD: PLIST,v 1.1 2001/10/31 21:22:53 zuntum Exp $
@comment $NetBSD: PLIST,v 1.2 2003/04/05 20:29:41 wiz Exp $
bin/jed
bin/jed-script
bin/rgrep
man/man1/jed.1
man/man1/rgrep.1
share/examples/jed/jed.conf
share/jed/doc/README
share/jed/doc/manual/jed.1
share/jed/doc/manual/jed.tex
share/jed/doc/manual/rgrep.1
share/jed/doc/tm/Makefile
share/jed/doc/tm/README
share/jed/doc/tm/jedfuns.tm
share/jed/doc/tm/quickref.tm
share/jed/doc/tm/rtl/abbrev.tm
share/jed/doc/tm/rtl/blocal.tm
share/jed/doc/tm/rtl/buffer.tm
share/jed/doc/tm/rtl/color.tm
share/jed/doc/tm/rtl/eval.tm
share/jed/doc/tm/rtl/file.tm
share/jed/doc/tm/rtl/hidden.tm
share/jed/doc/tm/rtl/hooks.tm
share/jed/doc/tm/rtl/info.tm
share/jed/doc/tm/rtl/insdel.tm
share/jed/doc/tm/rtl/keys.tm
share/jed/doc/tm/rtl/mark.tm
share/jed/doc/tm/rtl/menu.tm
share/jed/doc/tm/rtl/message.tm
share/jed/doc/tm/rtl/mini.tm
share/jed/doc/tm/rtl/misc.tm
share/jed/doc/tm/rtl/mouse.tm
share/jed/doc/tm/rtl/move.tm
share/jed/doc/tm/rtl/process.tm
share/jed/doc/tm/rtl/rect.tm
share/jed/doc/tm/rtl/region.tm
share/jed/doc/tm/rtl/search.tm
share/jed/doc/tm/rtl/syntax.tm
share/jed/doc/tm/rtl/terminal.tm
share/jed/doc/tm/rtl/tm-sort.sl
share/jed/doc/tm/rtl/userinfo.tm
share/jed/doc/tm/rtl/whatelse.sl
share/jed/doc/tm/rtl/window.tm
share/jed/doc/tm/rtl/xjed.tm
share/jed/doc/txt/abbrev.txt
share/jed/doc/txt/color.txt
share/jed/doc/txt/compile.txt
@ -66,6 +33,7 @@ share/jed/doc/txt/undo.txt
share/jed/doc/txt/wjed.txt
share/jed/doc/txt/wordstar.txt
share/jed/doc/txt/xjed.txt
share/jed/doc/txt/xrenderfont.txt
share/jed/doc/txt/yankpop.txt
share/jed/info/dir.info
share/jed/info/info.info
@ -73,7 +41,6 @@ share/jed/info/jed.1in
share/jed/info/jed.2in
share/jed/info/jed.3in
share/jed/info/jed.info
share/jed/lib/README
share/jed/lib/abbrev.sl
share/jed/lib/abbrmisc.sl
share/jed/lib/aboutjed.hlp
@ -145,7 +112,6 @@ share/jed/lib/iso-latin.sl
share/jed/lib/iso2xxx.sl
share/jed/lib/ispell.sl
share/jed/lib/javamode.sl
share/jed/lib/jed.conf
share/jed/lib/jed.hlp
share/jed/lib/jed.rc
share/jed/lib/jed.sl
@ -172,8 +138,6 @@ share/jed/lib/mime.sl
share/jed/lib/mini.sl
share/jed/lib/minued.sl
share/jed/lib/misc.sl
share/jed/lib/mkdoc.sl
share/jed/lib/mktex.sl
share/jed/lib/modehook.sl
share/jed/lib/modeinfo.sl
share/jed/lib/most.sl
@ -199,6 +163,8 @@ share/jed/lib/register.sl
share/jed/lib/replace.sl
share/jed/lib/rmail.sl
share/jed/lib/rot13.sl
share/jed/lib/runpgm.sl
share/jed/lib/sccs.sl
share/jed/lib/search.sl
share/jed/lib/seldisp.sl
share/jed/lib/sendmail.sl
@ -216,18 +182,15 @@ share/jed/lib/tabs.sl
share/jed/lib/tclmode.sl
share/jed/lib/tex.sl
share/jed/lib/texcom.sl
share/jed/lib/textmac.sl
share/jed/lib/textmode.sl
share/jed/lib/tiasm.sl
share/jed/lib/tm/linuxdoc.tm
share/jed/lib/tm2sgml.sl
share/jed/lib/tmisc.sl
share/jed/lib/tmmode.sl
share/jed/lib/tpascal.sl
share/jed/lib/untab.sl
share/jed/lib/util.sl
share/jed/lib/verilog.sl
share/jed/lib/vhdlmode.sl
share/jed/lib/vms_shell.com
share/jed/lib/vmshelp.sl
share/jed/lib/win1250.sl
share/jed/lib/wmark.sl
@ -235,14 +198,12 @@ share/jed/lib/wmenu.sl
share/jed/lib/wordstar.hlp
share/jed/lib/wordstar.sl
share/jed/lib/yankpop.sl
@dirrm share/jed/lib/tm
@dirrm share/jed/lib/colors/Xjed
@dirrm share/jed/lib/colors/
@dirrm share/jed/lib/colors
@dirrm share/jed/lib
@dirrm share/jed/doc/txt
@dirrm share/jed/doc/tm/rtl
@dirrm share/jed/doc/tm
@dirrm share/jed/doc/manual
@dirrm share/jed/doc
@dirrm share/jed/info
@dirrm share/jed
@dirrm share/examples/jed

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.6 2002/03/14 17:43:41 wiz Exp $
$NetBSD: distinfo,v 1.7 2003/04/05 20:29:41 wiz Exp $
SHA1 (jed-B0.99-15.tar.gz) = dfcb1b5ea0330666e919a83a3ebf01b4444d2e07
Size (jed-B0.99-15.tar.gz) = 833835 bytes
SHA1 (patch-ab) = 41bd984d5fdc26b0c7652981df9ed187b9c9ae27
SHA1 (jed-0.99-16.tar.bz2) = 34649571fb5caa61314553c10db2e15ebf248d82
Size (jed-0.99-16.tar.bz2) = 667623 bytes
SHA1 (patch-ab) = 38c8708fbfff84afa67aeb8691bdbd021156ab82

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ab,v 1.6 2001/10/25 19:29:13 agc Exp $
$NetBSD: patch-ab,v 1.7 2003/04/05 20:29:41 wiz Exp $
--- src/Makefile.in.orig Sun Oct 7 23:48:16 2001
+++ src/Makefile.in Tue Oct 9 09:16:12 2001
--- src/Makefile.in.orig Sun Oct 20 08:55:30 2002
+++ src/Makefile.in
@@ -13,8 +13,7 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
@ -12,7 +12,7 @@ $NetBSD: patch-ab,v 1.6 2001/10/25 19:29:13 agc Exp $
BIN_DIR = @bindir@
MAN_DIR = @mandir@/man1
INSTALL = @INSTALL@
@@ -154,7 +153,7 @@
@@ -158,7 +157,7 @@
rgrep: $(OBJDIR)/rgrep
@echo rgrep created in $(OBJDIR)
$(OBJDIR)/rgrep: $(OBJDIR)/vfile.o $(OBJDIR)/rgrep.o
@ -21,10 +21,10 @@ $NetBSD: patch-ab,v 1.6 2001/10/25 19:29:13 agc Exp $
#
getmail: $(OBJDIR)/getmail
@echo getmail created in $(OBJDIR)
@@ -186,7 +185,6 @@
@@ -191,7 +190,6 @@
install: all install_directories
$(INSTALL) $(OBJDIR)/jed $(DEST_BIN_DIR)/
-cd $(DEST_BIN_DIR); ln -sf jed jed-script
- -$(INSTALL) $(OBJDIR)/xjed $(DEST_BIN_DIR)/
-$(INSTALL) $(OBJDIR)/rgrep $(DEST_BIN_DIR)/
-$(INSTALL) $(OBJDIR)/getmail $(DEST_JED_ROOT)/bin/