Update to 3.20150613:

Highlights include:
* Travis continuous integration
* Better lua autodetection (thanks to Nikolay Orlyuk)
* Various code consistency changes
* Fixing p2 variable scopes in xkbevents handler (thanks to Jon Canning)
* Fixing resizing of dock windows managed by mod_statusbar (thanks
to Edward J. Schwartz)
This commit is contained in:
wiz 2015-06-14 21:02:46 +00:00
parent 086f2dd007
commit e8a2250a89
3 changed files with 37 additions and 24 deletions

View file

@ -1,11 +1,10 @@
# $NetBSD: Makefile,v 1.20 2014/10/19 22:27:48 alnsn Exp $
# $NetBSD: Makefile,v 1.21 2015/06/14 21:02:46 wiz Exp $
DISTNAME= notion-3-2014052800-src
PKGNAME= ${DISTNAME:S/3-/3./:S/-src//}
PKGREVISION= 2
DISTNAME= notion-3-2015061300
PKGNAME= ${DISTNAME:S/3-/3./}
CATEGORIES= wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=notion/}
EXTRACT_SUFX= .tar.bz2
MASTER_SITES= ${MASTER_SITE_GITHUB:=raboof/}
GITHUB_TAG= ${DISTNAME:S/notion-//}
MAINTAINER= wiz@NetBSD.org
HOMEPAGE= http://notion.sourceforge.net/
@ -19,6 +18,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
USE_LANGUAGES= c99
USE_TOOLS+= gmake msgfmt pax pkg-config
LUA_VERSIONS_INCOMPATIBLE= 53
MAKE_FLAGS+= PREFIX=${PREFIX}
MAKE_FLAGS+= EXAMPLEDIR=${PREFIX}/share/examples/notion
MAKE_FLAGS+= MANDIR=${PREFIX}/${PKGMANDIR}

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.9 2014/07/26 19:58:38 wiz Exp $
$NetBSD: distinfo,v 1.10 2015/06/14 21:02:46 wiz Exp $
SHA1 (notion-3-2014052800-src.tar.bz2) = 83b068fe810fefa4f50caa6a3a6350c1b332e806
RMD160 (notion-3-2014052800-src.tar.bz2) = 22d3b32f593aab24bfedb5f1e8ec1b5e6317779c
Size (notion-3-2014052800-src.tar.bz2) = 622504 bytes
SHA1 (patch-build_lua-detect.mk) = b641edda62f54c465a744814b8dd026d617735d5
SHA1 (notion-3-2015061300.tar.gz) = 66962dcb6462bf9f2c621530ac845716fafe6a98
RMD160 (notion-3-2015061300.tar.gz) = 7a894c523b39cc7c20f85779187c95480e5eac8f
Size (notion-3-2015061300.tar.gz) = 797057 bytes
SHA1 (patch-build_lua-detect.mk) = e0de2ef82151a5a0cfb3709116667ef6c5362f2e
SHA1 (patch-build_rules.mk) = f8321cea75a1dfb6187ce5229f85cfea7dc5c9a7
SHA1 (patch-libtu_output.c) = e9e9e77f0c1ff196fefa887a51f647f0dee7df89
SHA1 (patch-mod__xrandr_Makefile) = 9299bebbd6a1f043a4095abfa19c917e4229456f

View file

@ -1,16 +1,28 @@
$NetBSD: patch-build_lua-detect.mk,v 1.1 2014/07/26 19:58:38 wiz Exp $
$NetBSD: patch-build_lua-detect.mk,v 1.2 2015/06/14 21:02:46 wiz Exp $
Fix lua detection for pkgsrc.
--- build/lua-detect.mk.orig 2014-05-27 22:00:18.000000000 +0000
--- build/lua-detect.mk.orig 2015-06-13 14:37:26.000000000 +0000
+++ build/lua-detect.mk
@@ -27,7 +27,7 @@ ifeq ($(LUA_VERSION),5.0)
LUA_VERSION=
endif
@@ -15,20 +15,12 @@
-LUA_LIBS := $(or $(shell pkg-config --libs lua$(LUA_VERSION)), $(error "pkg-config couldn't find linker flags for lua$(LUA_VERSION)!"))
-LUA_INCLUDES := $(shell pkg-config --cflags lua$(LUA_VERSION))
+LUA_LIBS := $(or $(shell pkg-config --libs lua), $(error "pkg-config couldn't find linker flags for lua!"))
+LUA_INCLUDES := $(shell pkg-config --cflags lua)
LUA := $(or $(shell which lua$(LUA_VERSION)), $(error No lua$(LUA_VERSION) interpreter found!))
LUAC := $(or $(shell which luac$(LUA_VERSION)), $(error No lua$(LUA_VERSION) compiler found!))
LUA_VERSIONS_CANDIDATES = $(or $(LUA_VERSION),5.2 5.1 5.0)
-LUA_PKG := $(firstword $(foreach ver,$(LUA_VERSIONS_CANDIDATES),$(shell \
- ($(PKG_CONFIG) --exists lua-$(ver) && echo lua-$(ver)) \
- || ($(PKG_CONFIG) --exists lua$(ver:5.0=) && echo lua$(ver:5.0=)))))
-
-ifeq ($(LUA_PKG),)
- $(error Could not find $(or $(LUA_VERSION),any) lua version. (Did you install the -dev package?))
-endif
-
LUA_VERSION ?= $(or $(shell $(PKG_CONFIG) --variable=V $(LUA_PKG)),5.0)
# prior to 5.1 the lib didn't include version in name.
-LUA_SUFFIX := $(if $(findstring $(LUA_VERSION),5.0),,$(LUA_VERSION))
+LUA_SUFFIX :=
-LUA_LIBS := $(or $(shell $(PKG_CONFIG) --libs $(LUA_PKG)), $(error "pkg-config couldn't find linker flags for lua$(LUA_SUFFIX)!"))
-LUA_INCLUDES := $(shell $(PKG_CONFIG) --cflags $(LUA_PKG))
+LUA_LIBS := $(or $(shell $(PKG_CONFIG) --libs lua), $(error "pkg-config couldn't find linker flags for lua!"))
+LUA_INCLUDES := $(shell $(PKG_CONFIG) --cflags lua)
LUA := $(or $(shell which lua$(LUA_SUFFIX)), $(shell which lua), $(error No lua$(LUA_SUFFIX) interpreter found!))
LUAC := $(or $(shell which luac$(LUA_SUFFIX)), $(shell which luac), $(error No lua$(LUA_SUFFIX) compiler found!))