devilutionx: Update to 1.0.1

## DevilutionX 1.0.1
### Features
- Toggle fullscreen at any point by hitting alt+enter (mouse grab can be disabled in diablo.ini)
- Controller: B button closes the currently active panel.
- Added a navigation menu for controllers
- Focus on the exit item before quitting.
- Minor performance improvements (save/load time and main menu).
- Add a list of [known mods](https://github.com/diasurgical/devilutionX/blob/master/docs/mods.md)

### Platforms
- Added support for 32bit PowerPc
- Added support for Amiga
- Added support Clockwork PI GameShell
- Added support for GKD350h
- Switch to OPK for RetroFW (requires 2.0)
- Update OpendDingus/RetroFW build root

### Bugfixes
- Game crashing on systems that do not report monitor refresh rate.
- Fixed belt not working correctly when holding shift on us keyboard layouts
- Always keep track of the latest hero level when selecting difficulty.
- Correct screenshot path
- Turn the screen red for 200ms when taking screenshots.
- Fix town load screen missing on the first load.
- Fix minor HOM issue at some houses in town.
- Allow for space as text input
- Fixed a couple of typos in error messages

### Original Diablo bugs
- Fix belt not working correctly when holding shift on *non-*us keyboard layouts
- Fix one more rare crash.
This commit is contained in:
nia 2020-03-09 10:53:22 +00:00
parent 222ace775a
commit e8babfb3bd
3 changed files with 15 additions and 27 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.10 2020/03/08 16:49:35 wiz Exp $
# $NetBSD: Makefile,v 1.11 2020/03/09 10:53:22 nia Exp $
DISTNAME= devilutionx-1.0.0
PKGREVISION= 1
DISTNAME= devilutionx-1.0.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GITHUB:=diasurgical/}
GITHUB_PROJECT= devilutionX
@ -15,11 +14,14 @@ WRKSRC= ${WRKDIR}/${GITHUB_PROJECT}-${PKGVERSION_NOREV}
USE_CMAKE= yes
USE_TOOLS+= pkg-config
USE_LANGUAGES= c99 c++14
USE_LANGUAGES= c c++14
# std::make_unique, etc
GCC_REQD+= 5
CONFIGURE_DIRS= build
CMAKE_ARG_PATH= ..
CMAKE_ARGS+= -DCMAKE_BUILD_TYPE="Release"
CMAKE_ARGS+= -DASAN=OFF
CMAKE_ARGS+= -DDEBUG=OFF
@ -31,8 +33,6 @@ CMAKE_ARGS+= -DFASTER=OFF
CXXFLAGS+= -DO_LARGEFILE=0 -Dstat64=stat -Dlstat64=lstat -Dlseek64=lseek -Doff64_t=off_t -Dfstat64=fstat -Dftruncate64=ftruncate
.endif
CXXFLAGS+= -DASIO_DISABLE_STD_EXPERIMENTAL_STRING_VIEW=1
# /usr/include/g++/cstdio:176:11: error: '::vfscanf' has not been declared
# No idea.
CXXFLAGS.NetBSD+= -D_NETBSD_SOURCE
@ -43,8 +43,11 @@ INSTALLATION_DIRS+= share/icons/hicolor/16x16/apps
INSTALLATION_DIRS+= share/icons/hicolor/32x32/apps
INSTALLATION_DIRS+= share/icons/hicolor/48x48/apps
pre-configure:
${MKDIR} -p ${WRKSRC}/build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/devilutionx ${DESTDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/build/devilutionx ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${FILESDIR}/devilutionx.desktop \
${DESTDIR}${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/Packaging/resources/16.png \

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.6 2020/01/04 12:14:40 nia Exp $
$NetBSD: distinfo,v 1.7 2020/03/09 10:53:22 nia Exp $
SHA1 (devilutionx-1.0.0.tar.gz) = 308bc35e2e8e72cf3d1cb98f35117fc8801a66e7
RMD160 (devilutionx-1.0.0.tar.gz) = 8900b580917a08beae3adbab2b4a01e05f568d85
SHA512 (devilutionx-1.0.0.tar.gz) = 65eed32e03051880e2e859984911a76c6aae1853cb57491a04090026d6df9cdadf839a0dbb5433691ed1c83cfa7403c72fede38890d494ffd4eff6bef9030c37
Size (devilutionx-1.0.0.tar.gz) = 1798349 bytes
SHA1 (patch-3rdParty_StormLib_src_StormPort.h) = a59ea9c29a86067b908aab7e8d3e344711407e0a
SHA1 (devilutionx-1.0.1.tar.gz) = 891c1b2d1956e8d7cef14d486e99f448c98a6694
RMD160 (devilutionx-1.0.1.tar.gz) = 07bb1f4afef0a354b717add0afb0528689258868
SHA512 (devilutionx-1.0.1.tar.gz) = 8c08db37664f4d9971650675866671411fe0fc00fedf4d2b2db040d48fc07e36def3bd78fa892c2be012d46df9519f28a31fe0b3e14f46e1037476458f60cb6d
Size (devilutionx-1.0.1.tar.gz) = 2005920 bytes

View file

@ -1,14 +0,0 @@
$NetBSD: patch-3rdParty_StormLib_src_StormPort.h,v 1.1 2019/10/16 12:00:51 nia Exp $
strings.h for strncasecmp.
--- 3rdParty/StormLib/src/StormPort.h.orig 2019-10-09 22:34:02.000000000 +0000
+++ 3rdParty/StormLib/src/StormPort.h
@@ -162,6 +162,7 @@
#include <stdio.h>
#include <stdarg.h>
#include <string.h>
+ #include <strings.h>
#include <ctype.h>
#include <assert.h>
#include <errno.h>