Update to 4.3.1nb3: add patch sent in from Mishka in private mail,
closing pkg/17833. Fixes Strcasestr, and improves diagnostic message.
This commit is contained in:
parent
27cae62d46
commit
e8eff0b5b1
3 changed files with 43 additions and 3 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.15 2002/05/14 08:38:23 abs Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2002/08/08 17:48:59 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= nocol-4.3.1
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.netplex-tech.com/software/nocol/downloads/
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.5 2002/06/28 08:42:34 agc Exp $
|
||||
$NetBSD: distinfo,v 1.6 2002/08/08 17:48:59 wiz Exp $
|
||||
|
||||
SHA1 (nocol-4.3.1.tar.gz) = a8cb88727bc3a3ddd544792407d431b3ef13a325
|
||||
Size (nocol-4.3.1.tar.gz) = 1117438 bytes
|
||||
|
@ -13,3 +13,4 @@ SHA1 (patch-ah) = 14091c7a6c8de7dd451e4292f2d0121ab3643158
|
|||
SHA1 (patch-ai) = d8317fad7c5e4574fa980859762f5acb1a7c631d
|
||||
SHA1 (patch-aj) = 0eb201f47864132b04702fab4d03e452c07c2e2a
|
||||
SHA1 (patch-ak) = 8013fbe6dbff80749dbdc0d0fad391741e48a468
|
||||
SHA1 (patch-al) = aa4fa83d53c72e17ea9ffe2685f326ebbbde9132
|
||||
|
|
39
net/nocol/patches/patch-al
Normal file
39
net/nocol/patches/patch-al
Normal file
|
@ -0,0 +1,39 @@
|
|||
$NetBSD: patch-al,v 1.1 2002/08/08 17:49:00 wiz Exp $
|
||||
|
||||
--- portmon/portmon.c.orig Thu Apr 6 21:32:26 2000
|
||||
+++ portmon/portmon.c
|
||||
@@ -180,7 +180,7 @@ main(ac, av)
|
||||
else
|
||||
{
|
||||
update_event(&v, harray[i]->status,
|
||||
- /* value */ (u_long)(harray[i]->status),
|
||||
+ /* value */ (u_long)(harray[i]->elapsedsecs),
|
||||
harray[i]->testseverity) ;
|
||||
lseek(fdout, -(off_t)sizeof(v), SEEK_CUR);
|
||||
write(fdout, (char *)&v, sizeof(v));
|
||||
@@ -658,16 +658,21 @@ static char *Strcasestr(haystack, needle
|
||||
s1 = haystack; s2 = needle; n = needlelen;
|
||||
do
|
||||
{
|
||||
- if (tolower(*s1) != tolower(*s2++) || *s1 == 0) /* */
|
||||
+ if (*s1 == 0 || tolower(*s1) != tolower(*s2++)) /* */
|
||||
break;
|
||||
++s1;
|
||||
} while (--n != 0);
|
||||
|
||||
- if (n == 0 || *s1 == 0)
|
||||
- break; /* found, break out of forever loop */
|
||||
+ if (n == 0) {
|
||||
+ --haystack;
|
||||
+ break; /* found, break out of forever loop */
|
||||
+ }
|
||||
+ if (*s1 == 0) {
|
||||
+ haystack = NULL;
|
||||
+ break; /* not found, break out of forever loop */
|
||||
+ }
|
||||
|
||||
} /* end for */
|
||||
- haystack--;
|
||||
return ((char *)haystack);
|
||||
} /* Strcasestr() */
|
||||
|
Loading…
Reference in a new issue