Initial import of mini_httpd-1.19. This was packaged by

Bruce J.A. Nourish for pkgsrc-wip.

mini_httpd is a small HTTP server.  Its performance is not great, but for
low or medium traffic sites it's quite adequate. It implements all the
basic features of an HTTP server, including:

  * GET, HEAD, and POST methods.
  * CGI.
  * Basic authentication.
  * Security against ".." filename snooping.
  * The common MIME types.
  * Trailing-slash redirection.
  * index.html, index.htm, index.cgi
  * Directory listings.
  * Multihoming / virtual hosting.
  * Standard logging.
  * Custom error pages.

It can also be configured to do SSL/HTTPS and IPv6.
This commit is contained in:
reed 2004-02-03 16:18:54 +00:00
parent c075a736a6
commit e8fbe7c632
5 changed files with 84 additions and 0 deletions

17
www/mini_httpd/DESCR Normal file
View file

@ -0,0 +1,17 @@
mini_httpd is a small HTTP server. Its performance is not great, but for
low or medium traffic sites it's quite adequate. It implements all the
basic features of an HTTP server, including:
* GET, HEAD, and POST methods.
* CGI.
* Basic authentication.
* Security against ".." filename snooping.
* The common MIME types.
* Trailing-slash redirection.
* index.html, index.htm, index.cgi
* Directory listings.
* Multihoming / virtual hosting.
* Standard logging.
* Custom error pages.
It can also be configured to do SSL/HTTPS and IPv6.

28
www/mini_httpd/Makefile Normal file
View file

@ -0,0 +1,28 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/02/03 16:18:54 reed Exp $
DISTNAME= mini_httpd-1.19
CATEGORIES= www
MASTER_SITES= http://www.acme.com/software/mini_httpd/
MAINTAINER= pkgsrc@bjan.freeshell.org
HOMEPAGE= http://www.acme.com/software/mini_httpd/
COMMENT= Small, forking webserver with IPv6 and SSL support
USE_BUILDLINK2= yes
MAKE_ENV+= PKG_CFLAGS="${CFLAGS}"
LDFLAGS+= -lssl -lcrypto -lcrypt -lutil
do-install:
for FILE in mini_httpd.8 htpasswd.1; do \
${MV} -f ${WRKSRC}/$${FILE} ${WRKSRC}/$${FILE}.bak; \
${SED} -e 's/\([^.]\)htpasswd/\1mhtpasswd/g' \
-e 's/^htpasswd/m&/' \
${WRKSRC}/$${FILE}.bak > ${WRKSRC}/$${FILE}; \
done
${INSTALL_PROGRAM} ${WRKSRC}/mini_httpd ${PREFIX}/sbin/
${INSTALL_PROGRAM} ${WRKSRC}/htpasswd ${PREFIX}/sbin/mhtpasswd
${INSTALL_MAN} ${WRKSRC}/mini_httpd.8 ${PREFIX}/man/man8/
${INSTALL_MAN} ${WRKSRC}/htpasswd.1 ${PREFIX}/man/man1/mhtpasswd.1
.include "../../security/openssl/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

5
www/mini_httpd/PLIST Normal file
View file

@ -0,0 +1,5 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/02/03 16:18:54 reed Exp $
man/man1/mhtpasswd.1
man/man8/mini_httpd.8
sbin/mhtpasswd
sbin/mini_httpd

5
www/mini_httpd/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/02/03 16:18:54 reed Exp $
SHA1 (mini_httpd-1.19.tar.gz) = da1ce9cf717f16aea69a75d3a77e610e9a740cc7
Size (mini_httpd-1.19.tar.gz) = 42142 bytes
SHA1 (patch-aa) = 3e30a58fa50283a5b9fe3d272ae312f825a4c8ec

View file

@ -0,0 +1,29 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/02/03 16:18:55 reed Exp $
--- Makefile.orig 2002-11-01 16:02:57.000000000 -0700
+++ Makefile
@@ -15,20 +15,15 @@ CRYPT_LIB = -lcrypt
# tree with your OpenSSL installation - depending on how you installed it,
# it may be in /usr/local instead of /usr/local/ssl.
#SSL_TREE = /usr/local/ssl
-#SSL_DEFS = -DUSE_SSL
+SSL_DEFS = -DUSE_SSL
#SSL_INC = -I${SSL_TREE}/include
#SSL_LIBS = -L${SSL_TREE}/lib -lssl -lcrypto
-BINDIR = /usr/local/sbin
-MANDIR = /usr/local/man
-CC = gcc
+BINDIR = ${PREFIX}/sbin
+MANDIR = ${PREFIX}/man
CDEFS = ${SSL_DEFS} ${SSL_INC}
-CFLAGS = -O ${CDEFS}
-#CFLAGS = -g ${CDEFS}
-LDFLAGS = -s
-#LDFLAGS = -g
-LDLIBS = ${SSL_LIBS} ${SYSV_LIBS} ${CRYPT_LIB}
+CFLAGS = ${PKG_CFLAGS} ${CDEFS}
all: mini_httpd htpasswd