Fix inline usage
This commit is contained in:
parent
fbefc3d38a
commit
e911b0b620
3 changed files with 29 additions and 1 deletions
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.7 2005/02/23 23:12:00 agc Exp $
|
||||
$NetBSD: distinfo,v 1.8 2012/07/03 18:41:20 joerg Exp $
|
||||
|
||||
SHA1 (lincity-1.12.1.tar.gz) = 280375273f6e741d707dc8e11fdedb160d230c95
|
||||
RMD160 (lincity-1.12.1.tar.gz) = 5b0a3bfa77372577ac3d9cc42e6a806f27a52ef3
|
||||
Size (lincity-1.12.1.tar.gz) = 795709 bytes
|
||||
SHA1 (patch-pixmap.c) = 6d9064ba0d427ddd78d1b304748d47b7d8a168d7
|
||||
SHA1 (patch-pixmap.h) = 44fc362939408a206dd47a514c070f235a15db02
|
||||
|
|
13
games/lincity/patches/patch-pixmap.c
Normal file
13
games/lincity/patches/patch-pixmap.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-pixmap.c,v 1.1 2012/07/03 18:41:20 joerg Exp $
|
||||
|
||||
--- pixmap.c.orig 2012-07-03 15:36:45.000000000 +0000
|
||||
+++ pixmap.c
|
||||
@@ -390,7 +390,7 @@ resize_pixmap (int new_width, int new_he
|
||||
likes it in the file. Still need to fix this in autoconf,
|
||||
but for now this will do. */
|
||||
#if !defined (WIN32)
|
||||
-inline int
|
||||
+int
|
||||
pixmap_index (int x, int y)
|
||||
{
|
||||
return y*pixmap_width + x;
|
13
games/lincity/patches/patch-pixmap.h
Normal file
13
games/lincity/patches/patch-pixmap.h
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-pixmap.h,v 1.1 2012/07/03 18:41:20 joerg Exp $
|
||||
|
||||
--- pixmap.h.orig 2012-07-03 15:36:29.000000000 +0000
|
||||
+++ pixmap.h
|
||||
@@ -19,7 +19,7 @@ extern int pixmap_width;
|
||||
void initialize_pixmap (void);
|
||||
void resize_pixmap (int new_width, int new_height);
|
||||
int pixmap_getpixel (int x, int y);
|
||||
-inline int pixmap_index (int x, int y);
|
||||
+int pixmap_index (int x, int y);
|
||||
int pixmap_getpixel (int x, int y);
|
||||
void pixmap_setpixel (int x, int y, int col);
|
||||
void pixmap_hline (int x1, int y1, int x2, int col);
|
Loading…
Reference in a new issue