Changes 3.2.3:

** libgnutls: Fixes in parsing of priority strings. Patch by Stefan Buehler.
** libgnutls: Solve issue with received TLS packets that exceed 2^14.
(this fixes a bug that was accidentally introduced in 3.2.2)
** libgnutls: Removed gnulib modules under LGPLv3 that could possibly be
used by the library.
** libgnutls: Fixes in gnutls_record_send_range().
** API and ABI modifications:
gnutls_priority_kx_list: Added
gnutls_priority_mac_list: Added
gnutls_priority_cipher_list: Added
This commit is contained in:
adam 2013-08-01 20:00:59 +00:00
parent efb108f315
commit e92446c3c8
4 changed files with 14 additions and 20 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.130 2013/07/15 08:19:15 wiz Exp $
# $NetBSD: Makefile,v 1.131 2013/08/01 20:00:59 adam Exp $
DISTNAME= gnutls-3.2.2
DISTNAME= gnutls-3.2.3
CATEGORIES= security devel
MASTER_SITES= ftp://ftp.gnutls.org/gcrypt/gnutls/v3.2/
EXTRACT_SUFX= .tar.xz

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.45 2013/07/15 08:19:15 wiz Exp $
@comment $NetBSD: PLIST,v 1.46 2013/08/01 20:00:59 adam Exp $
bin/certtool
bin/danetool
bin/gnutls-cli
@ -448,11 +448,14 @@ man/man3/gnutls_pkcs7_set_crt_raw.3
man/man3/gnutls_prf.3
man/man3/gnutls_prf_raw.3
man/man3/gnutls_priority_certificate_type_list.3
man/man3/gnutls_priority_cipher_list.3
man/man3/gnutls_priority_compression_list.3
man/man3/gnutls_priority_deinit.3
man/man3/gnutls_priority_ecc_curve_list.3
man/man3/gnutls_priority_get_cipher_suite_index.3
man/man3/gnutls_priority_init.3
man/man3/gnutls_priority_kx_list.3
man/man3/gnutls_priority_mac_list.3
man/man3/gnutls_priority_protocol_list.3
man/man3/gnutls_priority_set.3
man/man3/gnutls_priority_set_direct.3

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.95 2013/07/15 08:19:15 wiz Exp $
$NetBSD: distinfo,v 1.96 2013/08/01 20:00:59 adam Exp $
SHA1 (gnutls-3.2.2.tar.xz) = ff3e1c25fade8e928700fa63f006265c7d9d1c08
RMD160 (gnutls-3.2.2.tar.xz) = f91c1729982bea8f42444d5f381fa9045bdd24bf
Size (gnutls-3.2.2.tar.xz) = 5164372 bytes
SHA1 (gnutls-3.2.3.tar.xz) = 18f5fffd1a0384944cb76cbedc0720c4726470f4
RMD160 (gnutls-3.2.3.tar.xz) = bde21d617cbef1051b019a99915ebf51246819d2
Size (gnutls-3.2.3.tar.xz) = 5119264 bytes
SHA1 (patch-ae) = 71fbbeb43ac1689fca6fec7f8348d8534c1dc38a
SHA1 (patch-gl_stdio.in.h) = b5802da2cccddd6fab73bd39c49f7d62bef58464
SHA1 (patch-lib_Makefile.in) = 2121ed1e974cd71fe49c286f7e91135be12d915f
SHA1 (patch-lib_Makefile.in) = 949df8644a1f6085d8ad63984188cee0518a837a
SHA1 (patch-lib_nettle_egd.c) = b7e9769e8c620519c43ca7b7481a558e9d389c68

View file

@ -1,8 +1,8 @@
$NetBSD: patch-lib_Makefile.in,v 1.2 2013/07/15 08:19:15 wiz Exp $
$NetBSD: patch-lib_Makefile.in,v 1.3 2013/08/01 20:00:59 adam Exp $
--- lib/Makefile.in.orig 2013-07-13 09:54:21.000000000 +0000
--- lib/Makefile.in.orig 2013-07-29 14:23:14.000000000 +0000
+++ lib/Makefile.in
@@ -379,7 +379,7 @@ am_libgnutls_la_OBJECTS = $(am__objects_
@@ -369,7 +369,7 @@ am_libgnutls_la_OBJECTS = $(am__objects_
libgnutls_la_OBJECTS = $(am_libgnutls_la_OBJECTS)
libgnutls_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
@ -11,12 +11,3 @@ $NetBSD: patch-lib_Makefile.in,v 1.2 2013/07/15 08:19:15 wiz Exp $
@ENABLE_CXX_TRUE@libgnutlsxx_la_DEPENDENCIES = libgnutls.la
am__libgnutlsxx_la_SOURCES_DIST = gnutlsxx.cpp
@ENABLE_CXX_TRUE@am_libgnutlsxx_la_OBJECTS = \
@@ -1845,7 +1845,7 @@ libgnutls_la_LIBADD = ../gl/libgnu.la x5
auth/libgnutls_auth.la algorithms/libgnutls_alg.la \
extras/libgnutls_extras.la $(am__append_8) $(am__append_11) \
$(am__append_14) $(thirdparty_libadd)
-thirdparty_libadd = $(LTLIBZ) $(LTLIBINTL) $(LIBSOCKET) \
+thirdparty_libadd = $(LTLIBZ) $(LTLIBINTL) $(LIBSOCKET) $(LIBRT) \
$(LTLIBPTHREAD) $(LTLIBICONV) $(P11_KIT_LIBS) $(LIB_SELECT) \
$(TSS_LIBS) $(am__append_12) $(am__append_13) $(am__append_17)
@HAVE_LD_OUTPUT_DEF_TRUE@defexecdir = $(bindir)