Fix missing include. Don't use libstdc++ implementation detail.

Free correct variable. Bump revision.
This commit is contained in:
joerg 2013-05-09 13:45:44 +00:00
parent 3029ed623a
commit e95835305b
5 changed files with 44 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.18 2013/02/16 11:20:26 wiz Exp $
# $NetBSD: Makefile,v 1.19 2013/05/09 13:45:44 joerg Exp $
#
DISTNAME= gnome-chemistry-utils-0.12.13
PKGREVISION= 7
PKGREVISION= 8
CATEGORIES= biology
MASTER_SITES= http://download-mirror.savannah.gnu.org/releases/gchemutils/0.12/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,5 +1,8 @@
$NetBSD: distinfo,v 1.4 2012/08/16 19:10:15 ryoon Exp $
$NetBSD: distinfo,v 1.5 2013/05/09 13:45:44 joerg Exp $
SHA1 (gnome-chemistry-utils-0.12.13.tar.bz2) = a3d83f281ccd7fdbc98e14e295093287d8648a69
RMD160 (gnome-chemistry-utils-0.12.13.tar.bz2) = 259509c4e9086fc40e91d1f2f93ad5bad9317b8c
Size (gnome-chemistry-utils-0.12.13.tar.bz2) = 5399998 bytes
SHA1 (patch-libs_gcu_loader-error.h) = 8e223394ac6fb6a17cc23439fc2e3bb2e3bc5440
SHA1 (patch-libs_gcu_spectrumdoc.cc) = 6d4d87c128096006fd384fc058c7942b49df8646
SHA1 (patch-programs_crystal_document.cc) = 192b376922d39796780863720459ee3ef025bfed

View file

@ -0,0 +1,12 @@
$NetBSD: patch-libs_gcu_loader-error.h,v 1.1 2013/05/09 13:45:45 joerg Exp $
--- libs/gcu/loader-error.h.orig 2013-05-07 20:05:57.000000000 +0000
+++ libs/gcu/loader-error.h
@@ -28,6 +28,7 @@
/*!\file*/
#include <stdexcept>
+#include <string>
namespace gcu {

View file

@ -0,0 +1,13 @@
$NetBSD: patch-libs_gcu_spectrumdoc.cc,v 1.1 2013/05/09 13:45:45 joerg Exp $
--- libs/gcu/spectrumdoc.cc.orig 2013-05-07 20:06:58.000000000 +0000
+++ libs/gcu/spectrumdoc.cc
@@ -1618,7 +1618,7 @@ void SpectrumDocument::ReadDataTable (is
break; // this should not occur, but a corrupted or bad file is always possible
s.getline (line, 300);
if (strstr (line, "##")) {
- s.seekg (-strlen (line) -1, _S_cur);
+ s.seekg (-strlen (line) -1, ios::cur);
if (read > npoints) {
g_warning (_("Found too many data!"));
// FIXME: throw an exception

View file

@ -0,0 +1,13 @@
$NetBSD: patch-programs_crystal_document.cc,v 1.1 2013/05/09 13:45:45 joerg Exp $
--- programs/crystal/document.cc.orig 2013-05-07 20:13:58.000000000 +0000
+++ programs/crystal/document.cc
@@ -607,7 +607,7 @@ void gcDocument::OnExportVRML (const str
if (error) {
cerr << "gio error: " << error->message << endl;
g_error_free (error);
- g_object_unref (file);
+ g_object_unref (stream);
throw (int) 1;
}
std::map<std::string, sAtom>AtomsMap;