Fix pointers for cursor_not_in_display() & cursor_in_display(). Fixes

BUS error on sparc64.  Appears to apply to version Bitchx 1.1 too.
This commit is contained in:
heas 2004-06-27 00:35:04 +00:00
parent 04959172c8
commit e96bb2c59f
3 changed files with 19 additions and 3 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.28 2004/03/29 07:28:51 xtraeme Exp $
# $NetBSD: Makefile,v 1.29 2004/06/27 00:35:04 heas Exp $
#
DISTNAME= ircii-pana-1.0c19
PKGNAME= bitchx-1.0.3.19
PKGREVISION= 6
PKGREVISION= 7
CATEGORIES= chat
MASTER_SITES= ftp://ftp.bitchx.org/pub/BitchX/source/ \
ftp://ftp.bitchx.org/pub/BitchX/source/old/

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.9 2003/12/02 01:55:48 jmcneill Exp $
$NetBSD: distinfo,v 1.10 2004/06/27 00:35:04 heas Exp $
SHA1 (ircii-pana-1.0c19.tar.gz) = 4821ebbd3f55ec2cfc2a20e2109e34ea45b3f144
Size (ircii-pana-1.0c19.tar.gz) = 2533621 bytes
@ -15,3 +15,4 @@ SHA1 (patch-aj) = 156be839ab2dc5abebb918398f64c62373f3561e
SHA1 (patch-ak) = 4e70e8d42b104b91849e79930fabe8c5a43d10f5
SHA1 (patch-al) = dd501c530af801bece9f035b4355d1ecaaa7658a
SHA1 (patch-am) = 6ed1f089f46ca1fb95192e14c1f26f3a7e6a9a98
SHA1 (patch-an) = 59a6dc31a90b88bbffac5bb4629feaa2488afeff

View file

@ -0,0 +1,15 @@
$NetBSD: patch-an,v 1.1 2004/06/27 00:35:04 heas Exp $
--- include/modval.h.orig 2001-05-19 20:40:58.000000000 +0000
+++ include/modval.h
@@ -279,8 +279,8 @@ extern Function_ptr *global;
#define output_line(x) ((int) (global[OUTPUT_LINE]((const unsigned char *)x)))
#define output_with_count(x, y, z) ((int) (global[OUTPUT_WITH_COUNT]((const unsigned char *)x, (int)y, (int)z)))
#define scroll_window(x) ((void) (global[SCROLL_WINDOW]((Window *)x)))
-#define cursor_not_in_display(x) ((void) (global[CURSOR_IN_DISPLAY]((Screen *)x)))
-#define cursor_in_display(x) ((void) (global[CURSOR_IN_DISPLAY]((Screen *)x)))
+#define cursor_not_in_display(x) ((void) (global[CURSOR_NOT_IN_DISPLAY]((Screen *)x)))
+#define cursor_in_display(x) ((void) (global[CURSOR_IN_DISPLAY]((Window *)x)))
#define is_cursor_in_display(x) ((int) (global[IS_CURSOR_IN_DISPLAY]((Screen *)x)))
#define repaint_window(x, y, z) ((void) (global[REPAINT_WINDOW]((Window *)x, (int)y, (int)z)))