don't key off of `alpha' to decide to do OSF specific things (-fpe3 flag

to the fortran compiler).  Also mark as not for older netbsd-alpha systems
as this is an IEEE-754 infected program (hi ross!).
This commit is contained in:
dmcmahill 2002-06-16 02:56:50 +00:00
parent aed20981b1
commit e9bca5e160
5 changed files with 2564 additions and 65 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.34 2002/05/24 13:24:36 markd Exp $
# $NetBSD: Makefile,v 1.35 2002/06/16 02:56:50 dmcmahill Exp $
DISTNAME= R-1.4.1
PKGREVISION= 2
@ -10,6 +10,10 @@ MAINTAINER= jlam@netbsd.org
HOMEPAGE= http://www.R-project.org/
COMMENT= Statistical language for data analysis and graphics
#needs FPC code not found in older versions of NetBSD
NOT_FOR_PLATFORM= NetBSD-1.[0-4]*-alpha NetBSD-1.5-alpha \
NetBSD-1.5.*-alpha NetBSD-1.5[A-U]-alpha
USE_BUILDLINK_ONLY= # defined
USE_X11= # defined
USE_PERL5= # defined

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.8 2002/05/20 18:16:41 cjep Exp $
$NetBSD: distinfo,v 1.9 2002/06/16 02:56:50 dmcmahill Exp $
SHA1 (R-1.4.1.tgz) = b9e9f4cd4576e62760fe4cc32ffdde04c0d8d2f7
Size (R-1.4.1.tgz) = 5136906 bytes
SHA1 (patch-aa) = f2999c2f21d9b95b22c3eebf2d34d524b32cce9d
SHA1 (patch-ab) = b5b7e1bcc401f74a7271451c62edcce151beeab0
SHA1 (patch-ac) = ac2df38674129b3ffc0f43963b600e89b3539855
SHA1 (patch-aa) = abf02a726d644b032e94d15e4a26ac9b79c5e2ca
SHA1 (patch-ab) = 21f688e12ab8a819b6e84dc48f41fdafd11bff85
SHA1 (patch-ac) = da94a293dddb186bb7bccf517b5b4f201906dff3
SHA1 (patch-ad) = 92992b9485aeb6c132ea0e9fa80f66426cbfab83

View file

@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.7 2002/03/01 10:46:53 markd Exp $
$NetBSD: patch-aa,v 1.8 2002/06/16 02:56:51 dmcmahill Exp $
--- configure.in.orig Fri Dec 14 04:16:03 2001
--- configure.in.orig Thu Dec 13 10:16:03 2001
+++ configure.in
@@ -426,9 +426,9 @@
if ${use_libmoto}; then
@ -15,7 +15,20 @@ $NetBSD: patch-aa,v 1.7 2002/03/01 10:46:53 markd Exp $
))
AC_CHECK_LIB(dl, dlopen)
@@ -776,6 +776,7 @@
@@ -553,11 +553,7 @@
R_PROG_CC_FLAG(-std1,
R_XTRA_CFLAGS="${R_XTRA_CFLAGS} -std1")
fi
- if test "${G77}" = yes; then
- R_XTRA_FFLAGS="${R_XTRA_FFLAGS} -mieee"
- else
- R_XTRA_FFLAGS="${R_XTRA_FFLAGS} -fpe3"
- fi
+ R_XTRA_FFLAGS="${R_XTRA_FFLAGS}"
## </Albrecht.Gebhardt@uni-klu.ac.at>
## </FIXME>
;;
@@ -776,6 +772,7 @@
main_ldflags="-export-dynamic"
;;
netbsd*)

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.11 2002/03/01 10:46:53 markd Exp $
$NetBSD: patch-ab,v 1.12 2002/06/16 02:56:51 dmcmahill Exp $
--- acinclude.m4.orig Thu Aug 23 21:15:12 2001
--- acinclude.m4.orig Sun Dec 9 16:09:06 2001
+++ acinclude.m4
@@ -467,6 +467,9 @@
@@ -574,6 +574,9 @@
extern void F77_SYMBOL(cftest)(int *a, int *b, double *x, double *y);
@ -12,3 +12,13 @@ $NetBSD: patch-ab,v 1.11 2002/03/01 10:46:53 markd Exp $
int main () {
int a[3] = {17, 237, 2000000000}, b[2], res = 0;
double x[3] = {3.14159265, 123.456789, 2.3e34}, z[3];
@@ -652,6 +655,9 @@
} Rcomplex;
extern void F77_SYMBOL(cftest)(Rcomplex *x);
+
+int MAIN_ () { return 0; }
+int MAIN__ () { return 0; }
int main () {
Rcomplex z[3];

File diff suppressed because it is too large Load diff