- add missing header file
- use CONFIGURE_ENV during the configure phase to make sure we pick up QMAKESPEC - set CONFIG_SHELL to ${SH} to help /bin/sh challenged platforms like solaris.
This commit is contained in:
parent
fafc5aa2e5
commit
e9be6355fe
3 changed files with 20 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.25 2005/06/16 06:57:42 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.26 2005/09/14 14:18:16 dmcmahill Exp $
|
||||
|
||||
PSI_VERSION= 0.9.3
|
||||
DISTNAME= psi-${PSI_VERSION}
|
||||
|
@ -24,6 +24,8 @@ USE_TOOLS+= gmake
|
|||
USE_LIBTOOL= yes
|
||||
HAS_CONFIGURE= yes
|
||||
|
||||
CONFIG_SHELL= ${SH}
|
||||
|
||||
CONFIGURE_ARGS= --prefix="${PREFIX}" --qtdir="${QTDIR}"
|
||||
CONFIGURE_ARGS+= --with-qca-inc="${BUILDLINK_PREFIX.qca}/include" \
|
||||
--with-qca-lib="${BUILDLINK_PREFIX.qca}/lib"
|
||||
|
@ -49,7 +51,7 @@ post-configure:
|
|||
-e "s:/bin/true:${TRUE}:" < ${WRKSRC}/Makefile \
|
||||
> ${WRKSRC}/Makefile.new
|
||||
${MV} ${WRKSRC}/Makefile.new ${WRKSRC}/Makefile
|
||||
cd ${WRKSRC}/libpsi/psiwidgets && ( \
|
||||
cd ${WRKSRC}/libpsi/psiwidgets && ( ${SETENV} ${CONFIGURE_ENV} \
|
||||
${QTDIR}/bin/qmake psiwidgets.pro -o Makefile; \
|
||||
${SED} -e 's,-rpath.*$$,-rpath "${QTDIR}/lib",' < Makefile > Makefile.new; \
|
||||
${MV} Makefile.new Makefile; \
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.11 2005/04/02 11:33:10 jdolecek Exp $
|
||||
$NetBSD: distinfo,v 1.12 2005/09/14 14:18:16 dmcmahill Exp $
|
||||
|
||||
SHA1 (psi-0.9.3/psi-0.9.3.tar.bz2) = dc5e7dbf5d791db2f0c4189cad055a40b21cf9b6
|
||||
RMD160 (psi-0.9.3/psi-0.9.3.tar.bz2) = 66983a9746812b27a5c8a1c072e9b33aca638d30
|
||||
|
@ -42,5 +42,6 @@ Size (psi-0.9.3/psi_ru.qm) = 131782 bytes
|
|||
SHA1 (psi-0.9.3/psi_vi.qm) = 9676425d54ecf37c4d7039cdc1aff81de87c9612
|
||||
RMD160 (psi-0.9.3/psi_vi.qm) = ed111729624fb299eaba729648105b7f1a93e35f
|
||||
Size (psi-0.9.3/psi_vi.qm) = 139897 bytes
|
||||
SHA1 (patch-aa) = 1f3fbbe1f32df44db06a76d33d32555dd0fe7b6f
|
||||
SHA1 (patch-ac) = 6faea4967d2682c087aa5de12b7c83ac5848d1b5
|
||||
SHA1 (patch-ad) = 8d255aa9de01ccb39d2cdc7b0074b5dec0e3c0cb
|
||||
|
|
14
chat/psi/patches/patch-aa
Normal file
14
chat/psi/patches/patch-aa
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-aa,v 1.5 2005/09/14 14:18:16 dmcmahill Exp $
|
||||
|
||||
--- cutestuff/openpgp/gpgproc/jprocess_unix.cpp.orig 2004-06-07 03:30:04.000000000 -0400
|
||||
+++ cutestuff/openpgp/gpgproc/jprocess_unix.cpp
|
||||
@@ -35,6 +35,9 @@
|
||||
**
|
||||
**********************************************************************/
|
||||
|
||||
+#define BSD_COMP
|
||||
+#include <sys/ioctl.h>
|
||||
+
|
||||
#include "qplatformdefs.h"
|
||||
|
||||
// Solaris redefines connect -> __xnet_connect with _XOPEN_SOURCE_EXTENDED.
|
Loading…
Reference in a new issue