Import mandelbulber-1.13.1 as graphics/mandelbulber.

The Mandelbulb is a three-dimensional analogue of the Mandelbrot
set. In reality there are many natural fractal shapes such as
clouds, trees, broccoli, and such.
This commit is contained in:
ryoon 2012-12-16 16:10:56 +00:00
parent a02f7c11cf
commit ea4aa0967f
5 changed files with 167 additions and 0 deletions

View file

@ -0,0 +1,3 @@
The Mandelbulb is a three-dimensional analogue of the Mandelbrot
set. In reality there are many natural fractal shapes such as
clouds, trees, broccoli, and such.

View file

@ -0,0 +1,40 @@
# $NetBSD: Makefile,v 1.1 2012/12/16 16:10:56 ryoon Exp $
#
DISTNAME= mandelbulber1.13-1
PKGNAME= ${DISTNAME:S/-/./:S/mandelbulber/mandelbulber-/}
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=mandelbulber/}
MAINTAINER= ryoon@NetBSD.org
HOMEPAGE= http://www.mandelbulber.com/
COMMENT= 3D fractal explorer
LICENSE= gnu-gpl-v3
USE_TOOLS+= gmake pax pkg-config
USE_LANGUAGES= c++
BUILD_DIRS= makefiles
MAKE_FILE= makefile
SUBST_CLASSES+= lib
SUBST_STAGE.lib= pre-configure
SUBST_MESSAGE.lib= Fix library path, CXXFLAGS, and CXX.
SUBST_FILES.lib+= makefiles/makefile
SUBST_FILES.lib+= makefiles/src/subdir.mk
SUBST_SED.lib+= -e 's;g++;${CXX:Q} ${CXXFLAGSQ} ${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.gtk2}/lib ${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.freetype2}/lib;'
SUBST_SED.lib+= -e 's,/usr/lib/x86_64-linux-gnu/,${PREFIX}/lib,'
CXXFLAGS+= -DSHARED_DIR=\\"${PREFIX}/share/mandelbulber\\"
INSTALLATION_DIRS= bin share/mandelbulber
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/makefiles/mandelbulber \
${DESTDIR}${PREFIX}/bin
cd ${WRKSRC}/usr/share && pax -rw -pmp * \
${DESTDIR}${PREFIX}/share/mandelbulber
.include "../../mk/jpeg.buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

103
graphics/mandelbulber/PLIST Normal file
View file

@ -0,0 +1,103 @@
@comment $NetBSD: PLIST,v 1.1 2012/12/16 16:10:56 ryoon Exp $
bin/mandelbulber
share/mandelbulber/defaults
share/mandelbulber/exampleKeyframes/keyframe00000.fract
share/mandelbulber/exampleKeyframes/keyframe00001.fract
share/mandelbulber/exampleKeyframes/keyframe00002.fract
share/mandelbulber/exampleKeyframes/keyframe00003.fract
share/mandelbulber/exampleKeyframes/keyframe00004.fract
share/mandelbulber/exampleKeyframes/keyframe00005.fract
share/mandelbulber/exampleKeyframes/keyframe00006.fract
share/mandelbulber/exampleKeyframes/keyframe00007.fract
share/mandelbulber/exampleKeyframes/keyframe00008.fract
share/mandelbulber/exampleKeyframes/keyframe00009.fract
share/mandelbulber/exampleKeyframes/keyframe00010.fract
share/mandelbulber/examples/FoldIntPow2 2.fract
share/mandelbulber/examples/FoldIntPow2 3.fract
share/mandelbulber/examples/Folded trigonometric power 8 version 2.fract
share/mandelbulber/examples/Folded trigonometric power 8.fract
share/mandelbulber/examples/Hybrid 1.fract
share/mandelbulber/examples/Hybrid 2.fract
share/mandelbulber/examples/Hybrid 3.fract
share/mandelbulber/examples/Hybrid 4.fract
share/mandelbulber/examples/IFS Dodecahedron.fract
share/mandelbulber/examples/IFS Icosahedron 2.fract
share/mandelbulber/examples/IFS Icosahedron.fract
share/mandelbulber/examples/IFS Octahedral Sierpinski.fract
share/mandelbulber/examples/IFS Sierpinski.fract
share/mandelbulber/examples/IFS Trees.fract
share/mandelbulber/examples/Mandelbulb with backlight.fract
share/mandelbulber/examples/Volumetric fog 1.fract
share/mandelbulber/examples/Volumetric light 1.fract
share/mandelbulber/examples/Volumetric light 2.fract
share/mandelbulber/examples/Volumetric light 3.fract
share/mandelbulber/examples/colour palette example.fract
share/mandelbulber/examples/constant factor -1.2 - mandelbox scale -1.5.fract
share/mandelbulber/examples/constant factor 1.2 - mandelbulb power 8.fract
share/mandelbulber/examples/constant factor 2.0 - mandelbox scale 2.0.fract
share/mandelbulber/examples/default.fract
share/mandelbulber/examples/example animation (keyframes).fract
share/mandelbulber/examples/fish eye.fract
share/mandelbulber/examples/hypercomplex - ambient occlusion.fract
share/mandelbulber/examples/hypercomplex - julia - environment mapping.fract
share/mandelbulber/examples/interior - mandelbox scale 2.fract
share/mandelbulber/examples/interior - mandelbulb power 2.fract
share/mandelbulber/examples/interior - mandelbulb power 8.fract
share/mandelbulber/examples/iter fog 1.fract
share/mandelbulber/examples/iter fog 2.fract
share/mandelbulber/examples/iter fog 3.fract
share/mandelbulber/examples/iter fog 4.fract
share/mandelbulber/examples/menger sponge - equirectangular projection.fract
share/mandelbulber/examples/menger sponge 2.fract
share/mandelbulber/examples/menger sponge 3.fract
share/mandelbulber/examples/menger sponge.fract
share/mandelbulber/examples/modified mandelbulb 1.fract
share/mandelbulber/examples/modified mandelbulb 2 - sliced.fract
share/mandelbulber/examples/modified mandelbulb 2.fract
share/mandelbulber/examples/modified mandelbulb 3.fract
share/mandelbulber/examples/power 2 - Julia environment mapping central light.fract
share/mandelbulber/examples/power 2 - default.fract
share/mandelbulber/examples/power 2 - hq ambient occlusion.fract
share/mandelbulber/examples/power 2 - julia.fract
share/mandelbulber/examples/power 2 - limits.fract
share/mandelbulber/examples/power 2 - screen space ambient occlusion.fract
share/mandelbulber/examples/primitive objects - inverted box.fract
share/mandelbulber/examples/primitive objects - set.fract
share/mandelbulber/examples/primitive objects - water.fract
share/mandelbulber/examples/quaternion - julia.fract
share/mandelbulber/examples/quaternion - lathe.fract
share/mandelbulber/examples/raytraced reflections 1.fract
share/mandelbulber/examples/raytraced reflections 2.fract
share/mandelbulber/examples/rotated mandelbox 1.fract
share/mandelbulber/examples/rotated mandelbox 2.fract
share/mandelbulber/examples/rotated mandelbox 3.fract
share/mandelbulber/examples/rotated mandelbox 4.fract
share/mandelbulber/examples/spherical folding - mandelbulb power 2.fract
share/mandelbulber/examples/spherical folding - mandelbulb power 8.fract
share/mandelbulber/examples/spherical folding - menger sponge.fract
share/mandelbulber/examples/stereo.fract
share/mandelbulber/examples/tglad - scale -1.4, minRadius 0.1.fract
share/mandelbulber/examples/tglad - scale -1.73 closeup.fract
share/mandelbulber/examples/tglad - scale -2.fract
share/mandelbulber/examples/tglad - scale 2 - coloured lights.fract
share/mandelbulber/examples/tglad - scale 2.fract
share/mandelbulber/examples/tglad - scale 3.fract
share/mandelbulber/examples/trigonometric - default.fract
share/mandelbulber/examples/trigonometric - hq ambient occlusion.fract
share/mandelbulber/examples/trigonometric - power 6 julia.fract
share/mandelbulber/examples/trigonometric - power 8 deep zoom.fract
share/mandelbulber/examples/volumetric fog 2.fract
share/mandelbulber/examples/xenodreambuie's formula 2.fract
share/mandelbulber/examples/xenodreambuie's formula.fract
share/mandelbulber/icons/go-down.png
share/mandelbulber/icons/go-next.png
share/mandelbulber/icons/go-previous.png
share/mandelbulber/icons/go-up.png
share/mandelbulber/icons/mandelbulber.png
share/mandelbulber/icons/object-rotate-left.png
share/mandelbulber/icons/object-rotate-right.png
share/mandelbulber/textures/background.jpg
share/mandelbulber/textures/colour palette.jpg
share/mandelbulber/textures/envmap.jpg
share/mandelbulber/textures/lightmap.jpg
share/mandelbulber/textures/lightmap2.jpg

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2012/12/16 16:10:56 ryoon Exp $
SHA1 (mandelbulber1.13-1.tar.gz) = 9dfdcc71a4e610e016b10c8bfb6225b4254c09a7
RMD160 (mandelbulber1.13-1.tar.gz) = d87e250b8bfb4249d43112d1d8395c5d9913f6c7
Size (mandelbulber1.13-1.tar.gz) = 1200010 bytes
SHA1 (patch-src_netrender.hpp) = 8d1bc2f6586d56434c8d2a4c33eac5b2ed911176

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_netrender.hpp,v 1.1 2012/12/16 16:10:56 ryoon Exp $
* Fix build on *BSD
--- src/netrender.hpp.orig 2012-12-02 16:22:54.000000000 +0000
+++ src/netrender.hpp
@@ -23,6 +23,8 @@
#include <netdb.h>
#endif
+#include <netinet/in.h>
+
#include <errno.h>
#include <unistd.h>
#include <vector>