Update to 2.4.41:

Alex Deucher (1):
      radeon: add new SI pci id

Ben Skeggs (2):
      nouveau: disallow pushbuf BOs in multiple memory types
      nouveau: expose channel engine selection on kepler chipsets

Chris Wilson (1):
      intel: Remove the fence count contributions when clearing relocs

David Herrmann (4):
      man: convert manpages to XML instead of plain troff
      man: add drm.7 overview page
      man: add drm-kms overview page
      man: add drm-memory overview page

David Shao (1):
      intel: Fix missing ETIME on BSD operating systems

Jerome Glisse (1):
      drm/radeon: track global bo name and always return the same

Jesse Barnes (1):
      man: disable man page building until David saves us all

Maarten Lankhorst (1):
      configure.ac: bump version to 2.4.41 for release

Marcin Slusarz (1):
      libdrm_nouveau.pc: don't include I${includedir}/nouveau

Maxime Villard (2):
      libkms: fix memory leak in error path
      libkms: return -EINVAL on fstat error
This commit is contained in:
wiz 2013-01-25 10:32:56 +00:00
parent aaecb4af7f
commit ea5a94379d
5 changed files with 23 additions and 29 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.24 2012/12/08 22:15:35 wiz Exp $
# $NetBSD: Makefile,v 1.25 2013/01/25 10:32:56 wiz Exp $
#
DISTNAME= libdrm-2.4.40
DISTNAME= libdrm-2.4.41
CATEGORIES= x11 graphics
MASTER_SITES= http://dri.freedesktop.org/libdrm/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2012/12/08 22:15:35 wiz Exp $
@comment $NetBSD: PLIST,v 1.9 2013/01/25 10:32:56 wiz Exp $
include/libdrm/drm.h
include/libdrm/drm_fourcc.h
include/libdrm/drm_mode.h
@ -35,6 +35,3 @@ lib/pkgconfig/libdrm.pc
lib/pkgconfig/libdrm_intel.pc
lib/pkgconfig/libdrm_nouveau.pc
lib/pkgconfig/libdrm_radeon.pc
man/man3/drmAvailable.3
man/man3/drmHandleEvent.3
man/man3/drmModeGetResources.3

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.25 2012/12/08 22:15:35 wiz Exp $
$NetBSD: distinfo,v 1.26 2013/01/25 10:32:56 wiz Exp $
SHA1 (libdrm-2.4.40.tar.bz2) = 0f77aa49922e17102caa75de86c8e79bbf23b4a1
RMD160 (libdrm-2.4.40.tar.bz2) = 445dd7776fcc7a74f777281f69beb498e4a57576
Size (libdrm-2.4.40.tar.bz2) = 492962 bytes
SHA1 (libdrm-2.4.41.tar.bz2) = edc0585d97765bad11d8f63c8343a23075f5eb3d
RMD160 (libdrm-2.4.41.tar.bz2) = 8bd53ce443017696bc3665ec09c362ff66d942bf
Size (libdrm-2.4.41.tar.bz2) = 487802 bytes
SHA1 (patch-ab) = 66dadd3244bfa9c69be0982fd2108deb94483de2
SHA1 (patch-ac) = 67c998df7dfc0dabc86320ea6d015cede3e464ea
SHA1 (patch-ad) = ea3ef8de8db782ddab23f182f1e6bd9d8f612a78
SHA1 (patch-configure) = 383e57da4b5635bd21b3c87b7bdd413be9e622c1
SHA1 (patch-include_drm_drm.h) = d370e83da5c39f0e49094787c5f4580758c911b0
SHA1 (patch-intel_intel__bufmgr__gem.c) = 418d00f24344b7abaa86d3b3d10817314ce70175
SHA1 (patch-libkms_linux.c) = 737d0a8e7b742ee9d24fec94c72de6b4915dd675

View file

@ -0,0 +1,15 @@
$NetBSD: patch-configure,v 1.1 2013/01/25 10:32:56 wiz Exp $
man/ wasn't intended to be distributed in 2.4.41.
--- configure.orig 2013-01-16 12:06:26.000000000 +0000
+++ configure
@@ -13047,7 +13047,7 @@ fi
-ac_config_files="$ac_config_files Makefile libkms/Makefile libkms/libkms.pc intel/Makefile intel/libdrm_intel.pc radeon/Makefile radeon/libdrm_radeon.pc nouveau/Makefile nouveau/libdrm_nouveau.pc omap/Makefile omap/libdrm_omap.pc exynos/Makefile exynos/libdrm_exynos.pc tests/Makefile tests/modeprint/Makefile tests/modetest/Makefile tests/kmstest/Makefile tests/radeon/Makefile tests/vbltest/Makefile include/Makefile include/drm/Makefile man/Makefile libdrm.pc"
+ac_config_files="$ac_config_files Makefile libkms/Makefile libkms/libkms.pc intel/Makefile intel/libdrm_intel.pc radeon/Makefile radeon/libdrm_radeon.pc nouveau/Makefile nouveau/libdrm_nouveau.pc omap/Makefile omap/libdrm_omap.pc exynos/Makefile exynos/libdrm_exynos.pc tests/Makefile tests/modeprint/Makefile tests/modetest/Makefile tests/kmstest/Makefile tests/radeon/Makefile tests/vbltest/Makefile include/Makefile include/drm/Makefile libdrm.pc"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure

View file

@ -1,18 +0,0 @@
$NetBSD: patch-intel_intel__bufmgr__gem.c,v 1.3 2012/08/13 07:02:01 wiz Exp $
ETIME is not defined on DragonFly BSD, work around it.
From PR 46649; upstream report at
https://bugs.freedesktop.org/show_bug.cgi?id=52549
--- intel/intel_bufmgr_gem.c.orig 2012-08-11 18:49:45.000000000 +0000
+++ intel/intel_bufmgr_gem.c
@@ -54,6 +54,9 @@
#include <stdbool.h>
#include "errno.h"
+#ifndef ETIME
+#define ETIME ETIMEDOUT
+#endif
#include "libdrm_lists.h"
#include "intel_bufmgr.h"
#include "intel_bufmgr_priv.h"