Nmap 5.21 [2010-01-27] (-> Nmap 5.00)

Some of highlights are:

o Dramatically improved the version detection database, integrating
  2,596 submissions that users contributed since February 3, 2009!
o Added 7 new NSE scripts for a grand total of 79!
o Performed a memory consumption audit and made changes to
  dramatically reduce Nmap's footprint.
o A major service detection submission integration.
o Added some new service detection probes
o Added 14 new NSE scripts for a grand total of 72! You can learn
  about them all at http://nmap.org/nsedoc/. Here are the new ones:
o Nmap's --traceroute has been rewritten for better performance.
o Integrated 1,349 fingerprints (and 81 corrections).
o [NSE] Default socket parallelism has been doubled from 10 to 20.
o [NSE] Now supports worker threads
o Zenmap now includes ports in the services view whenever Nmap found
  them "interesting," whatever their state.
o [Ncat, Ndiff] The exit codes of these programs now reflect whether
  they succeeded.
o Optimize MAC address prefix lookup by using an std::map
o Canonicalized the list of OS detection device types to a smaller set.
o Zenmap's UI performance has improved significantly.
o [NSE] socket garbage collection was rewritten for better performance.

Many many bugfixes!

For full changelog, see http://nmap.org/changelog.html

Ok'ed during freeze by wiz@
This commit is contained in:
pettai 2010-03-21 21:58:23 +00:00
parent e02a7173d8
commit ea7301c840
7 changed files with 118 additions and 50 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.70 2010/03/21 02:50:47 schmonz Exp $
# $NetBSD: Makefile,v 1.71 2010/03/21 21:58:23 pettai Exp $
#
DISTNAME= nmap-5.00
PKGREVISION= 2
DISTNAME= nmap-5.21
CATEGORIES= net security
MASTER_SITES= http://nmap.org/dist/
EXTRACT_SUFX= .tar.bz2
@ -10,6 +9,7 @@ EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://insecure.org/nmap/
COMMENT= Network/port scanner with OS detection
LICENSE= gnu-gpl-v2
PKG_INSTALLATION_TYPES= overwrite pkgviews
PKG_DESTDIR_SUPPORT= user-destdir
@ -18,11 +18,14 @@ BUILDLINK_API_DEPENDS.libpcap= libpcap>=0.9.4
BUILDLINK_API_DEPENDS.libpcre= libpcre>=6.7
GNU_CONFIGURE= yes
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
USE_TOOLS+= gmake
PLIST_SRC= ${WRKDIR}/.PLIST_SRC
BUILD_DEFS+= IPV6_READY
.include "options.mk"
CHECK_INTERPRETER_SKIP+= share/zenmap/su-to-zenmap.sh

View file

@ -1,8 +1,22 @@
@comment $NetBSD: PLIST,v 1.11 2009/07/20 20:49:40 adrianp Exp $
@comment $NetBSD: PLIST,v 1.12 2010/03/21 21:58:23 pettai Exp $
bin/ncat
bin/nmap
man/de/man1/nmap.1
man/es/man1/nmap.1
man/fr/man1/nmap.1
man/hr/man1/nmap.1
man/hu/man1/nmap.1
man/it/man1/nmap.1
man/jp/man1/nmap.1
man/man1/ncat.1
man/man1/nmap.1
man/pl/man1/nmap.1
man/pt_BR/man1/nmap.1
man/pt_PT/man1/nmap.1
man/ro/man1/nmap.1
man/ru/man1/nmap.1
man/sk/man1/nmap.1
man/zh/man1/nmap.1
share/ncat/ca-bundle.crt
share/nmap/nmap-mac-prefixes
share/nmap/nmap-os-db
@ -14,7 +28,27 @@ share/nmap/nmap.dtd
share/nmap/nmap.xsl
share/nmap/nse_main.lua
share/nmap/nselib/base64.lua
share/nmap/nselib/citrixxml.lua
share/nmap/nselib/comm.lua
share/nmap/nselib/data/favicon-db
share/nmap/nselib/data/folders.lst
share/nmap/nselib/data/http-fingerprints
share/nmap/nselib/data/oracle-sids
share/nmap/nselib/data/passwords.lst
share/nmap/nselib/data/psexec/README
share/nmap/nselib/data/psexec/backdoor.lua
share/nmap/nselib/data/psexec/default.lua
share/nmap/nselib/data/psexec/drives.lua
share/nmap/nselib/data/psexec/encoder.c
share/nmap/nselib/data/psexec/examples.lua
share/nmap/nselib/data/psexec/experimental.lua
share/nmap/nselib/data/psexec/network.lua
share/nmap/nselib/data/psexec/nmap_service.c
share/nmap/nselib/data/psexec/nmap_service.exe
share/nmap/nselib/data/psexec/nmap_service.vcproj
share/nmap/nselib/data/psexec/pwdump.lua
share/nmap/nselib/data/usernames.lst
share/nmap/nselib/data/yokoso-fingerprints
share/nmap/nselib/datafiles.lua
share/nmap/nselib/dns.lua
share/nmap/nselib/http.lua
@ -29,6 +63,7 @@ share/nmap/nselib/netbios.lua
share/nmap/nselib/nsedebug.lua
share/nmap/nselib/packet.lua
share/nmap/nselib/pop3.lua
share/nmap/nselib/proxy.lua
share/nmap/nselib/shortport.lua
share/nmap/nselib/smb.lua
share/nmap/nselib/smbauth.lua
@ -37,6 +72,7 @@ share/nmap/nselib/ssh1.lua
share/nmap/nselib/ssh2.lua
share/nmap/nselib/stdnse.lua
share/nmap/nselib/strbuf.lua
share/nmap/nselib/strict.lua
share/nmap/nselib/tab.lua
share/nmap/nselib/unpwdb.lua
share/nmap/nselib/url.lua
@ -44,7 +80,14 @@ share/nmap/scripts/asn-query.nse
share/nmap/scripts/auth-owners.nse
share/nmap/scripts/auth-spoof.nse
share/nmap/scripts/banner.nse
share/nmap/scripts/citrix-brute-xml.nse
share/nmap/scripts/citrix-enum-apps-xml.nse
share/nmap/scripts/citrix-enum-apps.nse
share/nmap/scripts/citrix-enum-servers-xml.nse
share/nmap/scripts/citrix-enum-servers.nse
share/nmap/scripts/daytime.nse
share/nmap/scripts/db2-info.nse
share/nmap/scripts/dhcp-discover.nse
share/nmap/scripts/dns-random-srcport.nse
share/nmap/scripts/dns-random-txid.nse
share/nmap/scripts/dns-recursion.nse
@ -55,17 +98,27 @@ share/nmap/scripts/ftp-bounce.nse
share/nmap/scripts/ftp-brute.nse
share/nmap/scripts/html-title.nse
share/nmap/scripts/http-auth.nse
share/nmap/scripts/http-date.nse
share/nmap/scripts/http-enum.nse
share/nmap/scripts/http-favicon.nse
share/nmap/scripts/http-headers.nse
share/nmap/scripts/http-iis-webdav-vuln.nse
share/nmap/scripts/http-malware-host.nse
share/nmap/scripts/http-open-proxy.nse
share/nmap/scripts/http-passwd.nse
share/nmap/scripts/http-trace.nse
share/nmap/scripts/http-userdir-enum.nse
share/nmap/scripts/iax2-version.nse
share/nmap/scripts/imap-capabilities.nse
share/nmap/scripts/irc-info.nse
share/nmap/scripts/ms-sql-info.nse
share/nmap/scripts/mysql-info.nse
share/nmap/scripts/nbstat.nse
share/nmap/scripts/nfs-showmount.nse
share/nmap/scripts/ntp-info.nse
share/nmap/scripts/oracle-sid-brute.nse
share/nmap/scripts/p2p-conficker.nse
share/nmap/scripts/pjl-ready-message.nse
share/nmap/scripts/pop3-brute.nse
share/nmap/scripts/pop3-capabilities.nse
share/nmap/scripts/pptp-version.nse
@ -77,15 +130,17 @@ share/nmap/scripts/skypev2-version.nse
share/nmap/scripts/smb-brute.nse
share/nmap/scripts/smb-check-vulns.nse
share/nmap/scripts/smb-enum-domains.nse
share/nmap/scripts/smb-enum-groups.nse
share/nmap/scripts/smb-enum-processes.nse
share/nmap/scripts/smb-enum-sessions.nse
share/nmap/scripts/smb-enum-shares.nse
share/nmap/scripts/smb-enum-users.nse
share/nmap/scripts/smb-os-discovery.nse
share/nmap/scripts/smb-pwdump.nse
share/nmap/scripts/smb-psexec.nse
share/nmap/scripts/smb-security-mode.nse
share/nmap/scripts/smb-server-stats.nse
share/nmap/scripts/smb-system-info.nse
share/nmap/scripts/smbv2-enabled.nse
share/nmap/scripts/smtp-commands.nse
share/nmap/scripts/smtp-open-relay.nse
share/nmap/scripts/smtp-strangeport.nse
@ -96,7 +151,9 @@ share/nmap/scripts/socks-open-proxy.nse
share/nmap/scripts/sql-injection.nse
share/nmap/scripts/ssh-hostkey.nse
share/nmap/scripts/sshv1.nse
share/nmap/scripts/ssl-cert.nse
share/nmap/scripts/sslv2.nse
share/nmap/scripts/telnet-brute.nse
share/nmap/scripts/upnp-info.nse
share/nmap/scripts/whois.nse
share/nmap/scripts/x11-access.nse

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST.zenmap,v 1.5 2009/07/20 20:49:40 adrianp Exp $
@comment $NetBSD: PLIST.zenmap,v 1.6 2010/03/21 21:58:23 pettai Exp $
bin/nmapfe
bin/uninstall_zenmap
bin/xnmap
@ -121,6 +121,8 @@ ${PYSITELIB}/zenmapGUI/DiffCompare.py
${PYSITELIB}/zenmapGUI/DiffCompare.pyc
${PYSITELIB}/zenmapGUI/FileChoosers.py
${PYSITELIB}/zenmapGUI/FileChoosers.pyc
${PYSITELIB}/zenmapGUI/FilterBar.py
${PYSITELIB}/zenmapGUI/FilterBar.pyc
${PYSITELIB}/zenmapGUI/Icons.py
${PYSITELIB}/zenmapGUI/Icons.pyc
${PYSITELIB}/zenmapGUI/MainWindow.py
@ -141,10 +143,10 @@ ${PYSITELIB}/zenmapGUI/ScanHostDetailsPage.py
${PYSITELIB}/zenmapGUI/ScanHostDetailsPage.pyc
${PYSITELIB}/zenmapGUI/ScanHostsView.py
${PYSITELIB}/zenmapGUI/ScanHostsView.pyc
${PYSITELIB}/zenmapGUI/ScanInterface.py
${PYSITELIB}/zenmapGUI/ScanInterface.pyc
${PYSITELIB}/zenmapGUI/ScanNmapOutputPage.py
${PYSITELIB}/zenmapGUI/ScanNmapOutputPage.pyc
${PYSITELIB}/zenmapGUI/ScanNotebook.py
${PYSITELIB}/zenmapGUI/ScanNotebook.pyc
${PYSITELIB}/zenmapGUI/ScanOpenPortsPage.py
${PYSITELIB}/zenmapGUI/ScanOpenPortsPage.pyc
${PYSITELIB}/zenmapGUI/ScanRunDetailsPage.py
@ -214,6 +216,7 @@ share/zenmap/locale/de/LC_MESSAGES/zenmap.mo
share/zenmap/locale/fr/LC_MESSAGES/zenmap.mo
share/zenmap/locale/hr/LC_MESSAGES/zenmap.mo
share/zenmap/locale/pt_BR/LC_MESSAGES/zenmap.mo
share/zenmap/locale/ru/LC_MESSAGES/zenmap.mo
share/zenmap/misc/profile_editor.xml
share/zenmap/pixmaps/default_32.png
share/zenmap/pixmaps/default_75.png

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.40 2009/07/20 19:40:08 adrianp Exp $
$NetBSD: distinfo,v 1.41 2010/03/21 21:58:23 pettai Exp $
SHA1 (nmap-5.00.tar.bz2) = 3e7557f7fd52ccf8f052042fe1412ba0c964dee8
RMD160 (nmap-5.00.tar.bz2) = 429fff5e436826978426bd800698de8e0d78b662
Size (nmap-5.00.tar.bz2) = 9068342 bytes
SHA1 (nmap-5.21.tar.bz2) = ce5ff792161dae0037e41b31e0c2ef683ce94655
RMD160 (nmap-5.21.tar.bz2) = 85e912c3c6a7ed03eb1b399c812836071e4dcf9f
Size (nmap-5.21.tar.bz2) = 10015121 bytes
SHA1 (patch-aa) = 61593e0479a79bcb4cce2e88b2e5753fa14bc429
SHA1 (patch-ab) = bef6a0bc8481702319d14d3427169562f13e1526
SHA1 (patch-ab) = 22c377e9a340a6e6d7b9a36b63e6ffc47a084b3b
SHA1 (patch-ac) = c22e8f6411b1152a6e7582c90e5ec5bd4c6acaad
SHA1 (patch-ad) = 767ace3bb0c94db80ce3352692358b63463f4e30
SHA1 (patch-ad) = 607225d4f0d1e9a7ea5f73aee79e71c6995f1c64
SHA1 (patch-aj) = 868440ce24a70c1a747af6d65eed24f20c4bb892

View file

@ -1,8 +1,9 @@
# $NetBSD: options.mk,v 1.3 2009/07/20 19:40:08 adrianp Exp $
# $NetBSD: options.mk,v 1.4 2010/03/21 21:58:23 pettai Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.nmap
PKG_SUPPORTED_OPTIONS= zenmap inet6 ndiff
PKG_SUPPORTED_OPTIONS= inet6 zenmap ndiff
PKG_SUGGESTED_OPTIONS= inet6
.include "../../mk/bsd.options.mk"
@ -19,7 +20,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.if !empty(PKG_OPTIONS:Mzenmap)
CONFIGURE_ARGS+= --with-zenmap
PLIST_SRC+= ${PKGDIR}/PLIST.zenmap
PYTHON_VERSIONS_ACCEPTED= 25 24
PYTHON_VERSIONS_ACCEPTED= 26 25 24
PY_PATCHPLIST= yes
.include "../../lang/python/application.mk"
.include "../../lang/python/extension.mk"
@ -34,7 +35,7 @@ CONFIGURE_ARGS+= --without-zenmap
.if !empty(PKG_OPTIONS:Mndiff)
CONFIGURE_ARGS+= --with-ndiff
PLIST_SRC+= ${PKGDIR}/PLIST.ndiff
PYTHON_VERSIONS_ACCEPTED= 25 24
PYTHON_VERSIONS_ACCEPTED= 26 25 24
.else
CONFIGURE_ARGS+= --without-ndiff
.endif

View file

@ -1,8 +1,26 @@
$NetBSD: patch-ab,v 1.12 2006/12/17 17:55:49 salo Exp $
$NetBSD: patch-ab,v 1.13 2010/03/21 21:58:23 pettai Exp $
--- configure.orig 2006-08-17 02:36:16.000000000 +0200
+++ configure 2006-12-17 15:07:11.000000000 +0100
@@ -5879,6 +5879,7 @@ cat >>conftest.$ac_ext <<_ACEOF
--- configure.orig 2009-11-05 20:50:33.000000000 +0100
+++ configure 2010-01-27 23:57:35.000000000 +0100
@@ -5891,7 +5891,7 @@
$as_echo_n "(cached) " >&6
else
- for am_cv_pathless_PYTHON in python python2 python3 python3.0 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 none; do
+ for am_cv_pathless_PYTHON in python python2 python3 python3.0 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 none; do
test "$am_cv_pathless_PYTHON" = none && break
prog="import sys
# split strings by '.' and convert to numeric. Append some zeros
@@ -6145,7 +6145,7 @@
$as_echo_n "(cached) " >&6
else
- for am_cv_pathless_PYTHON in python python2 python3 python3.0 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 none; do
+ for am_cv_pathless_PYTHON in python python2 python3 python3.0 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 none; do
test "$am_cv_pathless_PYTHON" = none && break
prog="import sys
# split strings by '.' and convert to numeric. Append some zeros
@@ -7161,6 +7161,7 @@
extern char pcap_version[];
int main() {
int major, minor1, minor2;

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ad,v 1.13 2009/04/01 07:56:19 apb Exp $
$NetBSD: patch-ad,v 1.14 2010/03/21 21:58:23 pettai Exp $
Correct handling of the length of data returned by SIOCGIFCONF. The
actual length of each item is never less than sizeof(struct ifreq), but
@ -24,38 +24,24 @@ had two problems:
sizeof(ifr->ifr_ifru). This assumption is incorrect on some
systems, at least on NetBSD.
--- tcpip.cc.orig 2008-09-04 14:41:59.000000000 +0000
+++ tcpip.cc
@@ -2890,12 +2890,10 @@ int sd;
ifr = (struct ifreq *) buf;
if (ifc.ifc_len == 0)
fatal("%s: SIOCGIFCONF claims you have no network interfaces!\n", __func__);
--- tcpip.cc.orig 2010-01-15 04:55:23.000000000 +0100
+++ tcpip.cc 2010-01-27 22:46:10.000000000 +0100
@@ -3053,12 +3053,13 @@
int rc;
char *p;
- /* On some platforms (such as FreeBSD), the length of each ifr changes
- based on the sockaddr type used, so we get the next length now. */
-#if HAVE_SOCKADDR_SA_LEN
- /* len = MAX(sizeof(struct sockaddr), ifr->ifr_addr.sa_len);*/
- len = ifr->ifr_addr.sa_len + sizeof(ifr->ifr_name);
-#else
+ /* On some platforms struct sockaddr has an sa_len member, if
+ ifr_ddr.sa_len is larger then sizeof ifr_ifru, then the actual
+ data extends beyond the end of ifr_ifru. */
len = sizeof(struct ifreq);
- /* len = sizeof(SA); */
+#if HAVE_SOCKADDR_SA_LEN
+ if (ifr->ifr_addr.sa_len > sizeof(ifr->ifr_ifru))
+ len = ifr->ifr_addr.sa_len > sizeof(ifr->ifr_name);
+ len += (ifr->ifr_addr.sa_len - sizeof(ifr->ifr_ifru));
#endif
/* Debugging code
@@ -2914,10 +2912,13 @@ int sd;
printf("ifr = %X\n",(unsigned)(*(char **)&ifr));
*/
- /* On some platforms (such as FreeBSD), the length of each ifr changes
- based on the sockaddr type used, so we get the next length now */
+ /* On platforms where struct sockaddr has an sa_len member, if
+ ifr_ddr.sa_len is larger then sizeof ifr_ifru, then the actual
+ data extends beyond the end of ifr_ifru. */
+ len = sizeof(struct ifreq);
#if HAVE_SOCKADDR_SA_LEN
- len = ifr->ifr_addr.sa_len + sizeof(ifr->ifr_name);
+ if (ifr->ifr_addr.sa_len > sizeof(ifr->ifr_ifru))
+ len += (ifr->ifr_addr.sa_len - sizeof(ifr->ifr_ifru));
#endif
/* skip any device with no name */
/* skip any device with no name */