Update to libtool 1.5.24:
- fix regression on DragonFly [patched before] - don't remove paths to uninstalled libs [patched before] - initial support for Sun compilers on Linux - better suport for GNU/kNetBSD and GNU/kFreeBSD - fixes for GCC multilib on x86_64 and similiar system. - documentation for --tag. - getconf ARG_MAX is used to find maximum argument length.
This commit is contained in:
parent
5dd321d92f
commit
ea96bde119
6 changed files with 1691 additions and 776 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.70 2007/04/18 16:31:18 tnn Exp $
|
||||
# $NetBSD: Makefile.common,v 1.71 2007/09/15 12:11:44 joerg Exp $
|
||||
|
||||
###########################################################################
|
||||
###########################################################################
|
||||
|
@ -23,7 +23,7 @@
|
|||
###########################################################################
|
||||
###########################################################################
|
||||
|
||||
DISTNAME= libtool-1.5.22
|
||||
DISTNAME= libtool-1.5.24
|
||||
CATEGORIES= devel pkgtools
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=libtool/}
|
||||
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.69 2006/12/15 11:28:51 dmcmahill Exp $
|
||||
$NetBSD: distinfo,v 1.70 2007/09/15 12:11:44 joerg Exp $
|
||||
|
||||
SHA1 (libtool-1.5.22.tar.gz) = 17353e66aeaac80ae188ea0a3a90609550ce3254
|
||||
RMD160 (libtool-1.5.22.tar.gz) = 7cbe793ee0509908daac928b4dc3a0f16f7293bf
|
||||
Size (libtool-1.5.22.tar.gz) = 2921483 bytes
|
||||
SHA1 (libtool-1.5.24.tar.gz) = b4c994f1bf4a76d2b0c1d0a6f54d16598c15f3db
|
||||
RMD160 (libtool-1.5.24.tar.gz) = e682fe6570c71d93ad65e0c6c77cb6558846f27d
|
||||
Size (libtool-1.5.24.tar.gz) = 2919557 bytes
|
||||
SHA1 (patch-aa) = 4c979de3439dfffa48295e094c1aee40c7e79fa6
|
||||
SHA1 (patch-ab) = 146f7c6a3c4b0863246cee70f0294765472bfbc8
|
||||
SHA1 (patch-ac) = 40d18dfe690ad7b76f1dae98df55fdc7e46ccd10
|
||||
SHA1 (patch-ad) = 70b560a1f419938a6d93358f3f74805df13de3b1
|
||||
SHA1 (patch-ab) = 5af35d31ba99ef2965de1ba4cb4614466c08d86d
|
||||
SHA1 (patch-ac) = 52f22f3f7a58e22d2240d0c6bb77455783ee5d70
|
||||
SHA1 (patch-ad) = 7b197a91d5d7b74c50648ef53e2e8116160189f0
|
||||
|
|
|
@ -1,19 +1,9 @@
|
|||
$NetBSD: manual-libtool.m4,v 1.20 2006/12/15 11:28:51 dmcmahill Exp $
|
||||
$NetBSD: manual-libtool.m4,v 1.21 2007/09/15 12:11:45 joerg Exp $
|
||||
|
||||
--- libtool.m4.orig 2005-12-18 21:53:17.000000000 +0000
|
||||
+++ libtool.m4 2006-12-12 21:49:49.000000000 +0000
|
||||
@@ -249,5 +249,9 @@
|
||||
esac
|
||||
done
|
||||
-cc_basename=`$echo "X$cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
|
||||
+
|
||||
+# Return the actual command name, not our pkgsrc wrapper name because several
|
||||
+# decisions are made only based on compiler names
|
||||
+new_cc_temp=`$cc_temp --wrappee-name 2>/dev/null` || new_cc_temp="$cc_temp"
|
||||
+cc_basename=`$echo "X$new_cc_temp" | $Xsed -e 's%.*/%%' -e "s%^$host_alias-%%"`
|
||||
])
|
||||
--- libtool.m4.orig 2007-06-24 04:19:11.000000000 +0200
|
||||
+++ libtool.m4
|
||||
@@ -402,11 +402,11 @@ else
|
||||
|
||||
@@ -393,9 +397,9 @@
|
||||
if test "X$echo" = Xecho; then
|
||||
# We didn't find a better echo, so look for alternatives.
|
||||
- if test "X`(print -r '\t') 2>/dev/null`" = 'X\t' &&
|
||||
|
@ -25,41 +15,67 @@ $NetBSD: manual-libtool.m4,v 1.20 2006/12/15 11:28:51 dmcmahill Exp $
|
|||
+ echo='print -r -'
|
||||
elif (test -f /bin/ksh || test -f /bin/ksh$ac_exeext) &&
|
||||
test "X$CONFIG_SHELL" != X/bin/ksh; then
|
||||
@@ -1290,4 +1294,5 @@
|
||||
# If we have ksh, try running configure again with it.
|
||||
@@ -1351,6 +1351,7 @@ beos*)
|
||||
bsdi[[45]]*)
|
||||
version_type=linux
|
||||
need_version=no
|
||||
+ need_lib_prefix=no
|
||||
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major $libname${shared_ext}'
|
||||
soname_spec='${libname}${release}${shared_ext}$major'
|
||||
@@ -1415,13 +1420,14 @@
|
||||
esac
|
||||
fi
|
||||
- version_type=freebsd-$objformat
|
||||
- case $version_type in
|
||||
- freebsd-elf*)
|
||||
finish_cmds='PATH="\$PATH:/sbin" ldconfig $libdir'
|
||||
@@ -1449,7 +1450,7 @@ freebsd1*)
|
||||
dynamic_linker=no
|
||||
;;
|
||||
|
||||
-freebsd* | dragonfly*)
|
||||
+freebsd*)
|
||||
# DragonFly does not have aout. When/if they implement a new
|
||||
# versioning mechanism, adjust this.
|
||||
if test -x /usr/bin/objformat; then
|
||||
@@ -1463,7 +1464,7 @@ freebsd* | dragonfly*)
|
||||
version_type=freebsd-$objformat
|
||||
case $version_type in
|
||||
freebsd-elf*)
|
||||
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
|
||||
+ version_type=linux
|
||||
+ case $objformat in
|
||||
+ elf*)
|
||||
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major $libname${shared_ext}'
|
||||
+ soname_spec='${libname}${release}${shared_ext}$major'
|
||||
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
|
||||
need_version=no
|
||||
need_lib_prefix=no
|
||||
;;
|
||||
- freebsd-*)
|
||||
- library_names_spec='${libname}${release}${shared_ext}$versuffix $libname${shared_ext}$versuffix'
|
||||
+ *)
|
||||
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix2'
|
||||
need_version=yes
|
||||
;;
|
||||
@@ -1441,5 +1447,5 @@
|
||||
hardcode_into_libs=yes
|
||||
;;
|
||||
- freebsd*) # from 4.6 on
|
||||
+ *) # from 4.6 on, and DragonFly
|
||||
shlibpath_overrides_runpath=yes
|
||||
hardcode_into_libs=yes
|
||||
@@ -1519,10 +1525,5 @@
|
||||
@@ -1493,6 +1494,16 @@ freebsd* | dragonfly*)
|
||||
esac
|
||||
;;
|
||||
|
||||
+dragonfly*)
|
||||
+ version_type=linux # XXX tv this should be =linux; current selection has problems
|
||||
+ need_version=no
|
||||
+ need_lib_prefix=no
|
||||
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
|
||||
+ shlibpath_var=LD_LIBRARY_PATH
|
||||
+ shlibpath_overrides_runpath=no
|
||||
+ hardcode_into_libs=yes
|
||||
+ ;;
|
||||
+
|
||||
gnu*)
|
||||
version_type=linux
|
||||
need_lib_prefix=no
|
||||
@@ -1561,15 +1572,22 @@ interix[[3-9]]*)
|
||||
hardcode_into_libs=yes
|
||||
;;
|
||||
|
||||
+interix3*)
|
||||
+ version_type=linux
|
||||
+ need_lib_prefix=no
|
||||
+ need_version=no
|
||||
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
|
||||
+ soname_spec='${libname}${release}${shared_ext}$major'
|
||||
+ dynamic_linker='Interix 3.x ld.so'
|
||||
+ shlibpath_var=LD_LIBRARY_PATH
|
||||
+ shlibpath_overrides_runpath=yes
|
||||
+ hardcode_into_libs=yes
|
||||
+ ;;
|
||||
+
|
||||
irix5* | irix6* | nonstopux*)
|
||||
case $host_os in
|
||||
nonstopux*) version_type=nonstopux ;;
|
||||
- *)
|
||||
|
@ -71,7 +87,9 @@ $NetBSD: manual-libtool.m4,v 1.20 2006/12/15 11:28:51 dmcmahill Exp $
|
|||
+ *) version_type=irix ;;
|
||||
esac
|
||||
need_lib_prefix=no
|
||||
@@ -1601,9 +1602,9 @@
|
||||
need_version=no
|
||||
@@ -1634,11 +1652,11 @@ linux* | k*bsd*-gnu)
|
||||
;;
|
||||
|
||||
netbsd*)
|
||||
- version_type=sunos
|
||||
|
@ -83,30 +101,65 @@ $NetBSD: manual-libtool.m4,v 1.20 2006/12/15 11:28:51 dmcmahill Exp $
|
|||
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix2'
|
||||
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
|
||||
dynamic_linker='NetBSD (a.out) ld.so'
|
||||
@@ -1636,5 +1637,5 @@
|
||||
else
|
||||
@@ -1663,13 +1681,14 @@ nto-qnx*)
|
||||
need_lib_prefix=no
|
||||
need_version=no
|
||||
library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major $libname${shared_ext}'
|
||||
+ dynamic_linker='QNX libc.so'
|
||||
soname_spec='${libname}${release}${shared_ext}$major'
|
||||
shlibpath_var=LD_LIBRARY_PATH
|
||||
shlibpath_overrides_runpath=yes
|
||||
;;
|
||||
|
||||
openbsd*)
|
||||
- version_type=sunos
|
||||
+ version_type=linux
|
||||
sys_lib_dlsearch_path_spec="/usr/lib"
|
||||
need_lib_prefix=no
|
||||
@@ -1644,5 +1645,5 @@
|
||||
# Some older versions of OpenBSD (3.3 at least) *do* need versioned libs.
|
||||
@@ -1677,7 +1696,7 @@ openbsd*)
|
||||
openbsd3.3 | openbsd3.3.*) need_version=yes ;;
|
||||
*) need_version=no ;;
|
||||
esac
|
||||
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix'
|
||||
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${shared_ext}$versuffix2'
|
||||
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
|
||||
finish_cmds='PATH="\$PATH:/sbin" ldconfig -m $libdir'
|
||||
shlibpath_var=LD_LIBRARY_PATH
|
||||
@@ -1833,7 +1834,5 @@
|
||||
if test -z "`echo __ELF__ | $CC -E - | grep __ELF__`" || test "$host_os-$host_cpu" = "openbsd2.8-powerpc"; then
|
||||
@@ -1871,9 +1890,7 @@ if test -f "$ltmain" && test -n "$tagnam
|
||||
|
||||
case $tagname in
|
||||
CXX)
|
||||
- if test -n "$CXX" && ( test "X$CXX" != "Xno" &&
|
||||
- ( (test "X$CXX" = "Xg++" && `g++ -v >/dev/null 2>&1` ) ||
|
||||
- (test "X$CXX" != "Xg++"))) ; then
|
||||
+ if test -n "$CXX" && test "X$CXX" != "Xno"; then
|
||||
+ if test -n "$CXX" && test "X$CXX" != "Xno" ; then
|
||||
AC_LIBTOOL_LANG_CXX_CONFIG
|
||||
else
|
||||
@@ -2581,20 +2580,8 @@
|
||||
tagname=""
|
||||
@@ -2392,6 +2409,10 @@ interix[[3-9]]*)
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[[^/]]+(\.so|\.a)$'
|
||||
;;
|
||||
|
||||
+interix3*)
|
||||
+ lt_cv_deplibs_check_method='match_pattern /lib[[^/]]+(\.so|\.a)$'
|
||||
+ ;;
|
||||
+
|
||||
irix5* | irix6* | nonstopux*)
|
||||
case $LD in
|
||||
*-32|*"-32 ") libmagic=32-bit;;
|
||||
@@ -2422,7 +2443,7 @@ newos6*)
|
||||
;;
|
||||
|
||||
nto-qnx*)
|
||||
- lt_cv_deplibs_check_method=unknown
|
||||
+ lt_cv_deplibs_check_method='match_pattern /lib[[^/]]+(\.so|S\.a)$'
|
||||
;;
|
||||
|
||||
openbsd*)
|
||||
@@ -2629,21 +2650,10 @@ AC_DEFUN([AC_LIBTOOL_CXX],
|
||||
# ---------------
|
||||
AC_DEFUN([_LT_AC_LANG_CXX],
|
||||
[AC_REQUIRE([AC_PROG_CXX])
|
||||
-AC_REQUIRE([_LT_AC_PROG_CXXCPP])
|
||||
|
@ -125,24 +178,37 @@ $NetBSD: manual-libtool.m4,v 1.20 2006/12/15 11:28:51 dmcmahill Exp $
|
|||
- AC_PROG_CXXCPP
|
||||
-fi
|
||||
-])# _LT_AC_PROG_CXXCPP
|
||||
-
|
||||
|
||||
# AC_LIBTOOL_F77
|
||||
# --------------
|
||||
@@ -2733,5 +2720,5 @@
|
||||
@@ -2781,7 +2791,7 @@ AC_DEFUN([AC_LIBTOOL_LANG_CXX_CONFIG], [
|
||||
AC_DEFUN([_LT_AC_LANG_CXX_CONFIG],
|
||||
[AC_LANG_PUSH(C++)
|
||||
AC_REQUIRE([AC_PROG_CXX])
|
||||
-AC_REQUIRE([_LT_AC_PROG_CXXCPP])
|
||||
+AC_REQUIRE([AC_PROG_CXXCPP])
|
||||
|
||||
_LT_AC_TAGVAR(archive_cmds_need_lc, $1)=no
|
||||
@@ -3081,5 +3068,5 @@
|
||||
_LT_AC_TAGVAR(module_cmds, $1)='$CC $allow_undefined_flag -o $lib -bundle $libobjs $deplibs$compiler_flags'
|
||||
# Don't fix this by using the ld -exported_symbols_list flag, it doesn't exist in older darwin lds
|
||||
- _LT_AC_TAGVAR(archive_expsym_cmds, $1)='sed -e "s,#.*,," -e "s,^[ ]*,," -e "s,^\(..*\),_&," < $export_symbols > $output_objdir/${libname}-symbols.expsym~$CC -qmkshrobj ${wl}-single_module $allow_undefined_flag -o $lib $libobjs $deplibs $compiler_flags ${wl}-install_name ${wl}$rpath/$soname $verstring~nmedit -s $output_objdir/${libname}-symbols.expsym ${lib}'
|
||||
+ _LT_AC_TAGVAR(archive_expsym_cmds, $1)='sed -e "s,#.*,," -e "s,^[ ]*,," -e "s,^\(..*\),_&," < $export_symbols > $output_objdir/${libname}-symbols.expsym~$CC -qmkshrobj ${wl}-single_module $allow_undefined_flag -o $lib $libobjs $deplibs $compiler_flags ${wl}-install_name ${wl}`echo $rpath/$soname` $verstring~nmedit -s $output_objdir/${libname}-symbols.expsym ${lib}'
|
||||
_LT_AC_TAGVAR(module_expsym_cmds, $1)='sed -e "s,#.*,," -e "s,^[ ]*,," -e "s,^\(..*\),_&," < $export_symbols > $output_objdir/${libname}-symbols.expsym~$CC $allow_undefined_flag -o $lib -bundle $libobjs $deplibs$compiler_flags~nmedit -s $output_objdir/${libname}-symbols.expsym ${lib}'
|
||||
;;
|
||||
@@ -3378,12 +3365,27 @@
|
||||
_LT_AC_TAGVAR(allow_undefined_flag, $1)=
|
||||
@@ -3294,6 +3304,16 @@ case $host_os in
|
||||
_LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--image-base,`expr ${RANDOM-$$} % 4096 / 2 \* 262144 + 1342177280` -o $lib'
|
||||
_LT_AC_TAGVAR(archive_expsym_cmds, $1)='sed "s,^,_," $export_symbols >$output_objdir/$soname.expsym~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--retain-symbols-file,$output_objdir/$soname.expsym ${wl}--image-base,`expr ${RANDOM-$$} % 4096 / 2 \* 262144 + 1342177280` -o $lib'
|
||||
;;
|
||||
+ interix3*)
|
||||
+ # Oy, what a hack.
|
||||
+ # Because shlibs are not compiled -fPIC due to broken code, we must
|
||||
+ # choose an --image-base. Otherwise, 0x10000000 will be chosen for
|
||||
+ # all libraries, leading to runtime relocations -- slow and very
|
||||
+ # memory consuming. To do this, we pick a random 256KB-aligned
|
||||
+ # start address between 0x50000000 and 0x6ffc0000 at link time.
|
||||
+ _LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared $libobjs $deplibs $compiler_flags ${wl}--image-base,$(($RANDOM %4096/2*262144+1342177280)) -o $lib'
|
||||
+ _LT_AC_TAGVAR(archive_expsym_cmds, $1)='sed s,^,_, $export_symbols >$output_objdir/$soname.exp && $CC -shared $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--retain-symbols-file $wl$output_objdir/$soname ${wl}--image-base,$(($RANDOM %4096/2*262144+1342177280)) -o $lib'
|
||||
+ ;;
|
||||
irix5* | irix6*)
|
||||
case $cc_basename in
|
||||
CC*)
|
||||
@@ -3447,14 +3467,29 @@ case $host_os in
|
||||
;;
|
||||
netbsd*)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
|
||||
+ # a.out is quite broken and goes directly to ld
|
||||
|
@ -172,18 +238,43 @@ $NetBSD: manual-libtool.m4,v 1.20 2006/12/15 11:28:51 dmcmahill Exp $
|
|||
- output_verbose_link_cmd='$CC -shared $CFLAGS -v conftest.$objext 2>&1 | grep conftest.$objext | $SED -e "s:-lgcc -lc -lgcc::"'
|
||||
;;
|
||||
openbsd2*)
|
||||
@@ -3873,4 +3875,10 @@
|
||||
;;
|
||||
# C++ shared libraries are fairly broken
|
||||
@@ -3767,6 +3802,11 @@ case $host_os in
|
||||
# FIXME: insert proper C++ library support
|
||||
_LT_AC_TAGVAR(ld_shlibs, $1)=no
|
||||
;;
|
||||
+ nto-qnx*)
|
||||
+ _LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
|
||||
+ _LT_AC_TAGVAR(archive_expsym_cmds, $1)='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
|
||||
+ output_verbose_link_cmd='echo'
|
||||
+ ;;
|
||||
*)
|
||||
# FIXME: insert proper C++ library support
|
||||
_LT_AC_TAGVAR(ld_shlibs, $1)=no
|
||||
@@ -3928,6 +3968,21 @@ if AC_TRY_EVAL(ac_compile); then
|
||||
esac
|
||||
done
|
||||
|
||||
+netbsd*)
|
||||
+ if test -n "$cpprt0_file"; then
|
||||
+ _LT_AC_TAGVAR(predep_objects,$1)=`eval echo $_LT_AC_TAGVAR(predep_objects,$1) | sed -e 's:/usr/lib/c++rt0.o:$cpprt0_file:'`
|
||||
+ fi
|
||||
+ ;;
|
||||
+ case "$host_os" in
|
||||
+ netbsd*)
|
||||
+ if test -n "$cpprt0_file"; then
|
||||
+ predep_objects_CXX=`eval echo $predep_objects_CXX | sed -e 's:/usr/lib/c++rt0.o:$cpprt0_file:'`
|
||||
+ fi
|
||||
+ ;;
|
||||
+ interix3*)
|
||||
+ # Interix installs completely hosed .la files for C++, so rather than
|
||||
+ # hack all around it, let's just trust "g++" to DTRT.
|
||||
+ predep_objects_CXX=
|
||||
+ postdep_objects_CXX=
|
||||
+ postdeps_CXX=
|
||||
+ ;;
|
||||
+ esac
|
||||
+
|
||||
solaris*)
|
||||
case $cc_basename in
|
||||
@@ -4848,7 +4856,9 @@
|
||||
# Clean up.
|
||||
rm -f a.out a.exe
|
||||
else
|
||||
@@ -4966,9 +5021,11 @@ AC_MSG_CHECKING([for $compiler option to
|
||||
_LT_AC_TAGVAR(lt_prog_compiler_pic, $1)='-DDLL_EXPORT'
|
||||
;;
|
||||
darwin* | rhapsody*)
|
||||
- # PIC is the default on this platform
|
||||
|
@ -194,7 +285,38 @@ $NetBSD: manual-libtool.m4,v 1.20 2006/12/15 11:28:51 dmcmahill Exp $
|
|||
+ _LT_AC_TAGVAR(lt_prog_compiler_static, $1)=''
|
||||
;;
|
||||
*djgpp*)
|
||||
@@ -5123,7 +5133,9 @@
|
||||
# DJGPP does not support shared libraries at all
|
||||
@@ -4994,6 +5051,10 @@ AC_MSG_CHECKING([for $compiler option to
|
||||
;;
|
||||
esac
|
||||
;;
|
||||
+ interix3*)
|
||||
+ # Interix 3.0-3.5 -fPIC option generates borked code.
|
||||
+ # (Instead, shlibs are relocated at runtime.)
|
||||
+ ;;
|
||||
*)
|
||||
_LT_AC_TAGVAR(lt_prog_compiler_pic, $1)='-fPIC'
|
||||
;;
|
||||
@@ -5072,6 +5133,8 @@ AC_MSG_CHECKING([for $compiler option to
|
||||
# This is c89, which is MS Visual C++ (no shared libs)
|
||||
# Anyone wants to do a port?
|
||||
;;
|
||||
+ interix3*)
|
||||
+ ;;
|
||||
irix5* | irix6* | nonstopux*)
|
||||
case $cc_basename in
|
||||
CC*)
|
||||
@@ -5211,6 +5274,8 @@ AC_MSG_CHECKING([for $compiler option to
|
||||
;;
|
||||
vxworks*)
|
||||
;;
|
||||
+ nto-qnx*)
|
||||
+ ;;
|
||||
*)
|
||||
_LT_AC_TAGVAR(lt_prog_compiler_can_build_shared, $1)=no
|
||||
;;
|
||||
@@ -5251,9 +5316,11 @@ AC_MSG_CHECKING([for $compiler option to
|
||||
;;
|
||||
|
||||
darwin* | rhapsody*)
|
||||
- # PIC is the default on this platform
|
||||
|
@ -205,10 +327,93 @@ $NetBSD: manual-libtool.m4,v 1.20 2006/12/15 11:28:51 dmcmahill Exp $
|
|||
+ _LT_AC_TAGVAR(lt_prog_compiler_static, $1)=''
|
||||
;;
|
||||
|
||||
@@ -5851,5 +5863,5 @@
|
||||
_LT_AC_TAGVAR(module_cmds, $1)='$CC $allow_undefined_flag -o $lib -bundle $libobjs $deplibs$compiler_flags'
|
||||
# Don't fix this by using the ld -exported_symbols_list flag, it doesn't exist in older darwin lds
|
||||
- _LT_AC_TAGVAR(archive_expsym_cmds, $1)='sed -e "s,#.*,," -e "s,^[ ]*,," -e "s,^\(..*\),_&," < $export_symbols > $output_objdir/${libname}-symbols.expsym~$CC -qmkshrobj $allow_undefined_flag -o $lib $libobjs $deplibs $compiler_flags ${wl}-install_name ${wl}$rpath/$soname $verstring~nmedit -s $output_objdir/${libname}-symbols.expsym ${lib}'
|
||||
+ _LT_AC_TAGVAR(archive_expsym_cmds, $1)='sed -e "s,#.*,," -e "s,^[ ]*,," -e "s,^\(..*\),_&," < $export_symbols > $output_objdir/${libname}-symbols.expsym~$CC -qmkshrobj $allow_undefined_flag -o $lib $libobjs $deplibs $compiler_flags ${wl}-install_name ${wl}`echo $rpath/$soname` $verstring~nmedit -s $output_objdir/${libname}-symbols.expsym ${lib}'
|
||||
_LT_AC_TAGVAR(module_expsym_cmds, $1)='sed -e "s,#.*,," -e "s,^[ ]*,," -e "s,^\(..*\),_&," < $export_symbols > $output_objdir/${libname}-symbols.expsym~$CC $allow_undefined_flag -o $lib -bundle $libobjs $deplibs$compiler_flags~nmedit -s $output_objdir/${libname}-symbols.expsym ${lib}'
|
||||
;;
|
||||
interix[[3-9]]*)
|
||||
@@ -5287,6 +5354,11 @@ AC_MSG_CHECKING([for $compiler option to
|
||||
esac
|
||||
;;
|
||||
|
||||
+ interix3*)
|
||||
+ # Interix 3.0-3.5 -fPIC option generates borked code.
|
||||
+ # (Instead, shlibs are relocated at runtime.)
|
||||
+ ;;
|
||||
+
|
||||
*)
|
||||
_LT_AC_TAGVAR(lt_prog_compiler_pic, $1)='-fPIC'
|
||||
;;
|
||||
@@ -5441,6 +5513,10 @@ AC_MSG_CHECKING([for $compiler option to
|
||||
_LT_AC_TAGVAR(lt_prog_compiler_static, $1)='-Bstatic'
|
||||
;;
|
||||
|
||||
+ nto-qnx*)
|
||||
+ _LT_AC_TAGVAR(lt_prog_compiler_pic, $1)='-fPIC'
|
||||
+ ;;
|
||||
+
|
||||
*)
|
||||
_LT_AC_TAGVAR(lt_prog_compiler_can_build_shared, $1)=no
|
||||
;;
|
||||
@@ -5719,6 +5795,17 @@ EOF
|
||||
fi
|
||||
;;
|
||||
|
||||
+ interix3*)
|
||||
+ # Oy, what a hack.
|
||||
+ # Because shlibs are not compiled -fPIC due to broken code, we must
|
||||
+ # choose an --image-base. Otherwise, 0x10000000 will be chosen for
|
||||
+ # all libraries, leading to runtime relocations -- slow and very
|
||||
+ # memory consuming. To do this, we pick a random 256KB-aligned
|
||||
+ # start address between 0x50000000 and 0x6ffc0000 at link time.
|
||||
+ _LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--image-base,$(($RANDOM %4096/2*262144+1342177280)) -o $lib'
|
||||
+ _LT_AC_TAGVAR(archive_expsym_cmds, $1)='sed s,^,_, $export_symbols >$output_objdir/$soname.exp && $CC -shared $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--retain-symbols-file $wl$output_objdir/$soname.exp ${wl}--image-base,$(($RANDOM %4096/2*262144+1342177280)) -o $lib'
|
||||
+ ;;
|
||||
+
|
||||
netbsd*)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ >/dev/null; then
|
||||
_LT_AC_TAGVAR(archive_cmds, $1)='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
|
||||
@@ -5784,6 +5871,11 @@ _LT_EOF
|
||||
_LT_AC_TAGVAR(hardcode_shlibpath_var, $1)=no
|
||||
;;
|
||||
|
||||
+ nto-qnx*)
|
||||
+ _LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
|
||||
+ _LT_AC_TAGVAR(archive_expsym_cmds, $1)='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
|
||||
+ ;;
|
||||
+
|
||||
*)
|
||||
if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then
|
||||
_LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
|
||||
@@ -6139,6 +6231,21 @@ _LT_EOF
|
||||
fi
|
||||
;;
|
||||
|
||||
+ interix3*)
|
||||
+ # Oy, what a hack.
|
||||
+ # Because shlibs are not compiled -fPIC due to broken code, we must
|
||||
+ # choose an --image-base. Otherwise, 0x10000000 will be chosen for
|
||||
+ # all libraries, leading to runtime relocations -- slow and very
|
||||
+ # memory consuming. To do this, we pick a random 256KB-aligned
|
||||
+ # start address between 0x50000000 and 0x6ffc0000 at link time.
|
||||
+ _LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared $libobjs $deplibs $compiler_flags ${wl}--image-base,$(($RANDOM %4096/2*262144+1342177280)) -o $lib'
|
||||
+ _LT_AC_TAGVAR(archive_expsym_cmds, $1)='sed s,^,_, $export_symbols >$output_objdir/$soname.exp && $CC -shared $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--retain-symbols-file $wl$output_objdir/$soname ${wl}--image-base,$(($RANDOM %4096/2*262144+1342177280)) -o $lib'
|
||||
+ _LT_AC_TAGVAR(export_dynamic_flag_spec, $1)='${wl}-E'
|
||||
+ _LT_AC_TAGVAR(hardcode_direct, $1)=yes
|
||||
+ _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}-h,$libdir'
|
||||
+ _LT_AC_TAGVAR(hardcode_shlibpath_var, $1)=no
|
||||
+ ;;
|
||||
+
|
||||
irix5* | irix6* | nonstopux*)
|
||||
if test "$GCC" = yes; then
|
||||
_LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname ${wl}$soname `test -n "$verstring" && echo ${wl}-set_version ${wl}$verstring` ${wl}-update_registry ${wl}${output_objdir}/so_locations -o $lib'
|
||||
@@ -6364,6 +6471,13 @@ _LT_EOF
|
||||
_LT_AC_TAGVAR(hardcode_shlibpath_var, $1)=no
|
||||
;;
|
||||
|
||||
+ nto-qnx*)
|
||||
+ _LT_AC_TAGVAR(archive_cmds, $1)='$LD -shared -o $lib $libobjs $deplibs $linker_flags'
|
||||
+ _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='-R$libdir'
|
||||
+ _LT_AC_TAGVAR(hardcode_direct, $1)=yes
|
||||
+ _LT_AC_TAGVAR(hardcode_shlibpath_var, $1)=no
|
||||
+ ;;
|
||||
+
|
||||
*)
|
||||
_LT_AC_TAGVAR(ld_shlibs, $1)=no
|
||||
;;
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.22 2006/08/23 19:49:12 jschauma Exp $
|
||||
$NetBSD: patch-ac,v 1.23 2007/09/15 12:11:45 joerg Exp $
|
||||
|
||||
--- ltmain.sh.orig Sun Dec 18 17:14:54 2005
|
||||
+++ ltmain.sh Wed Aug 23 15:40:14 2006
|
||||
@@ -226,6 +226,31 @@
|
||||
--- ltmain.sh.orig 2007-06-24 04:22:04.000000000 +0200
|
||||
+++ ltmain.sh
|
||||
@@ -244,6 +244,31 @@ func_win32_libid ()
|
||||
# arg is usually of the form 'gcc ...'
|
||||
func_infer_tag ()
|
||||
{
|
||||
|
@ -34,7 +34,7 @@ $NetBSD: patch-ac,v 1.22 2006/08/23 19:49:12 jschauma Exp $
|
|||
if test -n "$available_tags" && test -z "$tagname"; then
|
||||
CC_quoted=
|
||||
for arg in $CC; do
|
||||
@@ -266,7 +291,28 @@
|
||||
@@ -284,6 +309,27 @@ func_infer_tag ()
|
||||
break
|
||||
;;
|
||||
esac
|
||||
|
@ -58,12 +58,11 @@ $NetBSD: patch-ac,v 1.22 2006/08/23 19:49:12 jschauma Exp $
|
|||
+ if test -n "$tagname"; then
|
||||
+ break
|
||||
+ fi
|
||||
fi
|
||||
+ fi
|
||||
fi
|
||||
done
|
||||
# If $tagname still isn't set, then no tagged configuration
|
||||
# was found and let the user know that the "--tag" command
|
||||
@@ -568,7 +614,7 @@
|
||||
@@ -597,7 +643,7 @@ if test -z "$show_help"; then
|
||||
$echo "*** Warning: inferring the mode of operation is deprecated." 1>&2
|
||||
$echo "*** Future versions of Libtool will require --mode=MODE be specified." 1>&2
|
||||
case $nonopt in
|
||||
|
@ -72,7 +71,7 @@ $NetBSD: patch-ac,v 1.22 2006/08/23 19:49:12 jschauma Exp $
|
|||
mode=link
|
||||
for arg
|
||||
do
|
||||
@@ -1375,6 +1421,13 @@
|
||||
@@ -1414,6 +1460,13 @@ EOF
|
||||
exit $EXIT_FAILURE
|
||||
;;
|
||||
esac
|
||||
|
@ -86,7 +85,7 @@ $NetBSD: patch-ac,v 1.22 2006/08/23 19:49:12 jschauma Exp $
|
|||
if test "$prev" = rpath; then
|
||||
case "$rpath " in
|
||||
*" $arg "*) ;;
|
||||
@@ -1604,6 +1657,12 @@
|
||||
@@ -1643,6 +1696,12 @@ EOF
|
||||
compiler_flags="$compiler_flags $arg"
|
||||
compile_command="$compile_command $arg"
|
||||
finalize_command="$finalize_command $arg"
|
||||
|
@ -99,7 +98,7 @@ $NetBSD: patch-ac,v 1.22 2006/08/23 19:49:12 jschauma Exp $
|
|||
continue
|
||||
;;
|
||||
|
||||
@@ -2101,6 +2160,30 @@
|
||||
@@ -2141,6 +2200,30 @@ EOF
|
||||
else
|
||||
compiler_flags="$compiler_flags $deplib"
|
||||
fi
|
||||
|
@ -130,16 +129,7 @@ $NetBSD: patch-ac,v 1.22 2006/08/23 19:49:12 jschauma Exp $
|
|||
continue
|
||||
;;
|
||||
-l*)
|
||||
@@ -3197,7 +3280,7 @@
|
||||
age="0"
|
||||
;;
|
||||
irix|nonstopux)
|
||||
- current=`expr $number_major + $number_minor - 1`
|
||||
+ current=`expr $number_major + $number_minor`
|
||||
age="$number_minor"
|
||||
revision="$number_minor"
|
||||
;;
|
||||
@@ -3247,6 +3330,7 @@
|
||||
@@ -3290,6 +3373,7 @@ EOF
|
||||
# Calculate the version variables.
|
||||
major=
|
||||
versuffix=
|
||||
|
@ -147,7 +137,7 @@ $NetBSD: patch-ac,v 1.22 2006/08/23 19:49:12 jschauma Exp $
|
|||
verstring=
|
||||
case $version_type in
|
||||
none) ;;
|
||||
@@ -3296,6 +3380,7 @@
|
||||
@@ -3343,6 +3427,7 @@ EOF
|
||||
linux)
|
||||
major=.`expr $current - $age`
|
||||
versuffix="$major.$age.$revision"
|
||||
|
@ -155,7 +145,7 @@ $NetBSD: patch-ac,v 1.22 2006/08/23 19:49:12 jschauma Exp $
|
|||
;;
|
||||
|
||||
osf)
|
||||
@@ -3358,6 +3443,7 @@
|
||||
@@ -3405,6 +3490,7 @@ EOF
|
||||
if test "$avoid_version" = yes && test "$need_version" = no; then
|
||||
major=
|
||||
versuffix=
|
||||
|
@ -163,27 +153,7 @@ $NetBSD: patch-ac,v 1.22 2006/08/23 19:49:12 jschauma Exp $
|
|||
verstring=""
|
||||
fi
|
||||
|
||||
@@ -3409,12 +3495,13 @@
|
||||
oldobjs="$objs "`$echo "X$libobjs" | $SP2NL | $Xsed -e '/\.'${libext}'$/d' -e "$lo2o" | $NL2SP`
|
||||
fi
|
||||
|
||||
- # Eliminate all temporary directories.
|
||||
- for path in $notinst_path; do
|
||||
- lib_search_path=`$echo "$lib_search_path " | ${SED} -e "s% $path % %g"`
|
||||
- deplibs=`$echo "$deplibs " | ${SED} -e "s% -L$path % %g"`
|
||||
- dependency_libs=`$echo "$dependency_libs " | ${SED} -e "s% -L$path % %g"`
|
||||
- done
|
||||
+ ### Commented out in pkgsrc, since it is completely broken.
|
||||
+ ## Eliminate all temporary directories.
|
||||
+ #for path in $notinst_path; do
|
||||
+ # lib_search_path=`$echo "$lib_search_path " | ${SED} -e "s% $path % %g"`
|
||||
+ # deplibs=`$echo "$deplibs " | ${SED} -e "s% -L$path % %g"`
|
||||
+ # dependency_libs=`$echo "$dependency_libs " | ${SED} -e "s% -L$path % %g"`
|
||||
+ #done
|
||||
|
||||
if test -n "$xrpath"; then
|
||||
# If the user specified any rpath flags, then add them.
|
||||
@@ -5820,8 +5907,16 @@
|
||||
@@ -5883,8 +5969,16 @@ relink_command=\"$relink_command\""
|
||||
exit $EXIT_FAILURE
|
||||
fi
|
||||
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue