bam: Update to 0.5.1

- Fixed issues with CC environment variables
- Out of bounds fixed to debug output and output cache ( RyanLucchese )
- Solaris compiler support ( RyanLucchese )
- XLC compiler support ( RyanLucchese )
- Fixed parallel build with make ( hasufell )
- Syntax hilighting for the readme ( mailaender )
- Upgraded to Lua 5.3.3 from 5.1
- More accurate cache to reduce recompiles when switching parameters
- Make use of CC environment variables when available by default
- Build should now be reproducable and not add date or timestamps into the executable
- Bug-fixes
This commit is contained in:
nia 2019-07-01 13:39:43 +00:00
parent 08fcad9a1e
commit eac5d50f51
4 changed files with 11 additions and 65 deletions

View file

@ -1,14 +1,12 @@
# $NetBSD: Makefile,v 1.2 2015/09/12 20:03:01 tnn Exp $
# $NetBSD: Makefile,v 1.3 2019/07/01 13:39:43 nia Exp $
DISTNAME= bam-0.4.0
DISTNAME= bam-0.5.1
CATEGORIES= devel
MASTER_SITES= https://cloud.github.com/downloads/matricks/bam/
MASTER_SITES+= http://penenen.de/
#enable when updating next time
#EXTRACT_SUFX= .tar.bz2
MASTER_SITES= ${MASTER_SITE_GITHUB:=matricks/}
GITHUB_TAG= v${PKGVERSION_NOREV}
MAINTAINER= fstd.lkml@gmail.com
HOMEPAGE= http://matricks.github.io/bam/
HOMEPAGE= https://matricks.github.io/bam/
COMMENT= Fast and flexible LUA-driven build system
LICENSE= zlib
@ -18,7 +16,7 @@ INSTALLATION_DIRS= bin
do-build:
set -e; cd ${WRKSRC}; \
./make_unix.sh
CC=${CC:Q} ./make_unix.sh
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bam ${DESTDIR}${PREFIX}/bin/bam

View file

@ -1,8 +1,6 @@
$NetBSD: distinfo,v 1.2 2015/11/03 03:27:16 agc Exp $
$NetBSD: distinfo,v 1.3 2019/07/01 13:39:43 nia Exp $
SHA1 (bam-0.4.0.tar.gz) = c0f32ff9272d5552e02a9d68fbdd72106437ee69
RMD160 (bam-0.4.0.tar.gz) = cbb8d56c891e650f0a14c9a55efc4e9cc96e0e28
SHA512 (bam-0.4.0.tar.gz) = c599cdf3618d317a5d304febd2e59d1116fc5819cdaf49969fdc25f88ed8f3e25831861c0c7fea05059d8af7085b654a7732bd89086bc166661b932d168ee2ca
Size (bam-0.4.0.tar.gz) = 206780 bytes
SHA1 (patch-make_unix.sh) = 0a0ab4a7bd904ffceb4a06109624071478e19017
SHA1 (patch-src_platform.h) = 35e306fbd7ed9f20748491d4a0b9c5446a95eb67
SHA1 (bam-0.5.1.tar.gz) = b30b4f640406c285527e2130818c48c721276ef7
RMD160 (bam-0.5.1.tar.gz) = 7bbfc8b31949381b445bd6113f06fa3cc32d959c
SHA512 (bam-0.5.1.tar.gz) = e6f1b3daad6073c58b0e3cbf836bb0a6b66f0c36532d6e6eca9949239ab8b584cc88f892cce6f74974e370a8a688f33a95dde86dd65cc1790e49e5f8aeab0fef
Size (bam-0.5.1.tar.gz) = 258693 bytes

View file

@ -1,24 +0,0 @@
$NetBSD: patch-make_unix.sh,v 1.1 2015/09/12 18:51:07 wiz Exp $
===========================================================================
This patch avoids compiling bam with -ldl because the BSDs have it in libc.
Upstream has already addressed this in their development branch, so this
patch should become unnecessary with later versions.
===========================================================================
--- make_unix.sh.orig 2010-08-09 20:08:24.000000000 +0200
+++ make_unix.sh 2015-09-12 03:56:22.000000000 +0200
@@ -1,4 +1,10 @@
#!/bin/sh
gcc -Wall -ansi -pedantic src/tools/txt2c.c -o src/tools/txt2c
src/tools/txt2c src/base.lua src/tools.lua src/driver_gcc.lua src/driver_cl.lua > src/internal_base.h
-gcc -Wall -ansi -pedantic src/*.c src/lua/*.c -o bam -I src/lua -lm -lpthread -ldl -O2 -rdynamic $*
+
+case "$(uname)" in
+ *BSD) ldl= ;;
+ *) ldl='-ldl' ;;
+esac
+
+gcc -Wall -ansi -pedantic src/*.c src/lua/*.c -o bam -I src/lua -lm -lpthread $ldl -O2 -rdynamic $*

View file

@ -1,26 +0,0 @@
$NetBSD: patch-src_platform.h,v 1.1 2015/09/12 18:51:07 wiz Exp $
======================================================
This patch adds NetBSD as a known platform.
It has been submitted upstream.
https://github.com/matricks/bam/pull/84/ (2nd commit)
======================================================
--- src/platform.h.orig 2010-08-09 20:08:24.000000000 +0200
+++ src/platform.h 2015-09-12 03:51:29.000000000 +0200
@@ -34,6 +34,13 @@
#define BAM_PLATFORM_STRING "openbsd"
#endif
+#if defined(__NetBSD__)
+ #define BAM_FAMILY_UNIX
+ #define BAM_FAMILY_STRING "unix"
+ #define BAM_PLATFORM_NETBSD
+ #define BAM_PLATFORM_STRING "netbsd"
+#endif
+
#if defined(__LINUX__) || defined(__linux__)
#define BAM_FAMILY_UNIX
#define BAM_FAMILY_STRING "unix"