security: Remove sslwrap. Breaks with OpenSSL 1.1, no release since 2000

This commit is contained in:
nia 2020-03-01 17:25:25 +00:00
parent 01b1860ae5
commit eae692c7f9
8 changed files with 1 additions and 126 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.740 2020/03/01 17:22:55 nia Exp $
# $NetBSD: Makefile,v 1.741 2020/03/01 17:25:25 nia Exp $
#
COMMENT= Security tools
@ -602,7 +602,6 @@ SUBDIR+= sshpass
SUBDIR+= ssldump
SUBDIR+= sslproxy
SUBDIR+= sslsplit
SUBDIR+= sslwrap
SUBDIR+= ssss
SUBDIR+= starttls
SUBDIR+= steghide

View file

@ -1,8 +0,0 @@
sslwrap is a simple Unix service that sits over any simple TCP service
such as POP3, IMAP, SMTP, and encrypts all of the data on the connection
using TLS/SSL. It uses openssl to support SSL version 2 and 3. It can run
out of inetd. It can also encrypt data for services located on another
computer.
It works with the servers you already have, and does not require any
modifications to your existing servers.

View file

@ -1,32 +0,0 @@
# $NetBSD: Makefile,v 1.32 2020/01/18 21:50:48 jperkin Exp $
DISTNAME= ${PKGNAME_NOREV:S/-//}
PKGNAME= sslwrap-206
PKGREVISION= 9
CATEGORIES= security net
MASTER_SITES= http://www.rickk.com/sslwrap/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.rickk.com/sslwrap/
COMMENT= Simple SSL wrapper
OPSYSVARS+= LDADD
LDADD.SunOS= -lnsl -lsocket
MAKE_ENV+= LDADD=${LDADD:Q}
USE_BSD_MAKEFILE= yes
.include "../../security/openssl/buildlink3.mk"
.if !exists(${BUILDLINK_PREFIX.openssl}/include/openssl/e_os.h)
CFLAGS+= -DFLAT_INC
.endif
SUBST_CLASSES+= sslwrap
SUBST_MESSAGE.sslwrap= Adjusting the path for include files
SUBST_STAGE.sslwrap= do-configure
SUBST_FILES.sslwrap= apps.h s_cb.c s_server.c s_socket.c
SUBST_SED.sslwrap= -e 's|OPENSSL"|"openssl/|'
INSTALLATION_DIRS= sbin
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +0,0 @@
@comment $NetBSD: PLIST,v 1.1 2001/11/01 01:17:56 zuntum Exp $
sbin/sslwrap

View file

@ -1,9 +0,0 @@
$NetBSD: distinfo,v 1.7 2015/11/04 01:18:11 agc Exp $
SHA1 (sslwrap206.tar.gz) = fc8a4a4134d2668705f9fc4ac92a45a847c3edf9
RMD160 (sslwrap206.tar.gz) = 9b212acc6df16cded31ec6e85de8360ed99b9969
SHA512 (sslwrap206.tar.gz) = 627c25bdf45245f9b3e8d03272fc46a0ef8d1c356e2b7990898b07267c2bbb28efd13d5ca97d330ce7369eedd2d20b5fa781f2e1a00ac732407e06d0b3a8890d
Size (sslwrap206.tar.gz) = 21170 bytes
SHA1 (patch-aa) = 1a90645c6a3a43829181d44205fd07e87f4b9f6a
SHA1 (patch-ab) = 7f28cb5eca2a004408cb20aa365edad0d4f7d45a
SHA1 (patch-ac) = 7ffb5a45843d8d4d99867967547663ef7656bd32

View file

@ -1,46 +0,0 @@
$NetBSD: patch-aa,v 1.5 2004/02/08 13:44:12 grant Exp $
--- Makefile.orig 2000-11-12 09:01:25.000000000 +1100
+++ Makefile
@@ -1,28 +1,15 @@
+PROG= sslwrap
+SRCS= s_server.c s_socket.c s_cb.c
+LDADD+= -lssl -lcrypto
+MAN=
+
+.if defined(PREFIX)
+BINDIR= ${PREFIX}/sbin
+LIBDIR= ${PREFIX}/lib
+MANDIR= ${PREFIX}/man
+DOCDIR= ${PREFIX}/share/doc
+.endif
-SRC = s_server.c s_socket.c s_cb.c
-
-# For Solaris2.6
-#EXTLIBS = -lxnet
-
-# Debug/Optimizations
-#OPT = -g
-OPT = -O2
-
-# Define
-OPENSSL="\"openssl/\""
-#OPENSSL=""
-
-all :
- gcc -o sslwrap ${SRC} ${OPT} -DFLAT_INC -DOPENSSL=${OPENSSL} \
- -L/usr/local/ssl/lib -lssl -lcrypto \
- -I/usr/local/ssl/include \
- ${EXTLIBS}
-
-clean:
- rm -f sslwrap *.o *~
-
-
-
-
-
+NOGCCERROR=1
+.include <bsd.prog.mk>

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.2 2000/12/30 20:12:18 rh Exp $
--- apps.h.orig Sat Nov 11 23:01:25 2000
+++ apps.h
@@ -62,7 +62,7 @@
#ifdef FLAT_INC
#include "e_os.h"
#else
-#include "../e_os.h"
+#include OPENSSL"e_os.h"
#endif
#include OPENSSL"buffer.h"

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ac,v 1.1 2003/09/18 04:09:19 jmc Exp $
--- s_server.c.orig 2003-09-17 23:01:01.000000000 +0000
+++ s_server.c 2003-09-17 23:01:22.000000000 +0000
@@ -468,7 +468,9 @@
if (bugs) SSL_CTX_set_options(ctx,SSL_OP_ALL);
if (hack) SSL_CTX_set_options(ctx,SSL_OP_NETSCAPE_DEMO_CIPHER_CHANGE_BUG);
+#if defined(SSL_OP_NON_EXPORT_FIRST)
if (hack) SSL_CTX_set_options(ctx,SSL_OP_NON_EXPORT_FIRST);
+#endif
if (state) SSL_CTX_set_info_callback(ctx,apps_ssl_info_callback);