Update databases/elasticsearch to 2.0.0.
Breaking changes - Remove option to configure custom config file via CONF_FILE or -Des.default.conf Deprecations - Deprecate index.analysis.analyzer.default_index in favor of index.analysis.analyzer.default. Enhancements - Make PerThreadIDAndVersionLookup per-segment - TransportNodesAction shouldn't hold on to cluster state - Packaging: change permissions/ownership of config dir - Release: Fix package repo path to only consist of major version - Plugin Cloud GCE: Add _gce_ network host setting - Check "plugin already installed" before jar hell check. - Plugin script to set proper plugin bin dir attributes - Plugin script to set proper plugin config dir attributes Bug fixes - CRUD: Send response for update request when it timed out - Engine: Never wrap searcher for internal engine operations - Fielddata: Add GeoPoint in StreamInput/StreamOutput - Properly bind ClassSet extensions as singletons - Streamline top level reader close listeners and forbid general usage - Settings in log config file should not overwrite custom parameters - Plugin cli tool should not create empty log files - Mappings: Enforce metadata fields are not passed in documents - Plugin Cloud AWS: Discovery-ec2 plugin should check discovery.type - Parse Java system properties in plugin.bat - PluginManager: Dont leave leftover files on unsuccessful installs - REST: Restore support for escaped '/' as part of document id - REST: Add missing REST spec for detect_noop - REST: Expose nodes operation timeout in REST API - REST: Ensure XContent is consistent across platforms - Shadow Replicas: Don't pull translog from shadow engine - Snapshot restore operations throttle more than specified Upgrades - Upgrade Netty to 3.10.5.final NOT CLASSIFIED - [DOCS] terminate_after is not experimental anymore - Remove unused clear(IndexReader) method from IndexFieldData - changed ben to been - move render search template methods to cluster admin client - Docs: Document ES_CLASSPATH removal in breaking changes - Rewrite native script documentation - Docs: Update repository docs with new major version structure - Add a note about shard failure in the api
This commit is contained in:
parent
45f4dcd023
commit
eaffcefb7d
8 changed files with 123 additions and 136 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.12 2015/10/18 16:02:05 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2015/11/12 15:37:07 fhajny Exp $
|
||||
|
||||
DISTNAME= elasticsearch-1.7.3
|
||||
DISTNAME= elasticsearch-2.0.0
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= https://download.elasticsearch.org/elasticsearch/elasticsearch/
|
||||
|
||||
|
@ -15,48 +15,17 @@ USE_JAVA2= yes
|
|||
NO_BUILD= yes
|
||||
|
||||
PKG_SYSCONFSUBDIR= elasticsearch
|
||||
EXDIR= ${PREFIX}/share/examples/elasticsearch
|
||||
EGDIR= ${PREFIX}/share/elasticsearch
|
||||
EGDIR= ${PREFIX}/share/examples/elasticsearch
|
||||
|
||||
CONFS= elasticsearch.yml logging.yml
|
||||
.for f in ${CONFS}
|
||||
CONF_FILES+= ${EXDIR}/${f} ${PKG_SYSCONFDIR}/${f}
|
||||
CONF_FILES+= ${EGDIR}/${f} ${PKG_SYSCONFDIR}/${f}
|
||||
.endfor
|
||||
DOCS= LICENSE.txt NOTICE.txt README.textile
|
||||
BINS= elasticsearch elasticsearch.in.sh plugin
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if !empty(MACHINE_PLATFORM:MDarwin-*-i386)
|
||||
SIGAR_PLATFORM= universal-macosx
|
||||
.elif !empty(MACHINE_PLATFORM:MDarwin-*-x86_64)
|
||||
SIGAR_PLATFORM= universal64-macosx
|
||||
.elif !empty(MACHINE_PLATFORM:MFreeBSD-5*-i386)
|
||||
SIGAR_PLATFORM= x86-freebsd-5
|
||||
.elif !empty(MACHINE_PLATFORM:MFreeBSD-6*-i386)
|
||||
SIGAR_PLATFORM= x86-freebsd-6
|
||||
.elif !empty(MACHINE_PLATFORM:MFreeBSD-6*-x86_64)
|
||||
SIGAR_PLATFORM= amd64-freebsd-6
|
||||
.elif !empty(MACHINE_PLATFORM:MLinux-*-i386)
|
||||
SIGAR_PLATFORM= x86-linux
|
||||
.elif !empty(MACHINE_PLATFORM:MLinux-*-x86_64)
|
||||
SIGAR_PLATFORM= amd64-linux
|
||||
.elif !empty(MACHINE_PLATFORM:MSunOS-*-i386)
|
||||
SIGAR_PLATFORM= x86-solaris
|
||||
.elif !empty(MACHINE_PLATFORM:MSunOS-*-sparc)
|
||||
SIGAR_PLATFORM= sparc-solaris
|
||||
.elif !empty(MACHINE_PLATFORM:MSunOS-*-sparc64)
|
||||
SIGAR_PLATFORM= sparc64-solaris
|
||||
.elif !empty(MACHINE_PLATFORM:MSunOS-*-x86_64)
|
||||
SIGAR_PLATFORM= amd64-solaris
|
||||
.endif
|
||||
|
||||
.if ${_OPSYS_SHLIB_TYPE} == "dylib"
|
||||
SHLIB_EXT= dylib
|
||||
.else
|
||||
SHLIB_EXT= so
|
||||
.endif
|
||||
|
||||
BUILD_DEFS+= ES_USER ES_GROUP ES_DBDIR ES_LOGDIR ES_PIDDIR ES_TMPDIR
|
||||
|
||||
ES_USER?= elasticsearch
|
||||
|
@ -80,19 +49,13 @@ FILES_SUBST+= JAVA_HOME=${PKG_JAVA_HOME} ES_USER=${ES_USER} \
|
|||
|
||||
RCD_SCRIPTS= elasticsearch
|
||||
|
||||
OWN_DIRS+= ${ES_LIBDIR}/plugins
|
||||
OWN_DIRS_PERMS+= ${ES_LOGDIR} ${ES_USER} ${ES_GROUP} 0700
|
||||
OWN_DIRS_PERMS+= ${ES_DBDIR} ${ES_USER} ${ES_GROUP} 0700
|
||||
OWN_DIRS_PERMS+= ${ES_TMPDIR} ${ES_USER} ${ES_GROUP} 0700
|
||||
INSTALLATION_DIRS+= ${EXDIR} ${ES_LIBDIR} ${PREFIX}/share/doc/elasticsearch
|
||||
INSTALLATION_DIRS+= ${ES_LIBDIR}/plugins ${EGDIR}
|
||||
|
||||
PLIST_VARS+= sigar
|
||||
.if !empty(SIGAR_PLATFORM)
|
||||
PLIST.sigar= yes
|
||||
PLIST_SUBST+= SIGAR_FILE=libsigar-${SIGAR_PLATFORM}.${SHLIB_EXT}
|
||||
PRINT_PLIST_AWK+= {gsub(/libsigar-$(SIGAR_PLATFORM).$(SHLIB_EXT)/,"$${SIGAR_FILE}", $$0);}
|
||||
INSTALLATION_DIRS+= ${ES_LIBDIR}/sigar
|
||||
.endif
|
||||
MAKE_DIRS+= ${PKG_SYSCONFDIR}/scripts
|
||||
INSTALLATION_DIRS+= ${ES_LIBDIR} ${PREFIX}/libexec/elasticsearch
|
||||
INSTALLATION_DIRS+= ${EGDIR} ${PREFIX}/share/doc/elasticsearch
|
||||
|
||||
SUBST_CLASSES+= paths
|
||||
SUBST_STAGE.paths= pre-configure
|
||||
|
@ -101,7 +64,7 @@ SUBST_VARS.paths= PKG_JAVA_HOME PKG_SYSCONFDIR PREFIX ES_DBDIR ES_LIBDIR ES_LOGD
|
|||
|
||||
do-install:
|
||||
.for f in ${CONFS}
|
||||
${INSTALL_DATA} ${WRKSRC}/config/${f} ${DESTDIR}${EXDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/config/${f} ${DESTDIR}${EGDIR}
|
||||
.endfor
|
||||
.for f in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} \
|
||||
|
@ -109,13 +72,9 @@ do-install:
|
|||
.endfor
|
||||
.for f in ${BINS}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} \
|
||||
${DESTDIR}${PREFIX}/share/elasticsearch
|
||||
${DESTDIR}${PREFIX}/libexec/elasticsearch
|
||||
.endfor
|
||||
${INSTALL_DATA} ${WRKSRC}/lib/*.jar ${DESTDIR}${ES_LIBDIR}
|
||||
.if !empty(SIGAR_PLATFORM)
|
||||
${INSTALL_DATA} ${WRKSRC}/lib/sigar/sigar-*.jar ${DESTDIR}${ES_LIBDIR}/sigar/
|
||||
${INSTALL_LIB} ${WRKSRC}/lib/sigar/libsigar-${SIGAR_PLATFORM}.${SHLIB_EXT} ${DESTDIR}${ES_LIBDIR}/sigar/
|
||||
.endif
|
||||
|
||||
.include "../../mk/java-vm.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,34 +1,49 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2015/08/03 11:57:43 fhajny Exp $
|
||||
@comment $NetBSD: PLIST,v 1.7 2015/11/12 15:37:07 fhajny Exp $
|
||||
lib/elasticsearch/HdrHistogram-2.1.6.jar
|
||||
lib/elasticsearch/antlr-runtime-3.5.jar
|
||||
lib/elasticsearch/apache-log4j-extras-1.2.17.jar
|
||||
lib/elasticsearch/asm-4.1.jar
|
||||
lib/elasticsearch/asm-commons-4.1.jar
|
||||
lib/elasticsearch/commons-cli-1.3.1.jar
|
||||
lib/elasticsearch/compiler-0.8.13.jar
|
||||
lib/elasticsearch/compress-lzf-1.0.2.jar
|
||||
lib/elasticsearch/${PKGNAME}.jar
|
||||
lib/elasticsearch/groovy-all-2.4.4.jar
|
||||
lib/elasticsearch/groovy-all-2.4.4-indy.jar
|
||||
lib/elasticsearch/guava-18.0.jar
|
||||
lib/elasticsearch/hppc-0.7.1.jar
|
||||
lib/elasticsearch/jackson-core-2.5.3.jar
|
||||
lib/elasticsearch/jackson-dataformat-cbor-2.5.3.jar
|
||||
lib/elasticsearch/jackson-dataformat-smile-2.5.3.jar
|
||||
lib/elasticsearch/jackson-dataformat-yaml-2.5.3.jar
|
||||
lib/elasticsearch/jna-4.1.0.jar
|
||||
lib/elasticsearch/joda-convert-1.2.jar
|
||||
lib/elasticsearch/joda-time-2.8.2.jar
|
||||
lib/elasticsearch/jsr166e-1.1.0.jar
|
||||
lib/elasticsearch/jts-1.13.jar
|
||||
lib/elasticsearch/log4j-1.2.17.jar
|
||||
lib/elasticsearch/lucene-analyzers-common-4.10.4.jar
|
||||
lib/elasticsearch/lucene-core-4.10.4.jar
|
||||
lib/elasticsearch/lucene-expressions-4.10.4.jar
|
||||
lib/elasticsearch/lucene-grouping-4.10.4.jar
|
||||
lib/elasticsearch/lucene-highlighter-4.10.4.jar
|
||||
lib/elasticsearch/lucene-join-4.10.4.jar
|
||||
lib/elasticsearch/lucene-memory-4.10.4.jar
|
||||
lib/elasticsearch/lucene-misc-4.10.4.jar
|
||||
lib/elasticsearch/lucene-queries-4.10.4.jar
|
||||
lib/elasticsearch/lucene-queryparser-4.10.4.jar
|
||||
lib/elasticsearch/lucene-sandbox-4.10.4.jar
|
||||
lib/elasticsearch/lucene-spatial-4.10.4.jar
|
||||
lib/elasticsearch/lucene-suggest-4.10.4.jar
|
||||
${PLIST.sigar}lib/elasticsearch/sigar/${SIGAR_FILE}
|
||||
${PLIST.sigar}lib/elasticsearch/sigar/sigar-1.6.4.jar
|
||||
lib/elasticsearch/lucene-analyzers-common-5.2.1.jar
|
||||
lib/elasticsearch/lucene-backward-codecs-5.2.1.jar
|
||||
lib/elasticsearch/lucene-core-5.2.1.jar
|
||||
lib/elasticsearch/lucene-expressions-5.2.1.jar
|
||||
lib/elasticsearch/lucene-grouping-5.2.1.jar
|
||||
lib/elasticsearch/lucene-highlighter-5.2.1.jar
|
||||
lib/elasticsearch/lucene-join-5.2.1.jar
|
||||
lib/elasticsearch/lucene-memory-5.2.1.jar
|
||||
lib/elasticsearch/lucene-misc-5.2.1.jar
|
||||
lib/elasticsearch/lucene-queries-5.2.1.jar
|
||||
lib/elasticsearch/lucene-queryparser-5.2.1.jar
|
||||
lib/elasticsearch/lucene-sandbox-5.2.1.jar
|
||||
lib/elasticsearch/lucene-spatial-5.2.1.jar
|
||||
lib/elasticsearch/lucene-suggest-5.2.1.jar
|
||||
lib/elasticsearch/netty-3.10.5.Final.jar
|
||||
lib/elasticsearch/snakeyaml-1.12.jar
|
||||
lib/elasticsearch/spatial4j-0.4.1.jar
|
||||
lib/elasticsearch/t-digest-3.0.jar
|
||||
libexec/elasticsearch/elasticsearch
|
||||
libexec/elasticsearch/elasticsearch.in.sh
|
||||
libexec/elasticsearch/plugin
|
||||
share/doc/elasticsearch/LICENSE.txt
|
||||
share/doc/elasticsearch/NOTICE.txt
|
||||
share/doc/elasticsearch/README.textile
|
||||
share/elasticsearch/elasticsearch
|
||||
share/elasticsearch/elasticsearch.in.sh
|
||||
share/elasticsearch/plugin
|
||||
share/examples/elasticsearch/elasticsearch.yml
|
||||
share/examples/elasticsearch/logging.yml
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.13 2015/11/04 17:41:15 agc Exp $
|
||||
$NetBSD: distinfo,v 1.14 2015/11/12 15:37:07 fhajny Exp $
|
||||
|
||||
SHA1 (elasticsearch-1.7.3.tar.gz) = 754b089ec0a1aae5b36b39391d5385ed7428d8f5
|
||||
RMD160 (elasticsearch-1.7.3.tar.gz) = f5f87c2b5ab9975a5649b310996c56fbe4eac436
|
||||
SHA512 (elasticsearch-1.7.3.tar.gz) = 0cb6b2ebd77c3d1467f6a22f845bfbf9f4a7c9c9ddedae17aeb6bd2d2bc576171fc80e3a4963e7b890af574e9fd0b0faa152e7f2671a74254826e14fe2554c9f
|
||||
Size (elasticsearch-1.7.3.tar.gz) = 28510917 bytes
|
||||
SHA1 (patch-bin_plugin) = 348f91fc1aca0f199c2a792db5acb7484421270e
|
||||
SHA1 (patch-config_elasticsearch.yml) = 769fdd62aacdc4743979edbc986e983a5c42a7f8
|
||||
SHA1 (elasticsearch-2.0.0.tar.gz) = e369d8579bd3a2e8b5344278d5043f19f14cac88
|
||||
RMD160 (elasticsearch-2.0.0.tar.gz) = 37a956c5a6392e41a7ea42c48557616491415936
|
||||
SHA512 (elasticsearch-2.0.0.tar.gz) = 23473b658d68c07b65f66e04cdac07c0b88ac3a2a9ca1d5e700b5b17ebc1b23b77a5b0fa32959d30d8e0267ec186be42de0c11ce86864fe55d0e353c27d0003a
|
||||
Size (elasticsearch-2.0.0.tar.gz) = 28576708 bytes
|
||||
SHA1 (patch-bin_elasticsearch.in.sh) = 323f1007f041eae2e094a82282edebc55d8522cd
|
||||
SHA1 (patch-bin_plugin) = 5ddd9b55797305c2c1e77b174ae410c00ecb7b89
|
||||
SHA1 (patch-config_elasticsearch.yml) = 7729dfb1ed106f0a34e6daaf7a46d0352d42f1f1
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#! @RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: elasticsearch.sh,v 1.2 2014/04/25 08:47:52 imil Exp $
|
||||
# $NetBSD: elasticsearch.sh,v 1.3 2015/11/12 15:37:07 fhajny Exp $
|
||||
#
|
||||
# PROVIDE: elasticsearch
|
||||
# REQUIRE: DAEMON
|
||||
|
@ -27,22 +27,25 @@ ES_CLASSPATH="@ES_LIBDIR@/@DISTNAME@.jar:@ES_LIBDIR@/*"
|
|||
command="@PKG_JAVA_HOME@/bin/java"
|
||||
# flags taken from bin/elasticsearch and bin/elasticsearch.in.sh
|
||||
command_args=" -Delasticsearch \
|
||||
-Des.path.home=@PREFIX@ \
|
||||
-Des.path.conf=@PKG_SYSCONFDIR@ \
|
||||
-Des.pidfile=${pidfile} \
|
||||
-Des.config=${elasticsearch_config} \
|
||||
-Dfile.encoding=UTF-8 \
|
||||
-Djava.awt.headless=true \
|
||||
-Xms${elasticsearch_min_mem} \
|
||||
-Xmx${elasticsearch_max_mem} \
|
||||
-Xss256k \
|
||||
-Djava.awt.headless=true \
|
||||
-XX:+UseParNewGC \
|
||||
-XX:+UseConcMarkSweepGC \
|
||||
-XX:CMSInitiatingOccupancyFraction=75 \
|
||||
-XX:+UseCMSInitiatingOccupancyOnly \
|
||||
-XX:+DisableExplicitGC \
|
||||
-XX:+HeapDumpOnOutOfMemoryError \
|
||||
-XX:+UseCMSInitiatingOccupancyOnly \
|
||||
-XX:+UseCMSInitiatingOccupancyOnly \
|
||||
-XX:+UseConcMarkSweepGC \
|
||||
-XX:+UseParNewGC \
|
||||
-XX:CMSInitiatingOccupancyFraction=75 \
|
||||
-cp ${ES_CLASSPATH} \
|
||||
${elasticsearch_props} \
|
||||
org.elasticsearch.bootstrap.Elasticsearch \
|
||||
>/dev/null &"
|
||||
start >/dev/null &"
|
||||
|
||||
# ElasticSearch is fd hungry, default limit leads to write locks
|
||||
SOFT_FDLIMIT=`ulimit -S -n`
|
||||
|
|
|
@ -20,16 +20,27 @@
|
|||
<envvar name='JAVA_HOME' value='@PKG_JAVA_HOME@' />
|
||||
</method_environment>
|
||||
</method_context>
|
||||
<exec_method name="start" type="method" exec="@PKG_JAVA_HOME@/bin/java -Delasticsearch -Des.index.store.type=%{store_type} -Des.pidfile=@ES_PIDDIR@/elasticsearch.pid -Des.config=%{config_file} %{java_opts} -Xms%{min_heap} -Xmx%{max_heap} -cp %{class_path} org.elasticsearch.bootstrap.Elasticsearch" timeout_seconds="3600" />
|
||||
<exec_method type="method" name="stop" exec=":kill" timeout_seconds="60" />
|
||||
<exec_method type="method" name="refresh" exec=":kill -HUP" timeout_seconds="60" />
|
||||
<property_group name="application" type="application">
|
||||
<propval name="min_heap" type="astring" value="256m" />
|
||||
<propval name="max_heap" type="astring" value="1g" />
|
||||
<propval name="store_type" type="astring" value="niofs" />
|
||||
<propval name="class_path" type="astring" value="@ES_LIBDIR@/@DISTNAME@.jar:@ES_LIBDIR@/*:@ES_LIBDIR@/sigar/*.jar" />
|
||||
<propval name="config_file" type="astring" value="@PKG_SYSCONFDIR@/elasticsearch.yml" />
|
||||
<propval name="java_opts" type="astring" value="-Djava.awt.headless=true -Xss256k -XX:+DisableExplicitGC -XX:+HeapDumpOnOutOfMemoryError -XX:+UseCMSInitiatingOccupancyOnly -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:CMSInitiatingOccupancyFraction=75" />
|
||||
<exec_method name='start' type='method' exec='@PKG_JAVA_HOME@/bin/java -Delasticsearch -Des.path.home=@PREFIX@ -Des.path.conf=@PKG_SYSCONFDIR@ -Des.pidfile=@ES_PIDDIR@/elasticsearch.pid -Des.index.store.type=%{store_type} %{java_opts} -Xms%{min_heap} -Xmx%{max_heap} -cp %{class_path} org.elasticsearch.bootstrap.Elasticsearch start' timeout_seconds='3600' />
|
||||
<exec_method type='method' name='stop' exec=':kill' timeout_seconds='60' />
|
||||
<exec_method type='method' name='refresh' exec=':kill -HUP' timeout_seconds='60' />
|
||||
<property_group name='application' type='application'>
|
||||
<propval name='min_heap' type='astring' value='256m' />
|
||||
<propval name='max_heap' type='astring' value='1g' />
|
||||
<propval name='store_type' type='astring' value='niofs' />
|
||||
<propval name='class_path' type='astring' value='@ES_LIBDIR@/@DISTNAME@.jar:@ES_LIBDIR@/*' />
|
||||
<property name='java_opts' type='astring'>
|
||||
<astring_list>
|
||||
<value_node value='-Dfile.encoding=UTF-8'/>
|
||||
<value_node value='-Djava.awt.headless=true'/>
|
||||
<value_node value='-XX:+DisableExplicitGC'/>
|
||||
<value_node value='-XX:+HeapDumpOnOutOfMemoryError'/>
|
||||
<value_node value='-XX:+UseCMSInitiatingOccupancyOnly'/>
|
||||
<value_node value='-XX:+UseConcMarkSweepGC'/>
|
||||
<value_node value='-XX:+UseParNewGC'/>
|
||||
<value_node value='-XX:CMSInitiatingOccupancyFraction=75'/>
|
||||
<value_node value='-Xss256k'/>
|
||||
</astring_list>
|
||||
</property>
|
||||
</property_group>
|
||||
<property_group name='startd' type='framework'>
|
||||
<propval name='duration' type='astring' value='child' />
|
||||
|
|
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-bin_elasticsearch.in.sh,v 1.1 2015/11/12 15:37:08 fhajny Exp $
|
||||
|
||||
Fix paths.
|
||||
|
||||
--- bin/elasticsearch.in.sh.orig 2015-10-21 08:41:12.000000000 +0000
|
||||
+++ bin/elasticsearch.in.sh
|
||||
@@ -10,7 +10,7 @@ EOF
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-ES_CLASSPATH="$ES_HOME/lib/elasticsearch-2.0.0.jar:$ES_HOME/lib/*"
|
||||
+ES_CLASSPATH="@ES_LIBDIR@/elasticsearch-2.0.0.jar:@ES_LIBDIR@/*"
|
||||
|
||||
if [ "x$ES_MIN_MEM" = "x" ]; then
|
||||
ES_MIN_MEM=256m
|
|
@ -1,14 +1,14 @@
|
|||
$NetBSD: patch-bin_plugin,v 1.1 2015/10/18 16:02:05 fhajny Exp $
|
||||
$NetBSD: patch-bin_plugin,v 1.2 2015/11/12 15:37:08 fhajny Exp $
|
||||
|
||||
Fix paths and improve portability.
|
||||
|
||||
--- bin/plugin.orig 2015-10-15 09:16:10.000000000 +0000
|
||||
--- bin/plugin.orig 2015-10-21 13:32:03.000000000 +0000
|
||||
+++ bin/plugin
|
||||
@@ -15,15 +15,20 @@ while [ -h "$SCRIPT" ] ; do
|
||||
@@ -16,8 +16,13 @@ while [ -h "$SCRIPT" ] ; do
|
||||
fi
|
||||
done
|
||||
|
||||
+#set defualt JAVA_HOME
|
||||
+#set default JAVA_HOME
|
||||
+if [ -z "$JAVA_HOME" ]; then
|
||||
+ JAVA_HOME="@PKG_JAVA_HOME@"
|
||||
+fi
|
||||
|
@ -19,21 +19,18 @@ Fix paths and improve portability.
|
|||
|
||||
# make ELASTICSEARCH_HOME absolute
|
||||
ES_HOME=`cd "$ES_HOME"; pwd`
|
||||
@@ -25,7 +30,7 @@ ES_HOME=`cd "$ES_HOME"; pwd`
|
||||
|
||||
# Sets the default values for elasticsearch variables used in this script
|
||||
if [ -z "$CONF_DIR" ]; then
|
||||
- CONF_DIR="$ES_HOME/config"
|
||||
+ CONF_DIR="@PKG_SYSCONFDIR@"
|
||||
|
||||
if [ -z "$CONF_FILE" ]; then
|
||||
CONF_FILE="$CONF_DIR/elasticsearch.yml"
|
||||
@@ -103,6 +108,6 @@ if [ -e "$CONF_FILE" ]; then
|
||||
esac
|
||||
fi
|
||||
|
||||
-export HOSTNAME=`hostname -s`
|
||||
+export HOSTNAME=`hostname`
|
||||
# The default env file is defined at building/packaging time.
|
||||
@@ -105,4 +110,4 @@ fi
|
||||
HOSTNAME=`hostname | cut -d. -f1`
|
||||
export HOSTNAME
|
||||
|
||||
-eval "$JAVA" $JAVA_OPTS $ES_JAVA_OPTS -Xmx64m -Xms16m -Delasticsearch -Des.path.home=\""$ES_HOME"\" $properties -cp \""$ES_HOME/lib/*"\" org.elasticsearch.plugins.PluginManager $args
|
||||
\ No newline at end of file
|
||||
+eval "$JAVA" $JAVA_OPTS $ES_JAVA_OPTS -Xmx64m -Xms16m -Delasticsearch -Des.path.home=\""$ES_HOME"\" $properties -cp \""$ES_HOME/lib/elasticsearch/*"\" org.elasticsearch.plugins.PluginManager $args
|
||||
-eval "$JAVA" -client -Delasticsearch -Des.path.home="\"$ES_HOME\"" $properties -cp "\"$ES_HOME/lib/*\"" org.elasticsearch.plugins.PluginManagerCliParser $args
|
||||
+eval "$JAVA" -client -Delasticsearch -Des.path.home="\"$ES_HOME\"" $properties -cp "\"@ES_LIBDIR@/*\"" org.elasticsearch.plugins.PluginManagerCliParser $args
|
||||
|
|
|
@ -1,37 +1,23 @@
|
|||
$NetBSD: patch-config_elasticsearch.yml,v 1.3 2014/07/29 16:57:23 fhajny Exp $
|
||||
$NetBSD: patch-config_elasticsearch.yml,v 1.4 2015/11/12 15:37:08 fhajny Exp $
|
||||
|
||||
Define various paths
|
||||
|
||||
--- config/elasticsearch.yml.orig 2014-07-23 13:43:31.000000000 +0000
|
||||
--- config/elasticsearch.yml.orig 2015-10-21 08:41:12.000000000 +0000
|
||||
+++ config/elasticsearch.yml
|
||||
@@ -143,10 +143,12 @@
|
||||
# Path to directory containing configuration (this file and logging.yml):
|
||||
@@ -31,10 +31,16 @@
|
||||
# Path to directory where to store the data (separate multiple locations by comma):
|
||||
#
|
||||
#path.conf: /path/to/conf
|
||||
+path.conf: @PKG_SYSCONFDIR@
|
||||
|
||||
# Path to directory where to store index data allocated for this node.
|
||||
#
|
||||
#path.data: /path/to/data
|
||||
# path.data: /path/to/data
|
||||
+path.data: @ES_DBDIR@
|
||||
#
|
||||
# Can optionally include more than one location, causing data to be striped across
|
||||
# the locations (a la RAID 0) on a file level, favouring locations with most free
|
||||
@@ -157,14 +159,17 @@
|
||||
# Path to temporary files:
|
||||
#
|
||||
#path.work: /path/to/work
|
||||
+path.work: @ES_TMPDIR@
|
||||
|
||||
# Path to log files:
|
||||
#
|
||||
#path.logs: /path/to/logs
|
||||
# path.logs: /path/to/logs
|
||||
+path.logs: @ES_LOGDIR@
|
||||
|
||||
# Path to where plugins are installed:
|
||||
#
|
||||
#path.plugins: /path/to/plugins
|
||||
+
|
||||
+path.conf: @PKG_SYSCONFDIR@
|
||||
+path.plugins: @ES_LIBDIR@/plugins
|
||||
|
||||
|
||||
#################################### Plugin ###################################
|
||||
+path.work: @ES_TMPDIR@
|
||||
#
|
||||
# ----------------------------------- Memory -----------------------------------
|
||||
#
|
||||
|
|
Loading…
Reference in a new issue