patch-gssftp_ftp_ftp_var.h rewritten
This commit is contained in:
parent
edb5df1a1e
commit
eb1cd321a1
2 changed files with 32 additions and 10 deletions
|
@ -1,8 +1,8 @@
|
||||||
$NetBSD: distinfo,v 1.5 2012/02/26 13:16:32 adam Exp $
|
$NetBSD: distinfo,v 1.6 2012/11/29 07:31:02 adam Exp $
|
||||||
|
|
||||||
SHA1 (krb5-appl-1.0.3-signed.tar) = 6711c1b46633e666e6e707363ffffce5e1c84d9d
|
SHA1 (krb5-appl-1.0.3-signed.tar) = 6711c1b46633e666e6e707363ffffce5e1c84d9d
|
||||||
RMD160 (krb5-appl-1.0.3-signed.tar) = 491359af5da2ea3c680811b08d9696eb43794a21
|
RMD160 (krb5-appl-1.0.3-signed.tar) = 491359af5da2ea3c680811b08d9696eb43794a21
|
||||||
Size (krb5-appl-1.0.3-signed.tar) = 634880 bytes
|
Size (krb5-appl-1.0.3-signed.tar) = 634880 bytes
|
||||||
SHA1 (patch-ab) = 4522fcdb396d2079ac6405926a64f907d94a2593
|
SHA1 (patch-ab) = 4522fcdb396d2079ac6405926a64f907d94a2593
|
||||||
SHA1 (patch-gssftp_ftp_cmds_c) = 24942a2bcfc0cb0ce3045da5468d315c5b1bfadb
|
SHA1 (patch-gssftp_ftp_cmds_c) = 24942a2bcfc0cb0ce3045da5468d315c5b1bfadb
|
||||||
SHA1 (patch-gssftp_ftp_ftp_var.h) = bd851e19a70db30bec53d20d75bb1855a13b3084
|
SHA1 (patch-gssftp_ftp_ftp_var.h) = 44a7483c6af469738ae4eab3d1450bac259d71ac
|
||||||
|
|
|
@ -1,16 +1,38 @@
|
||||||
$NetBSD: patch-gssftp_ftp_ftp_var.h,v 1.1 2012/02/26 13:16:32 adam Exp $
|
$NetBSD: patch-gssftp_ftp_ftp_var.h,v 1.2 2012/11/29 07:31:02 adam Exp $
|
||||||
|
|
||||||
Don't redefine sig_t and sigtype.
|
Don't redefine sig_t and sigtype.
|
||||||
|
|
||||||
--- gssftp/ftp/ftp_var.h.orig 2012-02-26 13:04:30.000000000 +0000
|
--- gssftp/ftp/ftp_var.h.orig 2012-02-26 13:04:30.000000000 +0000
|
||||||
+++ gssftp/ftp/ftp_var.h
|
+++ gssftp/ftp/ftp_var.h
|
||||||
@@ -57,9 +57,7 @@ FILE* fdopen_socket(SOCKET s, char* mode
|
@@ -53,15 +53,6 @@
|
||||||
typedef void (*sig_t)(int);
|
#define PERROR_SOCKET(str) perror(str)
|
||||||
typedef void sigtype;
|
|
||||||
#else
|
|
||||||
-#define sig_t my_sig_t
|
|
||||||
#define sigtype krb5_sigtype
|
|
||||||
-typedef sigtype (*sig_t)();
|
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
-#ifdef _WIN32
|
||||||
|
-typedef void (*sig_t)(int);
|
||||||
|
-typedef void sigtype;
|
||||||
|
-#else
|
||||||
|
-#define sig_t my_sig_t
|
||||||
|
-#define sigtype krb5_sigtype
|
||||||
|
-typedef sigtype (*sig_t)();
|
||||||
|
-#endif
|
||||||
|
-
|
||||||
/*
|
/*
|
||||||
|
* FTP global variables.
|
||||||
|
*/
|
||||||
|
@@ -168,6 +159,15 @@
|
||||||
|
extern struct macel macros[16];
|
||||||
|
extern char macbuf[4096];
|
||||||
|
|
||||||
|
+#ifdef _WIN32
|
||||||
|
+typedef void (*sig_t)(int);
|
||||||
|
+typedef void sigtype;
|
||||||
|
+#else
|
||||||
|
+#define sig_t my_sig_t
|
||||||
|
+#define sigtype krb5_sigtype
|
||||||
|
+typedef sigtype (*sig_t)();
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
#ifdef DEFINITIONS
|
||||||
|
#undef extern
|
||||||
|
#endif
|
||||||
|
|
Loading…
Reference in a new issue