Fix build on systems which have pw_change but not _PASSWORD_CHGNOW.

This commit is contained in:
joerg 2007-03-07 17:56:37 +00:00
parent 9533301dd7
commit eb1cf5ad8b
2 changed files with 18 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.8 2007/03/01 14:01:21 salo Exp $
$NetBSD: distinfo,v 1.9 2007/03/07 17:56:37 joerg Exp $
SHA1 (tnftpd-20061217.tar.gz) = a81e69c648397c15541683910495037683d87d2f
RMD160 (tnftpd-20061217.tar.gz) = 9f098e35e549a202a7a392898095ee91f34e8604
Size (tnftpd-20061217.tar.gz) = 187602 bytes
SHA1 (patch-aa) = febc5e934b3bc5f83758bb966e30d5d17ca10af7

View file

@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.5 2007/03/07 17:56:37 joerg Exp $
--- src/ftpd.c.orig 2007-03-07 17:23:16.000000000 +0000
+++ src/ftpd.c
@@ -3744,7 +3744,11 @@ checkpassword(const struct passwd *pwent
expire = pwent->pw_expire;
#endif
#if HAVE_PW_CHANGE
+#ifdef _PASSWORD_CHGNOW
change = (pwent->pw_change == _PASSWORD_CHGNOW)? now : pwent->pw_change;
+#else
+ change = pwent->pw_change;
+#endif
#endif
#endif