Remove -DGTK_DISABLE_DEPRECATED, and fix some includes, so that it builds
with the currently packaged versions of its dependencies.
This commit is contained in:
parent
616772d8a0
commit
eb316020d4
5 changed files with 58 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.36 2004/05/09 00:45:45 snj Exp $
|
||||
# $NetBSD: Makefile,v 1.37 2004/05/16 00:57:24 kristerw Exp $
|
||||
#
|
||||
|
||||
DISTNAME= giram-0.3.5
|
||||
|
@ -27,6 +27,8 @@ CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}/0.3
|
|||
|
||||
SHLIBTOOL_OVERRIDE= libtool
|
||||
|
||||
BUILDLINK_TRANSFORM+= S:-DGTK_DISABLE_DEPRECATED:
|
||||
|
||||
OWN_DIRS+= ${PKG_SYSCONFDIR}/0.3
|
||||
CONF_FILES+= ${PREFIX}/share/examples/giram/giramrc \
|
||||
${PKG_SYSCONFDIR}/0.3/giramrc
|
||||
|
|
|
@ -1,6 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.6 2003/05/24 11:23:08 salo Exp $
|
||||
$NetBSD: distinfo,v 1.7 2004/05/16 00:57:24 kristerw Exp $
|
||||
|
||||
SHA1 (giram-0.3.5.tar.gz) = f8ecdd1a954315cb9e1356af3b8a3b20fb9f9b41
|
||||
Size (giram-0.3.5.tar.gz) = 1028404 bytes
|
||||
SHA1 (patch-aa) = a575aba5e5bc501f62b7ccd409f3d45306e8b002
|
||||
SHA1 (patch-ab) = d26d581019ef91e42c93a4eee01d7b78b69e65f3
|
||||
SHA1 (patch-ac) = 39ea22c932ff31f70ac0dc71828725a969d529d3
|
||||
SHA1 (patch-ad) = c161a8cebc9536626e28bc79155a0ab43ff3aee1
|
||||
SHA1 (patch-ae) = e07c9e06010f7af087f3cc3987ec34a6c15012d2
|
||||
|
|
17
graphics/giram/patches/patch-ac
Normal file
17
graphics/giram/patches/patch-ac
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-ac,v 1.3 2004/05/16 00:57:24 kristerw Exp $
|
||||
|
||||
--- src/texture.c.orig Sat May 15 13:29:15 2004
|
||||
+++ src/texture.c Sat May 15 13:29:42 2004
|
||||
@@ -21,10 +21,10 @@
|
||||
#include <string.h>
|
||||
#undef GTK_DISABLE_DEPRECATED
|
||||
#warning GTK_DISABLE_DEPRECATED
|
||||
-#include "giram.h"
|
||||
-#include "utils.h"
|
||||
#include "widgets/gtkcolorbutton.h"
|
||||
#include "widgets/gtkcolormapbutton.h"
|
||||
+#include "giram.h"
|
||||
+#include "utils.h"
|
||||
#include "texture.h"
|
||||
|
||||
#include "widgets/giramwidgets.h"
|
18
graphics/giram/patches/patch-ad
Normal file
18
graphics/giram/patches/patch-ad
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-ad,v 1.3 2004/05/16 00:57:24 kristerw Exp $
|
||||
|
||||
--- src/widgets/gtkcolorbutton.c.orig Sat May 15 13:13:54 2004
|
||||
+++ src/widgets/gtkcolorbutton.c Sat May 15 13:14:12 2004
|
||||
@@ -25,11 +25,11 @@
|
||||
#undef GTK_DISABLE_DEPRECATED
|
||||
#warning GTK_DISABLE_DEPRECATED
|
||||
|
||||
+#include "gtkcolorbutton.h"
|
||||
+
|
||||
#include "giram.h"
|
||||
|
||||
#include "giramintl.h"
|
||||
-
|
||||
-#include "gtkcolorbutton.h"
|
||||
|
||||
static void gtk_color_button_destroy(GtkObject *object);
|
||||
static void gtk_color_button_clicked(GtkButton *button);
|
16
graphics/giram/patches/patch-ae
Normal file
16
graphics/giram/patches/patch-ae
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ae,v 1.3 2004/05/16 00:57:24 kristerw Exp $
|
||||
|
||||
--- src/giramobjecteditor.c.orig Sun May 16 02:47:57 2004
|
||||
+++ src/giramobjecteditor.c Sun May 16 02:48:16 2004
|
||||
@@ -19,10 +19,10 @@
|
||||
*/
|
||||
|
||||
#include <stdlib.h>
|
||||
+#include "widgets/gtkcolorbutton.h"
|
||||
#include "giram.h"
|
||||
|
||||
#include "giramintl.h"
|
||||
-#include "widgets/gtkcolorbutton.h"
|
||||
#include "widgets/giramfileselection.h"
|
||||
|
||||
#include "widgets/giramvectorframe.h"
|
Loading…
Reference in a new issue