Initial import of samba, from FreeBSD, into the NetBSD packages
collection, thanks to Ty Sarna (tsarna@endicor.com), and addresses the first part of PR pkg/4746. The Samba software suite is a collection of programs that implements the SMB protocol for UNIX systems.
This commit is contained in:
parent
00fdfa6041
commit
eb359c12c4
7 changed files with 403 additions and 0 deletions
60
net/samba/Makefile
Normal file
60
net/samba/Makefile
Normal file
|
@ -0,0 +1,60 @@
|
|||
# New ports collection makefile for: samba
|
||||
# Version required: 1.9.17p4
|
||||
# Date created: 11th Feb 1995
|
||||
# Whom: gpalmer
|
||||
#
|
||||
# FreeBSD Id: Makefile,v 1.17 1997/10/23 15:03:20 max Exp
|
||||
#
|
||||
|
||||
DISTNAME= samba-1.9.17p4
|
||||
PKGNAME= samba-1.9.17.4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://samba.anu.edu.au/pub/samba/
|
||||
|
||||
MAINTAINER= hosokawa@jp.FreeBSD.ORG
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/source
|
||||
MAN1= smbstatus.1 smbclient.1 smbrun.1 smbtar.1 testparm.1 testprns.1
|
||||
MAN5= smb.conf.5
|
||||
MAN7= samba.7
|
||||
MAN8= smbd.8 nmbd.8 smbpasswd.8
|
||||
|
||||
STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/samba.sh.sample
|
||||
SAMPLE_CONFIG= ${PREFIX}/etc/smb.conf.sample
|
||||
SAMBA_SPOOL= /var/spool/samba
|
||||
XSAMBA_SPOOL= \/var\/spool\/samba
|
||||
SAMBA_LOGDIR= /var/log
|
||||
XSAMBA_LOGDIR= \/var\/log
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/samba/faq
|
||||
for i in ${WRKDIR}/${DISTNAME}/docs/*.txt ${WRKDIR}/${DISTNAME}/docs/README* ; do \
|
||||
${INSTALL_DATA} $$i ${PREFIX}/share/doc/samba ; \
|
||||
done
|
||||
for i in ${WRKDIR}/${DISTNAME}/docs/faq/* ; do \
|
||||
${INSTALL_DATA} $$i ${PREFIX}/share/doc/samba/faq ; \
|
||||
done
|
||||
.endif
|
||||
@if [ ! -f ${STARTUP_SCRIPT} ]; then \
|
||||
${ECHO} "Installing ${STARTUP_SCRIPT} startup file." ; \
|
||||
${ECHO} '#!/bin/sh' > ${STARTUP_SCRIPT} ; \
|
||||
${ECHO} 'smbd=${PREFIX}/sbin/smbd' >> ${STARTUP_SCRIPT} ;\
|
||||
${ECHO} 'nmbd=${PREFIX}/sbin/nmbd' >> ${STARTUP_SCRIPT} ;\
|
||||
${ECHO} 'if [ -f $$smbd ]; then' >> ${STARTUP_SCRIPT} ;\
|
||||
${ECHO} " ${ECHO} -n ' Samba'" >> ${STARTUP_SCRIPT} ;\
|
||||
${ECHO} ' $$smbd -D' >> ${STARTUP_SCRIPT} ; \
|
||||
${ECHO} ' $$nmbd -D' >> ${STARTUP_SCRIPT} ; \
|
||||
${ECHO} "fi" >> ${STARTUP_SCRIPT} ; \
|
||||
chmod 755 ${STARTUP_SCRIPT} ; \
|
||||
chown bin.bin ${STARTUP_SCRIPT}; \
|
||||
fi
|
||||
@test -d ${SAMBA_SPOOL} || ${MKDIR} ${SAMBA_SPOOL} && chmod 1777 ${SAMBA_SPOOL}
|
||||
@if [ ! -f ${SAMPLE_CONFIG} ]; then \
|
||||
${SED} -e 's/__SAMBA_SPOOL__/${XSAMBA_SPOOL}/' \
|
||||
-e 's/__LOGDIR__/${XSAMBA_LOGDIR}/' \
|
||||
${FILESDIR}/smb.conf.sample \
|
||||
> ${SAMPLE_CONFIG} ; \
|
||||
fi
|
||||
|
||||
.include <bsd.port.mk>
|
1
net/samba/files/md5
Normal file
1
net/samba/files/md5
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (samba-1.9.17p4.tar.gz) = dd8a65242a2bb969a9a5f3d7095df602
|
180
net/samba/files/smb.conf.sample
Normal file
180
net/samba/files/smb.conf.sample
Normal file
|
@ -0,0 +1,180 @@
|
|||
; Configuration file for smbd.
|
||||
; ============================================================================
|
||||
; For the format of this file and comprehensive descriptions of all the
|
||||
; configuration option, please refer to the man page for smb.conf(5).
|
||||
;
|
||||
; The following configuration should suit most systems for basic usage and
|
||||
; initial testing. It gives all clients access to their home directories and
|
||||
; allows access to all printers specified in /etc/printcap.
|
||||
;
|
||||
; Things you need to check:
|
||||
; --------------------------
|
||||
;
|
||||
; 1: Check the path to your printcap file. If you are using a system that does
|
||||
; not use printcap (eg., Solaris), create a file containing lines of the
|
||||
; form
|
||||
;
|
||||
; printername|printername|printername|
|
||||
;
|
||||
; where each "printername" is the name of a printer you want to provide
|
||||
; access to. Then alter the "printcap =" entry to point to the new file.
|
||||
;
|
||||
; If using Solaris, the following command will generate a suitable printcap
|
||||
; file:
|
||||
;
|
||||
; lpc status | grep ":" | sed s/:/\|/ > myprintcap
|
||||
;
|
||||
; 2: Make sure the "print command" entry is correct for your system. This
|
||||
; command should submit a file (represented by %s) to a printer
|
||||
; (represented by %p) for printing and should REMOVE the file after
|
||||
; printing.
|
||||
;
|
||||
; One most systems the default will be OK, as long as you get "printing ="
|
||||
; right.
|
||||
;
|
||||
; It is also a good idea to use an absolute path in the print command
|
||||
; as there is no guarantee the search path will be set correctly.
|
||||
;
|
||||
; 3: Make sure the "printing =" option is set correctly for your system.
|
||||
; Possible values are "sysv", "bsd" or "aix".
|
||||
;
|
||||
; 4: Make sure the "lpq command" entry is correct for your system. The default
|
||||
; may not work for you.
|
||||
;
|
||||
; 5: Make sure that the user specified in "guest account" exists. Typically
|
||||
; this will be a user that cannot log in and has minimal privileges.
|
||||
; Often the "nobody" account doesn't work (very system dependant).
|
||||
;
|
||||
; 6: You should consider the "security =" option. See a full description
|
||||
; in the main documentation and the smb.conf(5) manual page
|
||||
;
|
||||
; 7: Look at the "hosts allow" option, unless you want everyone on the internet
|
||||
; to be able to access your files.
|
||||
;
|
||||
[global]
|
||||
comment = NetBSD - Samba %v
|
||||
workgroup = WORKGROUP
|
||||
printing = bsd
|
||||
printcap name = /etc/printcap
|
||||
load printers = yes
|
||||
guest account = nobody
|
||||
; This next option sets a separate log file for each client. Remove
|
||||
; it if you want a combined log file.
|
||||
log file = __LOGDIR__/sambalog.%m
|
||||
dont descend = /dev,/proc,/root,/stand
|
||||
|
||||
; You will need a world readable lock directory and "share modes=yes"
|
||||
; if you want to support the file sharing modes for multiple users
|
||||
; of the same files
|
||||
; lock directory = /usr/local/samba/var/locks
|
||||
; share modes = yes
|
||||
|
||||
map archive = no
|
||||
status = yes
|
||||
public = yes
|
||||
read only = no
|
||||
preserve case = yes
|
||||
strip dot = yes
|
||||
security = share
|
||||
guest ok = no
|
||||
|
||||
[homes]
|
||||
comment = Home Directories
|
||||
browseable = no
|
||||
read only = no
|
||||
create mode = 0750
|
||||
|
||||
[printers]
|
||||
comment = All Printers
|
||||
path = __SAMBA_SPOOL__
|
||||
browseable = no
|
||||
printable = yes
|
||||
public = no
|
||||
writable = no
|
||||
create mode = 0700
|
||||
|
||||
; you might also want this one, notice that it is read only so as not to give
|
||||
; people without an account write access.
|
||||
;
|
||||
; [tmp]
|
||||
; comment = Temporary file space
|
||||
; path = /tmp
|
||||
; read only = yes
|
||||
; public = yes
|
||||
|
||||
;
|
||||
; Other examples.
|
||||
;
|
||||
; A private printer, usable only by fred. Spool data will be placed in fred's
|
||||
; home directory. Note that fred must have write access to the spool directory,
|
||||
; wherever it is.
|
||||
;[fredsprn]
|
||||
; comment = Fred's Printer
|
||||
; valid users = fred
|
||||
; path = /homes/fred
|
||||
; printer = freds_printer
|
||||
; public = no
|
||||
; writable = no
|
||||
; printable = yes
|
||||
;
|
||||
; A private directory, usable only by fred. Note that fred requires write
|
||||
; access to the directory.
|
||||
;[fredsdir]
|
||||
; comment = Fred's Service
|
||||
; path = /usr/somewhere/private
|
||||
; valid users = fred
|
||||
; public = no
|
||||
; writable = yes
|
||||
; printable = no
|
||||
;
|
||||
; A publicly accessible directory, but read only, except for people in
|
||||
; the staff group
|
||||
;[public]
|
||||
; comment = Public Stuff
|
||||
; path = /usr/somewhere/public
|
||||
; public = yes
|
||||
; writable = no
|
||||
; printable = no
|
||||
; write list = @staff
|
||||
;
|
||||
; a service which has a different directory for each machine that connects
|
||||
; this allows you to tailor configurations to incoming machines. You could
|
||||
; also use the %u option to tailor it by user name.
|
||||
; The %m gets replaced with the machine name that is connecting.
|
||||
;[pchome]
|
||||
; comment = PC Directories
|
||||
; path = /usr/pc/%m
|
||||
; public = no
|
||||
; writeable = yes
|
||||
;
|
||||
;
|
||||
; A publicly accessible directory, read/write to all users. Note that all files
|
||||
; created in the directory by users will be owned by the default user, so
|
||||
; any user with access can delete any other user's files. Obviously this
|
||||
; directory must be writable by the default user. Another user could of course
|
||||
; be specified, in which case all files would be owned by that user instead.
|
||||
;[public]
|
||||
; path = /usr/somewhere/else/public
|
||||
; public = yes
|
||||
; only guest = yes
|
||||
; writable = yes
|
||||
; printable = no
|
||||
;
|
||||
;
|
||||
; The following two entries demonstrate how to share a directory so that two
|
||||
; users can place files there that will be owned by the specific users. In this
|
||||
; setup, the directory should be writable by both users and should have the
|
||||
; sticky bit set on it to prevent abuse. Obviously this could be extended to
|
||||
; as many users as required.
|
||||
;[myshare]
|
||||
; comment = Mary's and Fred's stuff
|
||||
; path = /usr/somewhere/shared
|
||||
; valid users = mary fred
|
||||
; public = no
|
||||
; writable = yes
|
||||
; printable = no
|
||||
; create mask = 0765
|
||||
|
||||
|
||||
|
||||
|
70
net/samba/patches/patch-aa
Normal file
70
net/samba/patches/patch-aa
Normal file
|
@ -0,0 +1,70 @@
|
|||
--- Makefile.orig Sat Sep 27 00:04:52 1997
|
||||
+++ Makefile Wed Oct 15 17:09:58 1997
|
||||
@@ -5,11 +5,11 @@
|
||||
###########################################################################
|
||||
|
||||
# The base directory for all samba files
|
||||
-BASEDIR = /usr/local/samba
|
||||
+BASEDIR = $(PREFIX)
|
||||
|
||||
# The base manpages directory to put the man pages in
|
||||
# Note: $(MANDIR)/man1, $(MANDIR)/man5 and $(MANDIR)/man8 must exist.
|
||||
-MANDIR = /usr/local/man
|
||||
+MANDIR = $(PREFIX)/man
|
||||
|
||||
# The directories to put things in. If you use multiple
|
||||
# architectures or share the samba binaries across NFS then
|
||||
@@ -18,9 +18,9 @@
|
||||
# normally only applies to nmbd and smbd
|
||||
# SBINDIR implies a secure binary directory
|
||||
BINDIR = $(BASEDIR)/bin
|
||||
-SBINDIR = $(BASEDIR)/bin
|
||||
-LIBDIR = $(BASEDIR)/lib
|
||||
-VARDIR = $(BASEDIR)/var
|
||||
+SBINDIR = $(BASEDIR)/sbin
|
||||
+ETCDIR = $(BASEDIR)/etc
|
||||
+LOGDIR = /var/log
|
||||
|
||||
# The permissions to give the executables
|
||||
INSTALLPERMS = 0755
|
||||
@@ -45,13 +45,13 @@
|
||||
# set these to where to find various files
|
||||
# These can be overridden by command line switches (see smbd(8))
|
||||
# or in smb.conf (see smb.conf(5))
|
||||
-SMBLOGFILE = $(VARDIR)/log.smb
|
||||
-NMBLOGFILE = $(VARDIR)/log.nmb
|
||||
-CONFIGFILE = $(LIBDIR)/smb.conf
|
||||
-LMHOSTSFILE = $(LIBDIR)/lmhosts
|
||||
+SMBLOGFILE = $(LOGDIR)/smb
|
||||
+NMBLOGFILE = $(LOGDIR)/nmb
|
||||
+CONFIGFILE = $(ETCDIR)/smb.conf
|
||||
+LMHOSTSFILE = $(ETCDIR)/lmhosts
|
||||
|
||||
# the directory where lock files go
|
||||
-LOCKDIR = $(VARDIR)/locks
|
||||
+LOCKDIR = /var/spool/lock
|
||||
|
||||
# set this to the default group you want your machine to appear in
|
||||
# for browsing. This can also be set in nmbd (see nmbd(8))
|
||||
@@ -383,8 +383,8 @@
|
||||
# This is for FreeBSD
|
||||
# contributed by kuku@acds.physik.rwth-aachen.de
|
||||
# NOTE: You may need to add -DBSD44 if you have password problems
|
||||
-# FLAGSM = -DFreeBSD -DFAST_SHARE_MODES
|
||||
-# LIBSM = -lcrypt
|
||||
+FLAGSM = -DFreeBSD -DFAST_SHARE_MODES
|
||||
+LIBSM = -lcrypt
|
||||
|
||||
|
||||
# This is for NEXTSTEP Release 2.X
|
||||
@@ -684,8 +684,8 @@
|
||||
install: installbin installman installscripts
|
||||
|
||||
installbin: all
|
||||
- @$(SHELL) $(srcdir)installbin.sh $(INSTALLPERMS) $(BASEDIR) $(SBINDIR) $(LIBDIR) $(VARDIR) $(SPROGS)
|
||||
- @$(SHELL) $(srcdir)installbin.sh $(INSTALLPERMS) $(BASEDIR) $(BINDIR) $(LIBDIR) $(VARDIR) $(PROGS)
|
||||
+ @$(SHELL) $(srcdir)installbin.sh $(INSTALLPERMS) $(BASEDIR) $(SBINDIR) $(ETCDIR) $(LOGDIR) $(SPROGS)
|
||||
+ @$(SHELL) $(srcdir)installbin.sh $(INSTALLPERMS) $(BASEDIR) $(BINDIR) $(ETCDIR) $(LOGDIR) $(PROGS)
|
||||
|
||||
installscripts:
|
||||
@$(SHELL) $(srcdir)installscripts.sh $(INSTALLPERMS) $(BINDIR) $(SCRIPTS)
|
1
net/samba/pkg/COMMENT
Normal file
1
net/samba/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
A LanManager(R)-compatible server suite for Unix
|
16
net/samba/pkg/DESCR
Normal file
16
net/samba/pkg/DESCR
Normal file
|
@ -0,0 +1,16 @@
|
|||
The Samba suite is a set of programs which run under Unix-like
|
||||
operating systems. These programs deliver most of the important
|
||||
functionality of a Microsoft Lan Manager server. That is, they support
|
||||
remote access to Un*x filespace and Un*x printers from Lan Manager
|
||||
compatible clients. In practical terms, this means that such clients
|
||||
can connect to and use FreeBSD filespace as if it was a local disk drive,
|
||||
or FreeBSD printers as if they were local printers.
|
||||
|
||||
Some of the most popular Lan Manager compatible clients include Lan
|
||||
Manager itself, Windows for Workgroups, OS/2 and Windows NT.
|
||||
|
||||
Please note that if you want to use Windows NT 4.0 + Service Pack 3
|
||||
or above as clients, you have to use -des version of samba ports.
|
||||
-des version is not redistributable as a binary package because of
|
||||
the export control of US. Please type make install at net/samba-des
|
||||
in ports collection.
|
75
net/samba/pkg/PLIST
Normal file
75
net/samba/pkg/PLIST
Normal file
|
@ -0,0 +1,75 @@
|
|||
bin/smbclient
|
||||
bin/smbrun
|
||||
bin/smbstatus
|
||||
bin/smbpasswd
|
||||
bin/nmblookup
|
||||
bin/smbtar
|
||||
bin/addtosmbpass
|
||||
bin/testparm
|
||||
bin/testprns
|
||||
sbin/smbd
|
||||
sbin/nmbd
|
||||
man/man1/smbstatus.1.gz
|
||||
man/man1/smbclient.1.gz
|
||||
man/man1/smbrun.1.gz
|
||||
man/man1/smbtar.1.gz
|
||||
man/man1/testparm.1.gz
|
||||
man/man1/testprns.1.gz
|
||||
man/man5/smb.conf.5.gz
|
||||
man/man7/samba.7.gz
|
||||
man/man8/smbd.8.gz
|
||||
man/man8/nmbd.8.gz
|
||||
man/man8/smbpasswd.8.gz
|
||||
share/doc/samba/faq/Samba-Server-FAQ-1.html
|
||||
share/doc/samba/faq/Samba-Server-FAQ-2.html
|
||||
share/doc/samba/faq/Samba-Server-FAQ.html
|
||||
share/doc/samba/faq/Samba-Server-FAQ.sgml
|
||||
share/doc/samba/faq/Samba-meta-FAQ-1.html
|
||||
share/doc/samba/faq/Samba-meta-FAQ-2.html
|
||||
share/doc/samba/faq/Samba-meta-FAQ-3.html
|
||||
share/doc/samba/faq/Samba-meta-FAQ-4.html
|
||||
share/doc/samba/faq/Samba-meta-FAQ-5.html
|
||||
share/doc/samba/faq/Samba-meta-FAQ-6.html
|
||||
share/doc/samba/faq/Samba-meta-FAQ.html
|
||||
share/doc/samba/faq/Samba-meta-FAQ.sgml
|
||||
share/doc/samba/faq/Samba-meta-FAQ.txt
|
||||
share/doc/samba/faq/sambafaq-1.html
|
||||
share/doc/samba/faq/sambafaq-2.html
|
||||
share/doc/samba/faq/sambafaq-3.html
|
||||
share/doc/samba/faq/sambafaq-4.html
|
||||
share/doc/samba/faq/sambafaq-5.html
|
||||
share/doc/samba/faq/sambafaq.html
|
||||
share/doc/samba/faq/sambafaq.sgml
|
||||
share/doc/samba/faq/sambafaq.txt
|
||||
share/doc/samba/Application_Serving.txt
|
||||
share/doc/samba/BROWSING.txt
|
||||
share/doc/samba/BUGS.txt
|
||||
share/doc/samba/DIAGNOSIS.txt
|
||||
share/doc/samba/DNIX.txt
|
||||
share/doc/samba/DOMAIN.txt
|
||||
share/doc/samba/DOMAIN_CONTROL.txt
|
||||
share/doc/samba/ENCRYPTION.txt
|
||||
share/doc/samba/Faxing.txt
|
||||
share/doc/samba/GOTCHAS.txt
|
||||
share/doc/samba/HINTS.txt
|
||||
share/doc/samba/MIRRORS.txt
|
||||
share/doc/samba/NetBIOS.txt
|
||||
share/doc/samba/OS2-Client-HOWTO.txt
|
||||
share/doc/samba/Passwords.txt
|
||||
share/doc/samba/Printing.txt
|
||||
share/doc/samba/SCO.txt
|
||||
share/doc/samba/Speed.txt
|
||||
share/doc/samba/Support.txt
|
||||
share/doc/samba/Tracing.txt
|
||||
share/doc/samba/UNIX-SMB.txt
|
||||
share/doc/samba/Win95.txt
|
||||
share/doc/samba/UNIX_INSTALL.txt
|
||||
share/doc/samba/WinNT.txt
|
||||
share/doc/samba/security_level.txt
|
||||
share/doc/samba/README.DCEDFS
|
||||
share/doc/samba/README.jis
|
||||
share/doc/samba/README.sambatar
|
||||
etc/rc.d/samba.sh.sample
|
||||
etc/smb.conf.sample
|
||||
@dirrm share/doc/samba/faq
|
||||
@dirrm share/doc/samba
|
Loading…
Reference in a new issue