Install GTK pixmaps in ${PREFIX}/share/pixmaps, not /usr/share/pixmaps.
Fix PLIST to include the files. XXX: If you had this package installed, you can rm /usr/share/pixmaps/*screensaver* and probably rmdir /usr/share/pixmaps
This commit is contained in:
parent
1cd3ee1729
commit
eb45de28e9
4 changed files with 34 additions and 9 deletions
|
@ -1,4 +1,4 @@
|
||||||
@comment $NetBSD: PLIST,v 1.6 2002/03/19 15:34:32 wiz Exp $
|
@comment $NetBSD: PLIST,v 1.7 2002/04/06 11:16:43 wiz Exp $
|
||||||
bin/xscreensaver
|
bin/xscreensaver
|
||||||
bin/xscreensaver-command
|
bin/xscreensaver-command
|
||||||
bin/xscreensaver-demo
|
bin/xscreensaver-demo
|
||||||
|
@ -393,5 +393,12 @@ man/man1/xspirograph.1
|
||||||
man/man1/xsublim.1
|
man/man1/xsublim.1
|
||||||
man/man1/xteevee.1
|
man/man1/xteevee.1
|
||||||
man/man1/zoom.1
|
man/man1/zoom.1
|
||||||
|
share/pixmaps/screensaver-cmndln.xpm
|
||||||
|
share/pixmaps/screensaver-colorselector.xpm
|
||||||
|
share/pixmaps/screensaver-diagnostic.xpm
|
||||||
|
share/pixmaps/screensaver-locking.xpm
|
||||||
|
share/pixmaps/screensaver-power.xpm
|
||||||
|
share/pixmaps/screensaver-snap.xpm
|
||||||
|
share/pixmaps/xscreensaver.xpm
|
||||||
@dirrm libexec/xscreensaver/config
|
@dirrm libexec/xscreensaver/config
|
||||||
@dirrm libexec/xscreensaver
|
@dirrm libexec/xscreensaver
|
||||||
|
|
|
@ -1,9 +1,9 @@
|
||||||
$NetBSD: distinfo,v 1.16 2002/04/05 12:05:31 skrll Exp $
|
$NetBSD: distinfo,v 1.17 2002/04/06 11:16:43 wiz Exp $
|
||||||
|
|
||||||
SHA1 (xscreensaver-4.02.tar.gz) = b32cf3ed37680669a4a7ea2b945fadb5841fc6b3
|
SHA1 (xscreensaver-4.02.tar.gz) = b32cf3ed37680669a4a7ea2b945fadb5841fc6b3
|
||||||
Size (xscreensaver-4.02.tar.gz) = 2201442 bytes
|
Size (xscreensaver-4.02.tar.gz) = 2201442 bytes
|
||||||
SHA1 (patch-aa) = 9d7d54e7fe554e5fe44908b6a96923a019210feb
|
SHA1 (patch-aa) = 48beab31e1528d5d0234a662258ee589384dce71
|
||||||
SHA1 (patch-ab) = 3f60a99f7d45f38b6c4afe2fcc6eafc9456acb30
|
SHA1 (patch-ab) = 3f60a99f7d45f38b6c4afe2fcc6eafc9456acb30
|
||||||
SHA1 (patch-ac) = 4f201f01b65935c57efa7bfec8291f29a7ff1280
|
SHA1 (patch-ac) = 4f201f01b65935c57efa7bfec8291f29a7ff1280
|
||||||
SHA1 (patch-ae) = 9209256c4dcc7bde3dd812bb8fcbad1f8b4f0f08
|
SHA1 (patch-ae) = 9209256c4dcc7bde3dd812bb8fcbad1f8b4f0f08
|
||||||
SHA1 (patch-af) = a585edb4e65067e7b3913944093f9d18045d27d9
|
SHA1 (patch-af) = bebfa87e2df4f27221d701898c820bbdda3e6316
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
$NetBSD: patch-aa,v 1.18 2002/04/05 11:25:54 skrll Exp $
|
$NetBSD: patch-aa,v 1.19 2002/04/06 11:16:43 wiz Exp $
|
||||||
|
|
||||||
--- configure.orig Mon Mar 18 23:42:35 2002
|
--- configure.orig Tue Mar 19 00:42:35 2002
|
||||||
+++ configure
|
+++ configure
|
||||||
@@ -1638,7 +1638,7 @@
|
@@ -1638,7 +1638,7 @@
|
||||||
# implement the "install-strip" target properly (strip executables,
|
# implement the "install-strip" target properly (strip executables,
|
||||||
|
@ -29,3 +29,12 @@ $NetBSD: patch-aa,v 1.18 2002/04/05 11:25:54 skrll Exp $
|
||||||
if test -d $d; then
|
if test -d $d; then
|
||||||
X_CFLAGS="-I$d $X_CFLAGS"
|
X_CFLAGS="-I$d $X_CFLAGS"
|
||||||
echo "$ac_t""$d" 1>&6
|
echo "$ac_t""$d" 1>&6
|
||||||
|
@@ -10745,7 +10745,7 @@
|
||||||
|
GTK_ICONDIR='$(GNOME_DATADIR)/pixmaps'
|
||||||
|
elif test "$have_gtk" = yes; then
|
||||||
|
# should this be "$(prefix)/share/pixmaps"? But /usr/X11R6/share/ is wrong...
|
||||||
|
- GTK_ICONDIR='/usr/share/pixmaps'
|
||||||
|
+ GTK_ICONDIR='$(prefix)/share/pixmaps'
|
||||||
|
else
|
||||||
|
GTK_ICONDIR=''
|
||||||
|
fi
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
$NetBSD: patch-af,v 1.6 2002/04/05 04:50:23 mycroft Exp $
|
$NetBSD: patch-af,v 1.7 2002/04/06 11:16:44 wiz Exp $
|
||||||
|
|
||||||
--- configure.in.orig Mon Mar 18 23:01:26 2002
|
--- configure.in.orig Tue Mar 19 00:01:26 2002
|
||||||
+++ configure.in Thu Apr 4 18:48:21 2002
|
+++ configure.in
|
||||||
@@ -1512,7 +1512,7 @@
|
@@ -1512,7 +1512,7 @@
|
||||||
if test "$have_kerberos5" = yes ; then
|
if test "$have_kerberos5" = yes ; then
|
||||||
# from Matt Knopp <mhat@infocalypse.netlag.com>
|
# from Matt Knopp <mhat@infocalypse.netlag.com>
|
||||||
|
@ -11,3 +11,12 @@ $NetBSD: patch-af,v 1.6 2002/04/05 04:50:23 mycroft Exp $
|
||||||
elif test "$have_kerberos" = yes ; then
|
elif test "$have_kerberos" = yes ; then
|
||||||
# from Tim Showalter <tjs@psaux.com> for FreeBSD 4.2
|
# from Tim Showalter <tjs@psaux.com> for FreeBSD 4.2
|
||||||
PASSWD_LIBS="$PASSWD_LIBS -lkrb -ldes -lcom_err"
|
PASSWD_LIBS="$PASSWD_LIBS -lkrb -ldes -lcom_err"
|
||||||
|
@@ -2988,7 +2988,7 @@
|
||||||
|
GTK_ICONDIR='$(GNOME_DATADIR)/pixmaps'
|
||||||
|
elif test "$have_gtk" = yes; then
|
||||||
|
# should this be "$(prefix)/share/pixmaps"? But /usr/X11R6/share/ is wrong...
|
||||||
|
- GTK_ICONDIR='/usr/share/pixmaps'
|
||||||
|
+ GTK_ICONDIR='$(prefix)/share/pixmaps'
|
||||||
|
else
|
||||||
|
GTK_ICONDIR=''
|
||||||
|
fi
|
||||||
|
|
Loading…
Reference in a new issue