hg-fastimport: adjust __init__.py for latest mercurial

Tested using 5.6.1 on python-27.
Patch from joerg@
This commit is contained in:
roy 2021-01-09 15:30:03 +00:00
parent 13043c99dd
commit eb52048171
3 changed files with 27 additions and 7 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.12 2020/11/07 16:52:19 wiz Exp $
# $NetBSD: Makefile,v 1.13 2021/01/09 15:30:03 roy Exp $
DISTNAME= danielj7-hg-fastimport-d41a42894dfa
PKGNAME= ${PYPKGPREFIX}-hg-fastimport-20170211
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= devel
MASTER_SITES= -https://bitbucket.org/danielj7/hg-fastimport/get/v20170211.tar.bz2
EXTRACT_SUFX= .tar.bz2

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.4 2017/07/25 16:12:56 joerg Exp $
$NetBSD: distinfo,v 1.5 2021/01/09 15:30:03 roy Exp $
SHA1 (danielj7-hg-fastimport-d41a42894dfa.tar.bz2) = 8820358107c9de776d6250052a3f15ecccfbcd44
RMD160 (danielj7-hg-fastimport-d41a42894dfa.tar.bz2) = c6d0f6654509632f3b8266f7a4da519ff6789542
SHA512 (danielj7-hg-fastimport-d41a42894dfa.tar.bz2) = fc207c90721dc5f32d477bfbd5c4d7634f9a16c28d6e21254bbd942cd4ad7053dbcfd3f0fed91ee797759203f4196985d5bc3132618c58331c06a8fa764124b3
Size (danielj7-hg-fastimport-d41a42894dfa.tar.bz2) = 30701 bytes
SHA1 (patch-hgfastimport_____init____.py) = b5fd1d95411380e88cdc032f72ef4c67cbf0e3b4
SHA1 (patch-hgfastimport_____init____.py) = c3d9b92a1c609f1ee979b836c79a3759038c987b
SHA1 (patch-hgfastimport_hgimport.py) = cb630c9a8e19ea37fcbf8bae0beae485bfa96b0b

View file

@ -1,7 +1,25 @@
$NetBSD: patch-hgfastimport_____init____.py,v 1.1 2017/07/25 16:12:56 joerg Exp $
$NetBSD: patch-hgfastimport_____init____.py,v 1.2 2021/01/09 15:30:03 roy Exp $
--- hgfastimport/__init__.py.orig 2017-02-12 01:21:40.000000000 +0000
+++ hgfastimport/__init__.py
@@ -4,7 +4,7 @@ from __future__ import absolute_import
from mercurial import (
encoding,
util,
- cmdutil,
+ commands,
)
from mercurial.i18n import _
@@ -19,7 +19,7 @@ from .hgimport import fastimport_source
# XXX sort options copied straight from hgext/convert/__init__.py
cmdtable = {}
-command = cmdutil.command(cmdtable)
+command = commands.command
testedwith = '4.1'
@@ -27,7 +27,11 @@ testedwith = '4.1'
@command("fastimport",
[('', 'branchsort', None, _('try to sort changesets by branches')),
@ -15,11 +33,13 @@ $NetBSD: patch-hgfastimport_____init____.py,v 1.1 2017/07/25 16:12:56 joerg Exp
_('hg fastimport SOURCE ...'),
norepo=False)
def fastimport(ui, repo, *sources, **opts):
@@ -56,7 +60,7 @@ def fastimport(ui, repo, *sources, **opt
@@ -55,8 +59,8 @@ def fastimport(ui, repo, *sources, **opt
encoding.encoding = 'UTF-8'
# sink is the current repo, src is the list of fastimport streams
destc = hg.mercurial_sink(ui, repo.root)
- destc = hg.mercurial_sink(ui, repo.root)
- srcc = fastimport_source(ui, repo, sources)
+ destc = hg.mercurial_sink(ui, 'hg', repo.root)
+ srcc = fastimport_source(ui, repo, sources, opts['fallback_message_encoding'], opts['compress'], opts['blob_tree_depth'], opts['blob_tree'])
# XXX figuring out sortmode copied straight from hgext/convert/convcmd.py