Avoid left-shifting negative constants.
This commit is contained in:
parent
7a1b45399a
commit
eb6edeeaad
2 changed files with 15 additions and 1 deletions
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.3 2014/02/18 15:01:09 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.4 2015/09/08 18:52:13 joerg Exp $
|
||||
|
||||
SHA1 (b-o-s-s-a-code-05bfcc39bc0453c3028b1161175b95a81af7a901.zip) = 4a21cb6c19ad755fd31f6f0b96b6b1dd997c62c9
|
||||
RMD160 (b-o-s-s-a-code-05bfcc39bc0453c3028b1161175b95a81af7a901.zip) = eb9cc01f00bf9c8f1d59ea11e0b8cede532e4829
|
||||
Size (b-o-s-s-a-code-05bfcc39bc0453c3028b1161175b95a81af7a901.zip) = 692158 bytes
|
||||
SHA1 (patch-Makefile-NetBSD) = f3a145cadd6a889295b6f589c07c14d0468b7c98
|
||||
SHA1 (patch-PortFactory.h) = 4faae14f2efe2fc20eac90910b458484060ee2da
|
||||
SHA1 (patch-src_arm-dis_arm-dis.cpp) = 3e3b96bf9ea2213cbfd82df5e91c54cbdf2b9b52
|
||||
|
|
13
cross/bossa/patches/patch-src_arm-dis_arm-dis.cpp
Normal file
13
cross/bossa/patches/patch-src_arm-dis_arm-dis.cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-src_arm-dis_arm-dis.cpp,v 1.1 2015/09/08 18:52:13 joerg Exp $
|
||||
|
||||
--- src/arm-dis/arm-dis.cpp.orig 2015-09-03 11:58:25.000000000 +0000
|
||||
+++ src/arm-dis/arm-dis.cpp
|
||||
@@ -1961,7 +1961,7 @@ print_insn_coprocessor (bfd_vma pc,
|
||||
|
||||
/* Is ``imm'' a negative number? */
|
||||
if (imm & 0x40)
|
||||
- imm |= (-1 << 7);
|
||||
+ imm |= -128;
|
||||
|
||||
func (stream, "%d", imm);
|
||||
}
|
Loading…
Reference in a new issue