Add some explicit casts to help make_pair create the right type.
Add missing include.
This commit is contained in:
parent
76232f77cf
commit
eb7ce48f98
3 changed files with 28 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.21 2013/07/14 02:32:34 obache Exp $
|
||||
$NetBSD: distinfo,v 1.22 2013/08/31 14:52:14 joerg Exp $
|
||||
|
||||
SHA1 (gnash-0.8.10.tar.bz2) = be3b12a5edcd3b05f2ae73d02f0991aa786e7300
|
||||
RMD160 (gnash-0.8.10.tar.bz2) = 0093174ec0a912309772c033b5f1c1ad46ab41dc
|
||||
|
@ -7,11 +7,13 @@ SHA1 (patch-aa) = 5e3cfa0c21f6bd9ad01ce4c9f68f245316d063a3
|
|||
SHA1 (patch-ae) = ca44e2559a1ce0a24baf6d5479636f967e011202
|
||||
SHA1 (patch-libbase_GnashImageGif.cpp) = e08a9657269ac7f37ad892a003ac9025deda6c9f
|
||||
SHA1 (patch-libbase_GnashSleep.h) = f713b29feb0153efa24c10df20e0ac8342b88265
|
||||
SHA1 (patch-libbase_IOChannel.h) = 6b2b66291598e574f13a6a5ee905d6d5f1a459e8
|
||||
SHA1 (patch-libbase_Makefile.in) = c5b6533f5ac2b2ee26d0547c3054375e72512ccf
|
||||
SHA1 (patch-libbase_rc.cpp) = 2df75034a7f195864931504041ad956142495313
|
||||
SHA1 (patch-libcore_Makefile.in) = 6b92917f0be3779b7f6e1993ac29960cef50c736
|
||||
SHA1 (patch-libcore_movie__root.cpp) = 5ee7321011961427effd7951860cbf5f3c0b0a6f
|
||||
SHA1 (patch-libcore_swf_DefineButtonTag.h) = 9306aab8a56e3447037d7aa1f9f67daec3c6c15a
|
||||
SHA1 (patch-libmedia_FLVParser.cpp) = e990c82edceb3c5d481d7de86e720139b4dc60ea
|
||||
SHA1 (patch-libmedia_Makefile.in) = 10fde4560a20dcb28599d8c51a4fc7af93109474
|
||||
SHA1 (patch-librender_Makefile.in) = 25e38d82e3ecc156ff1f2b855a05437da015f3ce
|
||||
SHA1 (patch-libsound_Makefile.in) = 26c7390196b7e0bb301427b27cf87a1ae52f0b87
|
||||
|
|
12
multimedia/gnash/patches/patch-libbase_IOChannel.h
Normal file
12
multimedia/gnash/patches/patch-libbase_IOChannel.h
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-libbase_IOChannel.h,v 1.1 2013/08/31 14:52:14 joerg Exp $
|
||||
|
||||
--- libbase/IOChannel.h.orig 2013-08-31 11:55:31.000000000 +0000
|
||||
+++ libbase/IOChannel.h
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <string>
|
||||
#include <boost/cstdint.hpp> // for boost int types
|
||||
#include <iosfwd>
|
||||
+#include <ios>
|
||||
|
||||
#include "dsodefs.h" // DSOEXPORT
|
||||
#include "GnashException.h" // for IOException inheritance
|
13
multimedia/gnash/patches/patch-libmedia_FLVParser.cpp
Normal file
13
multimedia/gnash/patches/patch-libmedia_FLVParser.cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-libmedia_FLVParser.cpp,v 1.1 2013/08/31 14:52:14 joerg Exp $
|
||||
|
||||
--- libmedia/FLVParser.cpp.orig 2013-08-31 11:58:57.000000000 +0000
|
||||
+++ libmedia/FLVParser.cpp
|
||||
@@ -447,7 +447,7 @@ FLVParser::parseNextTag(bool index_only)
|
||||
}
|
||||
|
||||
boost::mutex::scoped_lock lock(_metaTagsMutex);
|
||||
- _metaTags.insert(std::make_pair(flvtag.timestamp, metaTag.release()));
|
||||
+ _metaTags.insert(std::make_pair(boost::uint64_t(flvtag.timestamp), boost::shared_ptr<SimpleBuffer>(metaTag.release())));
|
||||
}
|
||||
else
|
||||
{
|
Loading…
Reference in a new issue