Update protobuf-c to 1.3.0
protobuf-c (1.3.0) [ Robert Edmonds ] * Release 1.3.0. * Add test case for the issue in #220 (#254). * Fix issue #251, "Bad enums with multiple oneofs" (#256). * Add warning flags to my_CFLAGS (#257). * Fix namespace errors when compiled with latest protobuf (#280). * Bump minimum required header version for proto3 syntax (#282). [ Paolo Borelli ] * Turn the compiler into a protoc plugin (#206). This allows the protobuf-c compiler to be invoked as "protoc --c_out=...". For backwards compatibility, we still ship a protoc-c command, but it's a symlink to the protoc-gen-c binary. * proto3 support (#228). * Remove leftover FIXME comment (#258). * Fix proto3 "is zeroish" evaluation (#264). * Small cleanup in oneof handling (#265). * Rework is_zeroish one more time (#267). * proto3: make strings default to "" instead of NULL (#274). [ Tomek Wasilczyk ] * Fix -Wsign-compare warnings (#213). * Fix ISO C90 -Wdeclaration-after-statement warnings (#214). * Fix bigendian -Wunused-label warning (#215). [ Ilya Lipnitsky ] * protoc-c/c_message.cc: Force int size on oneof enums (#221). Fixes wrong enum generation and handling for onceof cases (#220). [ Adnan ] * Fix cmake build if built as part of an external project (#231). [ Gregory Detal ] * Remove .pb.{cc,h} in distdir instead of top_distdir in order to prevent removing files from other projects when protobuf-c is included as an autotools subproject (#232). [ Ben Farnham ] * Relax autoconf constraint from v2.64 to v2.63 so that it works on older Linux distros (#233). [ Thomas Köckerbauer ] * rm argument fix for Solaris (#234). * Add 'const' qualifier to 'init_value' variable in generated files (#236). [ Richard Kettlewell ] * Document and extend the effect of passing NULL to ..._free_unpacked functions (#255). [ Alex Milich ] * CMake: Workaround for static builds that use MSVC (#243). [ Josh Junon ] * CMake: Allow protobuf-c to be included via include_subdirectory (#245). [ Alexei Kasatkin ] * CMake: Windows fixes (#266).
This commit is contained in:
parent
e197265dd6
commit
eb96b0e04d
4 changed files with 9 additions and 28 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.2 2016/02/21 16:04:20 wiedi Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2017/08/30 11:05:05 wiedi Exp $
|
||||
|
||||
DISTNAME= protobuf-c-1.2.1
|
||||
DISTNAME= protobuf-c-1.3.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=protobuf-c/}
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2015/06/10 01:39:33 wiedi Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2017/08/30 11:05:05 wiedi Exp $
|
||||
bin/protoc-c
|
||||
bin/protoc-gen-c
|
||||
include/google/protobuf-c/protobuf-c.h
|
||||
include/protobuf-c/protobuf-c.h
|
||||
lib/libprotobuf-c.la
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.3 2016/02/21 16:04:20 wiedi Exp $
|
||||
$NetBSD: distinfo,v 1.4 2017/08/30 11:05:05 wiedi Exp $
|
||||
|
||||
SHA1 (protobuf-c-1.2.1.tar.gz) = 3ecd015299d5a8ab8304bf5eeea2fd0f75c1f6bb
|
||||
RMD160 (protobuf-c-1.2.1.tar.gz) = 16b5203a792b4db8adc18d5ec47546a7cdd377a1
|
||||
SHA512 (protobuf-c-1.2.1.tar.gz) = 1e9314dd93768067ecde981edc1e81cd54c53c8cbf7992cfc319e6ab56795dc5571e8f88d5f6fd428f27f6cda2bd7c14c48929b2944553afb7ab28b9589cf992
|
||||
Size (protobuf-c-1.2.1.tar.gz) = 117856 bytes
|
||||
SHA1 (protobuf-c-1.3.0.tar.gz) = b1df242c1445e2cc22708ca1889f5ce63bcbfc6c
|
||||
RMD160 (protobuf-c-1.3.0.tar.gz) = 528c1ae07297990f1e3405db2e3129eef9823698
|
||||
SHA512 (protobuf-c-1.3.0.tar.gz) = 52a8564c4570ce45de41f664d2c8edaa0712a5c076d6c9b48a4a1022df83ba5f2e1950823a0e91c2754d9ea9922e11d0cc86f82c23ba77e0f0c5659ed43126aa
|
||||
Size (protobuf-c-1.3.0.tar.gz) = 123153 bytes
|
||||
SHA1 (patch-Makefile.am) = 7e037f255e8415cf3584adb0f652aabc71b4ecfe
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
$NetBSD: patch-Makefile.am,v 1.1 2015/06/10 01:39:33 wiedi Exp $
|
||||
|
||||
rm -v is not portable
|
||||
|
||||
--- Makefile.am.orig 2015-03-14 21:00:57.000000000 +0000
|
||||
+++ Makefile.am
|
||||
@@ -185,11 +185,11 @@ EXTRA_DIST += \
|
||||
CLEANFILES += $(BUILT_SOURCES)
|
||||
|
||||
dist-hook:
|
||||
- rm -vf `find $(top_distdir) -name '*.pb-c.[ch]' -o -name '*.pb.cc' -o -name '*.pb.h'`
|
||||
+ rm -f `find $(top_distdir) -name '*.pb-c.[ch]' -o -name '*.pb.cc' -o -name '*.pb.h'`
|
||||
|
||||
install-data-hook:
|
||||
$(MKDIR_P) $(DESTDIR)$(includedir)/google/protobuf-c
|
||||
- cd $(DESTDIR)$(includedir)/google/protobuf-c && rm -vf protobuf-c.h
|
||||
+ cd $(DESTDIR)$(includedir)/google/protobuf-c && rm -f protobuf-c.h
|
||||
cd $(DESTDIR)$(includedir)/google/protobuf-c && $(LN_S) ../../protobuf-c/protobuf-c.h protobuf-c.h
|
||||
|
||||
#
|
Loading…
Reference in a new issue