Fix conflicting local redefinition of an iterator.

This commit is contained in:
joerg 2012-10-26 20:19:40 +00:00
parent b2427e50de
commit ebdacc98a2
2 changed files with 22 additions and 1 deletions

View file

@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.6 2011/11/24 14:15:41 joerg Exp $
$NetBSD: distinfo,v 1.7 2012/10/26 20:19:40 joerg Exp $
SHA1 (krecipes-1.0-beta1.tar.gz) = c1274f035476778d9b3f85bc007752ba0af841e3
RMD160 (krecipes-1.0-beta1.tar.gz) = c32732255bbf530932fa3183581be72e12e7a2d2
Size (krecipes-1.0-beta1.tar.gz) = 8682447 bytes
SHA1 (patch-aa) = 073893dcf03798122eaa0161100d7b56e35e4715
SHA1 (patch-krecipes_src_dialogs_ingredientsdialog.cpp) = 09b8a1276931ce1a6a54ee399c0be128e79abc90
SHA1 (patch-krecipes_src_importers_kreimporter.h) = e875275b530ec7246d1276d67854506780586a80
SHA1 (patch-krecipes_src_importers_recipemlimporter.h) = 004385da2f3104f5ea72a02fa866577a2e4d82ca

View file

@ -0,0 +1,20 @@
$NetBSD: patch-krecipes_src_dialogs_ingredientsdialog.cpp,v 1.1 2012/10/26 20:19:40 joerg Exp $
--- krecipes/src/dialogs/ingredientsdialog.cpp.orig 2012-10-26 18:14:37.000000000 +0000
+++ krecipes/src/dialogs/ingredientsdialog.cpp
@@ -551,12 +551,12 @@ void IngredientsDialog::reloadWeightList
QListViewItem * lastElement = weightsListView->listView() ->lastItem();
Weight w = *weight_it;
- WeightListItem *weight_it = new WeightListItem( weightsListView->listView(), lastElement, w );
- weight_it->setAmountUnit( w.perAmount,
+ WeightListItem *weight_it2 = new WeightListItem( weightsListView->listView(), lastElement, w );
+ weight_it2->setAmountUnit( w.perAmount,
database->unitName(w.perAmountUnitID),
Element((w.prepMethodID==-1)?QString::null:database->prepMethodName(w.prepMethodID),w.prepMethodID)
);
- weight_it->setWeightUnit( w.weight, database->unitName(w.weightUnitID) );
+ weight_it2->setWeightUnit( w.weight, database->unitName(w.weightUnitID) );
}
}
}