Remove devel/stlport as promised; it has been unbuildable in years,

and to the extent it isn't dead upstream (which appears to be very
limited) upstream isn't interested in making releases.
This commit is contained in:
dholland 2012-12-29 19:23:32 +00:00
parent f69b8cf333
commit ebf67d550d
9 changed files with 0 additions and 657 deletions

View file

@ -1,7 +0,0 @@
STLPort features a complete ANSI C++ standard library. Main features are:
+ Includes <complex> and SGI iostreams.
+ Can be configured to use either SGI or native iostreams.
+ Debug mode containers are implemented in terms of wrappers around non-debug
ones. That provides for more clean and efficient implementation. In Debug
Mode, different namespace _STLD:: is being used, so no link-time clashes
between debug and non-debug versions are possible.

View file

@ -1,61 +0,0 @@
# $NetBSD: Makefile,v 1.34 2012/10/31 11:19:47 asau Exp $
DISTNAME= STLport-4.6
PKGNAME= stlport-4.6
PKGREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.stlport.com/archive/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.stlport.org/
COMMENT= Complete C++ standard library
BROKEN= Unbuildable for years and appears to be dead upstream.
USE_TOOLS+= gmake
USE_LIBTOOL= yes
USE_LANGUAGES= c c++
NO_CONFIGURE= yes
BUILD_DIRS= src
MAKE_ENV+= CXXFLAGS=${CXXFLAGS:M*:Q}
MAKE_FILE= gcc-libtool.mak
PTHREAD_OPTS+= require
PTHREAD_AUTO_VARS= yes
LDFLAGS+= ${PTHREAD_LIBS}
LIBDIR= ${PREFIX}/lib
HTMLDIR= ${PREFIX}/share/doc/html/stlport
INSTALLATION_DIRS= include lib
pre-install:
cd ${WRKSRC:Q}/stlport && ${RM} -rf BC50 config/new_compiler old_hp
do-install:
set -e; \
cd ${WRKSRC:Q}; \
${FIND} stlport -type d -print \
| while read d; do \
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX:Q}/include/"$$d"; \
done; \
${FIND} stlport -type f ! -name "*.orig" -print \
| while read f; do \
${INSTALL_DATA} "$$f" ${DESTDIR}${PREFIX:Q}/include/"$$f"; \
done
set -e; \
for lib in \
libstlport_gcc.la \
libstlport_gcc_stldebug.la; \
do \
${LIBTOOL} --mode=install ${INSTALL_LIB} ${WRKSRC:Q}/lib/"$$lib" ${DESTDIR}${LIBDIR:Q}; \
done
${INSTALL_DATA_DIR} ${DESTDIR}${HTMLDIR:Q}
${INSTALL_DATA_DIR} ${DESTDIR}${HTMLDIR:Q}/images
cd ${WRKSRC:Q}/doc && ${INSTALL_DATA} *.css *.html ${DESTDIR}${HTMLDIR:Q}
cd ${WRKSRC:Q}/doc && ${INSTALL_DATA} images/* ${DESTDIR}${HTMLDIR:Q}/images
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,350 +0,0 @@
@comment $NetBSD: PLIST,v 1.5 2009/06/14 17:49:15 joerg Exp $
include/stlport/algorithm
include/stlport/bitset
include/stlport/cassert
include/stlport/cctype
include/stlport/cerrno
include/stlport/cfloat
include/stlport/climits
include/stlport/clocale
include/stlport/cmath
include/stlport/complex
include/stlport/config/_epilog.h
include/stlport/config/_msvc_warnings_off.h
include/stlport/config/_prolog.h
include/stlport/config/stl_apcc.h
include/stlport/config/stl_apple.h
include/stlport/config/stl_as400.h
include/stlport/config/stl_bc.h
include/stlport/config/stl_como.h
include/stlport/config/stl_confix.h
include/stlport/config/stl_cray.h
include/stlport/config/stl_dec.h
include/stlport/config/stl_dec_vms.h
include/stlport/config/stl_dm.h
include/stlport/config/stl_fujitsu.h
include/stlport/config/stl_gcc.h
include/stlport/config/stl_hpacc.h
include/stlport/config/stl_ibm.h
include/stlport/config/stl_icc.h
include/stlport/config/stl_intel.h
include/stlport/config/stl_kai.h
include/stlport/config/stl_mlc.h
include/stlport/config/stl_msvc.h
include/stlport/config/stl_mwerks.h
include/stlport/config/stl_mycomp.h
include/stlport/config/stl_sco.h
include/stlport/config/stl_select_lib.h
include/stlport/config/stl_sgi.h
include/stlport/config/stl_solaris.h
include/stlport/config/stl_sunpro.h
include/stlport/config/stl_symantec.h
include/stlport/config/stl_watcom.h
include/stlport/config/stl_wince.h
include/stlport/config/stlcomp.h
include/stlport/config/vc_select_lib.h
include/stlport/csetjmp
include/stlport/csignal
include/stlport/cstdarg
include/stlport/cstddef
include/stlport/cstdio
include/stlport/cstdlib
include/stlport/cstring
include/stlport/ctime
include/stlport/ctype.h
include/stlport/cwchar
include/stlport/cwctype
include/stlport/deque
include/stlport/exception
include/stlport/exception.h
include/stlport/export
include/stlport/export.sun
include/stlport/fstream
include/stlport/fstream.h
include/stlport/functional
include/stlport/hash_map
include/stlport/hash_set
include/stlport/iomanip
include/stlport/iomanip.h
include/stlport/ios
include/stlport/ios.h
include/stlport/iosfwd
include/stlport/iostream
include/stlport/iostream.h
include/stlport/istream
include/stlport/istream.h
include/stlport/iterator
include/stlport/limits
include/stlport/list
include/stlport/locale
include/stlport/locale.h
include/stlport/map
include/stlport/math.h
include/stlport/mem.h
include/stlport/memory
include/stlport/mmemory.h
include/stlport/new
include/stlport/new.h
include/stlport/numeric
include/stlport/ostream
include/stlport/ostream.h
include/stlport/pthread.h
include/stlport/pthread_alloc
include/stlport/queue
include/stlport/rlocks.h
include/stlport/rope
include/stlport/set
include/stlport/setjmp.h
include/stlport/signal.h
include/stlport/slist
include/stlport/sstream
include/stlport/stack
include/stlport/stdarg.h
include/stlport/stddef.h
include/stlport/stdexcept
include/stlport/stdio.h
include/stlport/stdio_streambuf
include/stlport/stdiostream.h
include/stlport/stdlib.h
include/stlport/stl/_abbrevs.h
include/stlport/stl/_algo.c
include/stlport/stl/_algo.h
include/stlport/stl/_algobase.c
include/stlport/stl/_algobase.h
include/stlport/stl/_alloc.c
include/stlport/stl/_alloc.h
include/stlport/stl/_alloc_old.h
include/stlport/stl/_auto_ptr.h
include/stlport/stl/_bitset.c
include/stlport/stl/_bitset.h
include/stlport/stl/_bvector.h
include/stlport/stl/_check_config.h
include/stlport/stl/_cmath.h
include/stlport/stl/_codecvt.h
include/stlport/stl/_collate.h
include/stlport/stl/_complex.c
include/stlport/stl/_complex.h
include/stlport/stl/_config.h
include/stlport/stl/_config_compat.h
include/stlport/stl/_config_compat_post.h
include/stlport/stl/_construct.h
include/stlport/stl/_ctraits_fns.h
include/stlport/stl/_ctype.h
include/stlport/stl/_cwchar.h
include/stlport/stl/_deque.c
include/stlport/stl/_deque.h
include/stlport/stl/_epilog.h
include/stlport/stl/_exception.h
include/stlport/stl/_fstream.c
include/stlport/stl/_fstream.h
include/stlport/stl/_function.h
include/stlport/stl/_function_adaptors.h
include/stlport/stl/_function_base.h
include/stlport/stl/_hash_fun.h
include/stlport/stl/_hash_map.h
include/stlport/stl/_hash_set.h
include/stlport/stl/_hashtable.c
include/stlport/stl/_hashtable.h
include/stlport/stl/_heap.c
include/stlport/stl/_heap.h
include/stlport/stl/_ios.c
include/stlport/stl/_ios.h
include/stlport/stl/_ios_base.h
include/stlport/stl/_iosfwd.h
include/stlport/stl/_istream.c
include/stlport/stl/_istream.h
include/stlport/stl/_istreambuf_iterator.h
include/stlport/stl/_iterator.h
include/stlport/stl/_iterator_base.h
include/stlport/stl/_iterator_old.h
include/stlport/stl/_limits.c
include/stlport/stl/_limits.h
include/stlport/stl/_list.c
include/stlport/stl/_list.h
include/stlport/stl/_locale.h
include/stlport/stl/_map.h
include/stlport/stl/_messages_facets.h
include/stlport/stl/_monetary.c
include/stlport/stl/_monetary.h
include/stlport/stl/_new.h
include/stlport/stl/_null_stream.h
include/stlport/stl/_num_get.c
include/stlport/stl/_num_get.h
include/stlport/stl/_num_put.c
include/stlport/stl/_num_put.h
include/stlport/stl/_numeric.c
include/stlport/stl/_numeric.h
include/stlport/stl/_numpunct.h
include/stlport/stl/_ostream.c
include/stlport/stl/_ostream.h
include/stlport/stl/_ostreambuf_iterator.h
include/stlport/stl/_pair.h
include/stlport/stl/_prolog.h
include/stlport/stl/_pthread_alloc.c
include/stlport/stl/_pthread_alloc.h
include/stlport/stl/_ptrs_specialize.h
include/stlport/stl/_queue.h
include/stlport/stl/_range_errors.h
include/stlport/stl/_raw_storage_iter.h
include/stlport/stl/_relops.h
include/stlport/stl/_relops_cont.h
include/stlport/stl/_relops_hash_cont.h
include/stlport/stl/_relops_template.h
include/stlport/stl/_rope.c
include/stlport/stl/_rope.h
include/stlport/stl/_set.h
include/stlport/stl/_site_config.h
include/stlport/stl/_slist.c
include/stlport/stl/_slist.h
include/stlport/stl/_slist_base.c
include/stlport/stl/_slist_base.h
include/stlport/stl/_sparc_atomic.h
include/stlport/stl/_sstream.c
include/stlport/stl/_sstream.h
include/stlport/stl/_stack.h
include/stlport/stl/_stdio_file.h
include/stlport/stl/_stream_iterator.h
include/stlport/stl/_streambuf.c
include/stlport/stl/_streambuf.h
include/stlport/stl/_streambuf_iterator.h
include/stlport/stl/_string.c
include/stlport/stl/_string.h
include/stlport/stl/_string_fwd.c
include/stlport/stl/_string_fwd.h
include/stlport/stl/_string_hash.h
include/stlport/stl/_string_io.c
include/stlport/stl/_string_io.h
include/stlport/stl/_strstream.h
include/stlport/stl/_tempbuf.c
include/stlport/stl/_tempbuf.h
include/stlport/stl/_threads.c
include/stlport/stl/_threads.h
include/stlport/stl/_time_facets.c
include/stlport/stl/_time_facets.h
include/stlport/stl/_tree.c
include/stlport/stl/_tree.h
include/stlport/stl/_uninitialized.h
include/stlport/stl/_valarray.c
include/stlport/stl/_valarray.h
include/stlport/stl/_vector.c
include/stlport/stl/_vector.h
include/stlport/stl/c_locale.h
include/stlport/stl/char_traits.h
include/stlport/stl/concept_checks.h
include/stlport/stl/debug/_debug.c
include/stlport/stl/debug/_debug.h
include/stlport/stl/debug/_deque.h
include/stlport/stl/debug/_hashtable.h
include/stlport/stl/debug/_iterator.h
include/stlport/stl/debug/_list.h
include/stlport/stl/debug/_relops_cont.h
include/stlport/stl/debug/_relops_hash_cont.h
include/stlport/stl/debug/_slist.h
include/stlport/stl/debug/_string.h
include/stlport/stl/debug/_tree.h
include/stlport/stl/debug/_vector.h
include/stlport/stl/msl_string.h
include/stlport/stl/type_traits.h
include/stlport/stl/wrappers/_deque.h
include/stlport/stl/wrappers/_hash_map.h
include/stlport/stl/wrappers/_hash_set.h
include/stlport/stl/wrappers/_list.h
include/stlport/stl/wrappers/_map.h
include/stlport/stl/wrappers/_mmap.h
include/stlport/stl/wrappers/_set.h
include/stlport/stl/wrappers/_slist.h
include/stlport/stl/wrappers/_vector.h
include/stlport/stl_user_config.h
include/stlport/streambuf
include/stlport/streambuf.h
include/stlport/string
include/stlport/string.h
include/stlport/strstream
include/stlport/strstream.h
include/stlport/time.h
include/stlport/typeinfo
include/stlport/typeinfo.h
include/stlport/using/cstring
include/stlport/using/export
include/stlport/using/fstream
include/stlport/using/h/fstream.h
include/stlport/using/h/iomanip.h
include/stlport/using/h/iostream.h
include/stlport/using/h/ostream.h
include/stlport/using/h/streambuf.h
include/stlport/using/h/strstream.h
include/stlport/using/iomanip
include/stlport/using/ios
include/stlport/using/iosfwd
include/stlport/using/iostream
include/stlport/using/istream
include/stlport/using/locale
include/stlport/using/ostream
include/stlport/using/sstream
include/stlport/using/streambuf
include/stlport/using/strstream
include/stlport/utility
include/stlport/valarray
include/stlport/vector
include/stlport/wchar.h
include/stlport/wctype.h
include/stlport/wrap_std/complex
include/stlport/wrap_std/export
include/stlport/wrap_std/fstream
include/stlport/wrap_std/h/fstream.h
include/stlport/wrap_std/h/iostream.h
include/stlport/wrap_std/h/streambuf.h
include/stlport/wrap_std/h/strstream.h
include/stlport/wrap_std/iomanip
include/stlport/wrap_std/ios
include/stlport/wrap_std/iosfwd
include/stlport/wrap_std/iostream
include/stlport/wrap_std/istream
include/stlport/wrap_std/locale
include/stlport/wrap_std/ostream
include/stlport/wrap_std/sstream
include/stlport/wrap_std/streambuf
include/stlport/wrap_std/strstream
lib/libstlport_gcc.la
lib/libstlport_gcc_stldebug.la
share/doc/html/stlport/README.BC.html
share/doc/html/stlport/README.CW.html
share/doc/html/stlport/README.DEC.html
share/doc/html/stlport/README.MPW.html
share/doc/html/stlport/README.VC++.html
share/doc/html/stlport/README.aCC.html
share/doc/html/stlport/README.gcc.html
share/doc/html/stlport/README.os390.html
share/doc/html/stlport/README.pow.html
share/doc/html/stlport/README.sgi40.html
share/doc/html/stlport/README.sunpro.html
share/doc/html/stlport/README.xlC.html
share/doc/html/stlport/auto_configure.html
share/doc/html/stlport/bug_report.html
share/doc/html/stlport/buglist.html
share/doc/html/stlport/compiler_readmes.html
share/doc/html/stlport/configure.html
share/doc/html/stlport/copyrights.html
share/doc/html/stlport/cvs.html
share/doc/html/stlport/debug_mode.html
share/doc/html/stlport/doc.css
share/doc/html/stlport/eh_testsuite.html
share/doc/html/stlport/exception_safety.html
share/doc/html/stlport/images/black.gif
share/doc/html/stlport/images/stl_logo_doc.gif
share/doc/html/stlport/images/t_doc2.gif
share/doc/html/stlport/images/trans.gif
share/doc/html/stlport/index.html
share/doc/html/stlport/install.html
share/doc/html/stlport/license.html
share/doc/html/stlport/platforms.html
share/doc/html/stlport/projects.html
share/doc/html/stlport/release_notes.html
share/doc/html/stlport/select_io.html
share/doc/html/stlport/sgi_stl.html
share/doc/html/stlport/story.html
share/doc/html/stlport/testsuite.html
share/doc/html/stlport/thanks.html
share/doc/html/stlport/use_stlport.html
share/doc/html/stlport/vendor_interface.html
share/doc/html/stlport/wrappers.html

View file

@ -1,10 +0,0 @@
$NetBSD: distinfo,v 1.9 2010/09/26 11:27:21 obache Exp $
SHA1 (STLport-4.6.tar.gz) = 55401b648bebc0b7b6b4e3d7b4e420d22c358af9
RMD160 (STLport-4.6.tar.gz) = da9d53334eebed285b096acc9d5e806395926f00
Size (STLport-4.6.tar.gz) = 756708 bytes
SHA1 (patch-aa) = 16b309bcbede9dbd2595c90c1d8193238c0414ab
SHA1 (patch-aj) = 67dd73dcf5a41dd2da38e58363a05f7f54709124
SHA1 (patch-ak) = ce55c80bc369bf9a8c20d751293197b71fbf4ed8
SHA1 (patch-al) = db8f177fb55fa1f41f4bd67b988b2f3ae6220fd6
SHA1 (patch-am) = 01a50206ec73f482c1e2ed7fee2733d7f422de5a

View file

@ -1,66 +0,0 @@
$NetBSD: patch-aa,v 1.6 2010/09/26 11:27:21 obache Exp $
--- src/gcc-libtool.mak.orig 2004-01-04 10:44:33.000000000 +0100
+++ src/gcc-libtool.mak
@@ -0,0 +1,61 @@
+#
+# Note : this makefile is for gcc-2.95 and later !
+#
+
+#
+# compiler
+#
+LIBTOOL ?= libtool
+CC ?= gcc
+CXX ?= c++ -fexceptions
+
+#
+# Basename for libraries
+#
+LIB_BASENAME = libstlport_gcc
+
+#
+# guts for common stuff
+#
+#
+LINK=$(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -o
+# 2.95 flag
+DYN_LINK=$(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -rpath $(PREFIX)/lib -version-info $(VERSION_MAJOR):$(VERSION_MINOR) -shared -o
+
+OBJEXT=lo
+DYNEXT=la
+STEXT=a
+RM=rm -rf
+PATH_SEP=/
+MKDIR=mkdir -p
+COMP=GCC$(ARCH)
+INSTALL_STEP = install_unix
+
+all: all_dynamic all_static
+
+include common_macros.mak
+
+WARNING_FLAGS= -Wall -W -Wno-sign-compare -Wno-unused -Wno-uninitialized -ftemplate-depth-32
+
+CXXFLAGS_COMMON = ${CXXFLAGS} ${CPPFLAGS} -I${STLPORT_DIR} ${WARNING_FLAGS}
+
+CXXFLAGS_RELEASE_static = $(CXXFLAGS_COMMON) -O2
+CXXFLAGS_RELEASE_dynamic = $(CXXFLAGS_COMMON) -O2
+
+CXXFLAGS_DEBUG_static = $(CXXFLAGS_COMMON) -O -g
+CXXFLAGS_DEBUG_dynamic = $(CXXFLAGS_COMMON) -O -g
+
+CXXFLAGS_STLDEBUG_static = $(CXXFLAGS_DEBUG_static) -D_STLP_DEBUG
+CXXFLAGS_STLDEBUG_dynamic = $(CXXFLAGS_DEBUG_dynamic) -D_STLP_DEBUG
+
+include common_percent_rules.mak
+include common_rules.mak
+
+
+#install: all
+# cp -p $(LIB_TARGET) ${D_LIB_TARGET} ../lib
+
+#%.s: %.cpp
+# $(CXX) $(CXXFLAGS) -O4 -S -pto $< -o $@
+
+

View file

@ -1,22 +0,0 @@
$NetBSD: patch-aj,v 1.1 2004/01/05 22:14:19 mrauch Exp $
--- stlport/config/stl_gcc.h.orig Mon Feb 24 01:51:01 2003
+++ stlport/config/stl_gcc.h
@@ -268,7 +268,7 @@ typedef unsigned int wint_t;
# define _STLP_NATIVE_OLD_STREAMS_INCLUDE_PATH ../g++-v3/backward
# else
# if defined(__GNUC_PATCHLEVEL__) && (__GNUC_PATCHLEVEL__ > 0)
-# define _STLP_NATIVE_INCLUDE_PATH ../__GNUC__.__GNUC_MINOR__.__GNUC_PATCHLEVEL__
+# define _STLP_NATIVE_INCLUDE_PATH ../g++
# define _STLP_NATIVE_OLD_STREAMS_INCLUDE_PATH ../__GNUC__.__GNUC_MINOR__.__GNUC_PATCHLEVEL__/backward
# else
# define _STLP_NATIVE_INCLUDE_PATH ../__GNUC__.__GNUC_MINOR__
@@ -330,7 +330,7 @@ typedef unsigned int wint_t;
# endif
# else
// azov
-# ifdef __Lynx__
+# if defined __Lynx__ || defined __NetBSD__
# define _STLP_NATIVE_CPP_RUNTIME_INCLUDE_PATH _STLP_NATIVE_INCLUDE_PATH
# else
# if (__GNUC__ > 2) || (__GNUC__ == 2 && __GNUC_MINOR__ >= 97)

View file

@ -1,38 +0,0 @@
$NetBSD: patch-ak,v 1.1 2004/01/05 22:14:19 mrauch Exp $
--- src/common_macros.mak.orig 2003-11-01 00:52:05.000000000 +0100
+++ src/common_macros.mak
@@ -34,16 +34,16 @@ STLDEBUG_OBJDIR_static=$(OBJDIR)$(PATH_S
RELEASE_OBJDIR_staticx=$(OBJDIR)$(PATH_SEP)Releasex
DEBUG_OBJDIR_staticx=$(OBJDIR)$(PATH_SEP)Debugx
STLDEBUG_OBJDIR_staticx=$(OBJDIR)$(PATH_SEP)DebugSTLx
-RELEASE_OBJDIR_dynamic=$(OBJDIR)$(PATH_SEP)ReleaseD
-DEBUG_OBJDIR_dynamic=$(OBJDIR)$(PATH_SEP)DebugD
-STLDEBUG_OBJDIR_dynamic=$(OBJDIR)$(PATH_SEP)DebugSTLD
+RELEASE_OBJDIR_dynamic=$(OBJDIR)$(PATH_SEP)Release
+DEBUG_OBJDIR_dynamic=$(OBJDIR)$(PATH_SEP)Debug
+STLDEBUG_OBJDIR_dynamic=$(OBJDIR)$(PATH_SEP)DebugSTL
#
# By default on UNIX, STLport headers go into /usr/local/include/stlport,
# and libraries go into /usr/local/lib. Please override any of them if desired.
#
-INSTALLDIR=/usr/local
+INSTALLDIR=$(PREFIX)
# INSTALLDIR=/tmp
INSTALLDIR_INC=$(INSTALLDIR)/include/stlport
INSTALLDIR_LIB=$(INSTALLDIR)/lib
@@ -62,9 +62,9 @@ RELEASE_NAME=$(LIB_BASENAME)
DEBUG_NAME=$(LIB_BASENAME)_debug
STLDEBUG_NAME=$(LIB_BASENAME)_stldebug
-RELEASE_DYNLIB=$(RELEASE_NAME).$(DYNEXT)$(DYNAMIC_SUFFIX)
-DEBUG_DYNLIB=$(DEBUG_NAME).$(DYNEXT)$(DYNAMIC_SUFFIX)
-STLDEBUG_DYNLIB=$(STLDEBUG_NAME).$(DYNEXT)$(DYNAMIC_SUFFIX)
+RELEASE_DYNLIB=$(RELEASE_NAME).$(DYNEXT)
+DEBUG_DYNLIB=$(DEBUG_NAME).$(DYNEXT)
+STLDEBUG_DYNLIB=$(STLDEBUG_NAME).$(DYNEXT)
RELEASE_DYNLIB_SONAME=$(RELEASE_NAME).$(DYNEXT)$(VERSION_SUFFIX)
DEBUG_DYNLIB_SONAME=$(DEBUG_NAME).$(DYNEXT)$(VERSION_SUFFIX)

View file

@ -1,81 +0,0 @@
$NetBSD: patch-al,v 1.2 2010/09/26 11:27:21 obache Exp $
--- src/common_percent_rules.mak.orig 2001-09-30 22:11:31.000000000 +0200
+++ src/common_percent_rules.mak
@@ -1,46 +1,46 @@
.SUFFIXES: .cpp .c .o .so .a
-$(RELEASE_OBJDIR_static)/%.o: %.cpp
- $(CXX) $(CXXFLAGS_RELEASE_static) $< -c -o $@
-$(RELEASE_OBJDIR_static)/%.o: %.c
- $(CC) $(CXXFLAGS_RELEASE_static) $< -c -o $@
+$(RELEASE_OBJDIR_static)/%.lo: %.cpp
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_RELEASE_static) $< -c -o $@
+$(RELEASE_OBJDIR_static)/%.lo: %.c
+ $(LIBTOOL) --mode=compile --tag=CXX $(CC) $(CXXFLAGS_RELEASE_static) $< -c -o $@
$(RELEASE_OBJDIR_static)/%.i : %.cpp
- $(CXX) $(CXXFLAGS_RELEASE_static) $< -E $@
+ $(LIBTOOL) $(CXX) --mode=compile --tag=CXX $(CXXFLAGS_RELEASE_static) $< -E $@
-$(RELEASE_OBJDIR_dynamic)/%.o : %.cpp
- $(CXX) $(CXXFLAGS_RELEASE_dynamic) $< -c -o $@
-$(RELEASE_OBJDIR_dynamic)/%.o : %.c
- $(CC) $(CXXFLAGS_RELEASE_dynamic) $< -c -o $@
+$(RELEASE_OBJDIR_dynamic)/%.lo : %.cpp
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_RELEASE_dynamic) $< -c -o $@
+$(RELEASE_OBJDIR_dynamic)/%.lo : %.c
+ $(LIBTOOL) --mode=compile TAG=CC $(CC) $(CXXFLAGS_RELEASE_dynamic) $< -c -o $@
$(RELEASE_OBJDIR_dynamic)/%.i : %.cpp
- $(CXX) $(CXXFLAGS_RELEASE_dynamic) $< -E $@
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_RELEASE_dynamic) $< -E $@
-$(DEBUG_OBJDIR_static)/%.o : %.cpp
- $(CXX) $(CXXFLAGS_DEBUG_static) $< -c -o $@
-$(DEBUG_OBJDIR_static)/%.o : %.c
- $(CC) $(CXXFLAGS_DEBUG_static) $< -c -o $@
+$(DEBUG_OBJDIR_static)/%.lo : %.cpp
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_DEBUG_static) $< -c -o $@
+$(DEBUG_OBJDIR_static)/%.lo : %.c
+ $(LIBTOOL) --mode=compile TAG=CC $(CC) $(CXXFLAGS_DEBUG_static) $< -c -o $@
$(DEBUG_OBJDIR_static)/%.i : %.cpp
- $(CXX) $(CXXFLAGS_DEBUG_static) $< -E $@
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_DEBUG_static) $< -E $@
-$(DEBUG_OBJDIR_dynamic)/%.o : %.cpp
- $(CXX) $(CXXFLAGS_DEBUG_dynamic) $< -c -o $@
-$(DEBUG_OBJDIR_dynamic)/%.o : %.c
- $(CC) $(CXXFLAGS_DEBUG_dynamic) $< -c -o $@
+$(DEBUG_OBJDIR_dynamic)/%.lo : %.cpp
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_DEBUG_dynamic) $< -c -o $@
+$(DEBUG_OBJDIR_dynamic)/%.lo : %.c
+ $(LIBTOOL) --mode=compile TAG=CC $(CC) $(CXXFLAGS_DEBUG_dynamic) $< -c -o $@
$(DEBUG_OBJDIR_dynamic)/%.i : %.cpp
- $(CXX) $(CXXFLAGS_DEBUG_dynamic) $< -E $@
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_DEBUG_dynamic) $< -E $@
-$(STLDEBUG_OBJDIR_static)/%.o : %.cpp
- $(CXX) $(CXXFLAGS_STLDEBUG_static) $< -c -o $@
-$(STLDEBUG_OBJDIR_static)/%.o : %.c
- $(CC) $(CXXFLAGS_STLDEBUG_static) $< -c -o $@
+$(STLDEBUG_OBJDIR_static)/%.lo : %.cpp
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_STLDEBUG_static) $< -c -o $@
+$(STLDEBUG_OBJDIR_static)/%.lo : %.c
+ $(LIBTOOL) --mode=compile TAG=CC $(CC) $(CXXFLAGS_STLDEBUG_static) $< -c -o $@
$(STLDEBUG_OBJDIR_static)/%.i : %.cpp
- $(CXX) $(CXXFLAGS_STLDEBUG_static) $< -E $@
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_STLDEBUG_static) $< -E $@
-$(STLDEBUG_OBJDIR_dynamic)/%.o : %.cpp
- $(CXX) $(CXXFLAGS_STLDEBUG_dynamic) $< -c -o $@
-$(STLDEBUG_OBJDIR_dynamic)/%.o : %.c
- $(CC) $(CXXFLAGS_STLDEBUG_dynamic) $< -c -o $@
+$(STLDEBUG_OBJDIR_dynamic)/%.lo : %.cpp
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_STLDEBUG_dynamic) $< -c -o $@
+$(STLDEBUG_OBJDIR_dynamic)/%.lo : %.c
+ $(LIBTOOL) --mode=compile TAG=CC $(CC) $(CXXFLAGS_STLDEBUG_dynamic) $< -c -o $@
$(STLDEBUG_OBJDIR_dynamic)/%.i : %.cpp
- $(CXX) $(CXXFLAGS_STLDEBUG_dynamic) $< -E $@
+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CXXFLAGS_STLDEBUG_dynamic) $< -E $@

View file

@ -1,22 +0,0 @@
$NetBSD: patch-am,v 1.1 2004/01/05 22:14:19 mrauch Exp $
--- stlport/stl/_threads.h.orig 2003-10-22 19:58:59.000000000 +0200
+++ stlport/stl/_threads.h
@@ -393,7 +393,7 @@ class _STLP_CLASS_DECLSPEC _STLP_mutex_R
# if defined(_STLP_UITHREADS)
,_id( __STATIC_CAST(thread_t,-1) )
# elif defined(_STLP_PTHREADS)
-# if !defined(__FreeBSD__) && !defined(__DECCXX)
+# if !defined(__FreeBSD__) && !defined(__DECCXX) && !defined(__NetBSD__)
,_id( __STATIC_CAST(pthread_t,-1) )
# else
,_id( __STATIC_CAST(pthread_t,0) )
@@ -434,7 +434,7 @@ class _STLP_CLASS_DECLSPEC _STLP_mutex_R
# if defined(_STLP_UITHREADS)
_id = __STATIC_CAST(thread_t,-1);
# elif defined(_STLP_PTHREADS)
-# if !defined(__FreeBSD__) && !defined(__DECCXX)
+# if !defined(__FreeBSD__) && !defined(__DECCXX) && !defined(__NetBSD__)
_id = __STATIC_CAST(pthread_t,-1);
# else
_id = __STATIC_CAST(pthread_t,0);