kill a check that time_t<=int which keeps this pkg from building

on NetBSD-current/32bit
(I don't see what this check is good for)
This commit is contained in:
drochner 2011-04-04 11:27:39 +00:00
parent 16951a5f57
commit ebfb0afbeb
2 changed files with 19 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.14 2008/03/08 11:15:03 tnn Exp $
$NetBSD: distinfo,v 1.15 2011/04/04 11:27:39 drochner Exp $
SHA1 (findutils-4.2.33.tar.gz) = 930a77cd0cbf4ee05888947cc10809f0761c84b8
RMD160 (findutils-4.2.33.tar.gz) = 51c750025487434dd785a332050fff925633c8f9
@ -6,3 +6,4 @@ Size (findutils-4.2.33.tar.gz) = 1455067 bytes
SHA1 (patch-aa) = 162de59955ded4cf6d53d012511402a672a39b7c
SHA1 (patch-ab) = 782c5c642e8e6883686c36ddc470edc3d063f0f0
SHA1 (patch-ag) = def96d47ad09cf98b0caf9f44e94df1c0fd611a2
SHA1 (patch-ah) = 213f8984aba51d500cb0d0c8ba2362918e065741

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ah,v 1.4 2011/04/04 11:27:39 drochner Exp $
test fails on NetBSD-current/32bit
--- gnulib/lib/mktime.c.orig 2007-12-08 13:47:18.000000000 +0000
+++ gnulib/lib/mktime.c
@@ -165,8 +165,10 @@ ydhms_diff (long int year1, long int yda
int year0, int yday0, int hour0, int min0, int sec0)
{
verify (C99_integer_division, -1 / 2 == 0);
+#if 0
verify (long_int_year_and_yday_are_wide_enough,
INT_MAX <= LONG_MAX / 2 || TIME_T_MAX <= UINT_MAX);
+#endif
/* Compute intervening leap days correctly even if year is negative.
Take care to avoid integer overflow here. */