databases/postgresql84-server: Fix rpath of plpgsql.so
Due to updated PKG_DEVELOPER checks, postgresql84-server started failing with the following message: ERROR: lib/postgresql/plpgsql.so: missing libintl.so.8 The plpgsql.so library had no rpath set other than what the base compiler adds by default. On DragonFly, the libintl.so library would likely have been found anyway as /usr/pkg/lib is part of the LD_CONFIG hint file search path, but that isn't a guarantee. The new patch adds ${libdir} to the plpgsql.so rpath so it passes PKG_DEVELOPER checks now.
This commit is contained in:
parent
e67360197d
commit
ec45e82173
3 changed files with 17 additions and 2 deletions
|
@ -1,6 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.14 2012/07/01 19:30:24 morr Exp $
|
||||
# $NetBSD: Makefile,v 1.15 2012/07/12 18:57:28 marino Exp $
|
||||
|
||||
PKGNAME= ${DISTNAME:C/-/84-server-/}
|
||||
PKGREVISION= 1
|
||||
COMMENT= PostgreSQL database server programs
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.18 2012/07/01 19:30:23 morr Exp $
|
||||
$NetBSD: distinfo,v 1.19 2012/07/12 18:57:27 marino Exp $
|
||||
|
||||
SHA1 (postgresql-8.4.12.tar.bz2) = 04ad9650573df7723511f57ef8cdeadce8d3855d
|
||||
RMD160 (postgresql-8.4.12.tar.bz2) = 2aa0da64dc3220497d510bd60a1abf0b68fd51ef
|
||||
|
@ -15,3 +15,4 @@ SHA1 (patch-ao) = b098032408fc951865966710554667a249db6320
|
|||
SHA1 (patch-ba) = 2cc374fdf4351a4c03ecad30fb99d2aff2cf0bdf
|
||||
SHA1 (patch-bb) = 22859530d2694cf4c347f5e4c02eff0483d536d1
|
||||
SHA1 (patch-src_pl_plperl_plperl.h) = 8d448cc8e0e0dbc4d15dad369d3ca7a796874ac2
|
||||
SHA1 (patch-src_pl_plpgsql_src_Makefile) = 1592ecb85d6ef1bd691f77b320f639b6fc822e14
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-src_pl_plpgsql_src_Makefile,v 1.1 2012/07/12 18:57:27 marino Exp $
|
||||
|
||||
--- src/pl/plpgsql/src/Makefile.orig 2012-05-31 23:11:47.000000000 +0000
|
||||
+++ src/pl/plpgsql/src/Makefile
|
||||
@@ -15,7 +15,7 @@ NAME= plpgsql
|
||||
|
||||
override CPPFLAGS := -I$(srcdir) $(CPPFLAGS)
|
||||
SHLIB_LINK = $(filter -lintl, $(LIBS))
|
||||
-rpath =
|
||||
+rpath = $(COMPILER_RPATH_FLAG)$(libdir)
|
||||
|
||||
OBJS = pl_gram.o pl_handler.o pl_comp.o pl_exec.o pl_funcs.o
|
||||
|
Loading…
Reference in a new issue