Update mysqlcc to 0.9.8.
* Suppoer mysql4 and mysql5 (but not mysql51 because of API change). * Install supporting files. Changes for 0.9.8 ----------------- * Created a conditional for mysql_shutdown to check for the existance of SHUTDOWN_DEFAULT in order to work with older mysql client libraries * Changed requirement for qpopmenu.h to qpopupmenu.h in include/CProperties.h and src/CTableTools.cpp * Added /usr/share/qt3 to the list of places to look for qt3 (fixes Debian problems) Notes for 0.9.7 ---------------- This is a development release. Henceforth, version numbers will follow the Linux kernel standard wherein odd numbered releases (such as 0.9.7) refer to development releases and even numbered releases (such as 0.9.8) refer to stable releases. Users connecting to or using MySQL 5 libraries should be using this release. Users still connecting only to MySQL 4 or lower servers should continue using version 0.9.4. This is an issue which will be addressed by version 0.9.8 and, if that version is available at the time you read this, that version should be used instead. Changes for 0.9.7 ----------------- * Changed the call to mysql_shutdown to include SHUTDOWN_DEFAULT as required by MySQL >= 5 client libraries in CMySQL.cpp * Repaired default_table assignment in CQueryWindow.cpp
This commit is contained in:
parent
6fc829d141
commit
ec7f179b06
6 changed files with 87 additions and 29 deletions
|
@ -1,11 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.27 2010/01/18 09:58:43 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.28 2010/03/05 13:50:03 taca Exp $
|
||||
#
|
||||
|
||||
DISTNAME= mysqlcc-0.9.4-src
|
||||
DISTNAME= mysqlcc-0.9.8-src
|
||||
PKGNAME= ${DISTNAME:S/-src//}
|
||||
PKGREVISION= 12
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= # ${MASTER_SITE_SOURCEFORGE:=mysqlcc/}
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=mysqlcc/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://mysqlcc.sourceforge.net/
|
||||
|
@ -15,7 +14,7 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
|||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_PKGLOCALEDIR= YES
|
||||
USE_TOOLS+= automake
|
||||
USE_TOOLS+= autoconf automake
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= \
|
||||
--with-mysql-lib=${BUILDLINK_PREFIX.mysql-client}/lib/mysql
|
||||
|
@ -25,15 +24,29 @@ CONFIGURE_ARGS+= --with-openssl-includes=${SSLBASE}/include
|
|||
CONFIGURE_ARGS+= --with-openssl-lib=${SSLBASE}/lib
|
||||
CONFIGURE_ENV+= QMAKESPEC="${QTDIR}/mkspecs/netbsd-g++"
|
||||
|
||||
MYSQL_VERSIONS_ACCEPTED= 41
|
||||
SUBST_CLASSES+= paths
|
||||
SUBST_STAGE.paths= pre-configure
|
||||
SUBST_FILES.paths= src/CApplication.cpp
|
||||
SUBST_SED.paths= -e "s|@PREFIX@|${PREFIX}|"
|
||||
SUBST_MESSAGE.paths= Fixing paths.
|
||||
|
||||
INSTALLATION_DIRS= bin
|
||||
MYSQL_VERSIONS_ACCEPTED= 50 41
|
||||
|
||||
INSTALLATION_DIRS= bin share/mysqlcc/translations
|
||||
SUPPORT_FILES= error.wav information.wav syntax.txt warning.wav
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && aclocal && autoconf
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/mysqlcc ${DESTDIR}${PREFIX}/bin
|
||||
.for f in ${SUPPORT_FILES}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DESTDIR}${PREFIX}/share/mysqlcc
|
||||
.endfor
|
||||
${INSTALL_DATA} ${WRKSRC}/translations/*.qm \
|
||||
${DESTDIR}${PREFIX}/share/mysqlcc/translations
|
||||
${INSTALL_DATA} ${WRKSRC}/translations/*.ts \
|
||||
${DESTDIR}${PREFIX}/share/mysqlcc/translations
|
||||
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../x11/qt3-tools/buildlink3.mk"
|
||||
|
|
|
@ -1,2 +1,23 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/12/21 07:58:30 martti Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2010/03/05 13:50:03 taca Exp $
|
||||
bin/mysqlcc
|
||||
share/mysqlcc/error.wav
|
||||
share/mysqlcc/information.wav
|
||||
share/mysqlcc/syntax.txt
|
||||
share/mysqlcc/translations/Deutsch.qm
|
||||
share/mysqlcc/translations/Deutsch.ts
|
||||
share/mysqlcc/translations/French.qm
|
||||
share/mysqlcc/translations/French.ts
|
||||
share/mysqlcc/translations/Italian.qm
|
||||
share/mysqlcc/translations/Italian.ts
|
||||
share/mysqlcc/translations/Polish.qm
|
||||
share/mysqlcc/translations/Polish.ts
|
||||
share/mysqlcc/translations/Russian.qm
|
||||
share/mysqlcc/translations/Russian.ts
|
||||
share/mysqlcc/translations/Simplified_Chinese.qm
|
||||
share/mysqlcc/translations/Simplified_Chinese.ts
|
||||
share/mysqlcc/translations/Spanish.qm
|
||||
share/mysqlcc/translations/Spanish.ts
|
||||
share/mysqlcc/translations/Traditional_Chinese.qm
|
||||
share/mysqlcc/translations/Traditional_Chinese.ts
|
||||
share/mysqlcc/warning.wav
|
||||
@pkgdir share/mysqlcc/plugins
|
||||
|
|
|
@ -1,9 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.3 2005/02/23 16:33:06 agc Exp $
|
||||
$NetBSD: distinfo,v 1.4 2010/03/05 13:50:03 taca Exp $
|
||||
|
||||
SHA1 (mysqlcc-0.9.4-src.tar.gz) = 690a9a8f4ad6bdf33673e92d1016b0e4b8cea030
|
||||
RMD160 (mysqlcc-0.9.4-src.tar.gz) = e2632121dcd899f0f009e8f92746974a8009f6a6
|
||||
Size (mysqlcc-0.9.4-src.tar.gz) = 747244 bytes
|
||||
SHA1 (mysqlcc-0.9.8-src.tar.gz) = d85b9fd480a2e8eef01ac62d62642c0375be9ea0
|
||||
RMD160 (mysqlcc-0.9.8-src.tar.gz) = 60fc67e21704fb135dab72652c4d736f795ddfc7
|
||||
Size (mysqlcc-0.9.8-src.tar.gz) = 1529243 bytes
|
||||
SHA1 (patch-aa) = fbb012582b1df2a34572332dc6e682377101d605
|
||||
SHA1 (patch-ab) = 9b2540c2eee1d0665a83da360d75bd488510a84b
|
||||
SHA1 (patch-ac) = 5978ef78fa5d941370ae779de259757f1e50c9a8
|
||||
SHA1 (patch-ad) = d4fce89c63c2536195fe6af5d4e187a943c7d223
|
||||
SHA1 (patch-ae) = 1ca050f7bbd65ef5911a32283fd832741942f623
|
||||
SHA1 (patch-af) = 98a5b36f295ccaf8c2f8410d56a3837b94cae091
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2004/12/01 16:00:50 xtraeme Exp $
|
||||
|
||||
--- shared/src/CMySQL.cpp.orig 2004-12-01 16:35:54.000000000 +0100
|
||||
+++ shared/src/CMySQL.cpp 2004-12-01 16:37:29.000000000 +0100
|
||||
@@ -451,7 +451,11 @@
|
||||
if (!isConnected())
|
||||
return false;
|
||||
|
||||
+#if (MYSQL_VERSION_ID >= 40103)
|
||||
+ if (mysql_shutdown(mysql, SHUTDOWN_DEFAULT) != 0)
|
||||
+#else
|
||||
if (mysql_shutdown(mysql) != 0)
|
||||
+#endif
|
||||
{
|
||||
if (emiterror)
|
||||
emitError();
|
15
databases/mysqlcc/patches/patch-ae
Normal file
15
databases/mysqlcc/patches/patch-ae
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ae,v 1.1 2010/03/05 13:50:04 taca Exp $
|
||||
|
||||
Substitute path.
|
||||
|
||||
--- src/CApplication.cpp.orig 2006-08-11 20:29:12.000000000 +0000
|
||||
+++ src/CApplication.cpp
|
||||
@@ -110,7 +110,7 @@ void CApplication::initGlobals(bool star
|
||||
#else
|
||||
//Directory where mysqlcc.exe (or mysqlcc) is.
|
||||
//QString mydir = QDir::currentDirPath() + "/";
|
||||
- QString mydir = "/usr/share/mysqlcc/"; // This needs to be done with a PREFIX define ..
|
||||
+ QString mydir = "@PREFIX@/share/mysqlcc/"; // This needs to be done with a PREFIX define ..
|
||||
#endif
|
||||
|
||||
//Translations path
|
24
databases/mysqlcc/patches/patch-af
Normal file
24
databases/mysqlcc/patches/patch-af
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-af,v 1.1 2010/03/05 13:50:04 taca Exp $
|
||||
|
||||
Use proper max value.
|
||||
|
||||
--- src/main.cpp.orig 2006-08-11 20:29:12.000000000 +0000
|
||||
+++ src/main.cpp
|
||||
@@ -95,7 +95,7 @@ static struct my_option my_long_options[
|
||||
0, 1},
|
||||
|
||||
{"select_limit", OPT_SELECT_LIMIT, "", (gptr*) &select_limit,
|
||||
- (gptr*) &select_limit, 0, GET_ULONG, REQUIRED_ARG, 1000L, 1, ~0L, 0, 1, 0},
|
||||
+ (gptr*) &select_limit, 0, GET_ULONG, REQUIRED_ARG, 1000L, 1, LONG_MAX, 0, 1, 0},
|
||||
|
||||
{"net_buffer_length", OPT_NET_BUFFER_LENGTH, "",
|
||||
(gptr*) &my_net_buffer_length, (gptr*) &my_net_buffer_length, 0, GET_ULONG,
|
||||
@@ -111,7 +111,7 @@ static struct my_option my_long_options[
|
||||
(gptr*) &opt_local_infile, 0, GET_BOOL, OPT_ARG, 0, 0, 0, 0, 0, 0},
|
||||
|
||||
{"max_join_size", OPT_MAX_JOIN_SIZE, "", (gptr*) &max_join_size,
|
||||
- (gptr*) &max_join_size, 0, GET_ULONG, REQUIRED_ARG, 1000000L, 1, ~0L, 0, 1,
|
||||
+ (gptr*) &max_join_size, 0, GET_ULONG, REQUIRED_ARG, 1000000L, 1, LONG_MAX, 0, 1,
|
||||
0},
|
||||
|
||||
{ 0, 0, 0, 0, 0, 0, GET_NO_ARG, NO_ARG, 0, 0, 0, 0, 0, 0}
|
Loading…
Reference in a new issue