Convert to use glib2 instead of glib1. Bump PKGREVISION.
This commit is contained in:
parent
538ad7276b
commit
ecb3f5088a
3 changed files with 22 additions and 4 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.25 2009/01/19 10:20:03 sketch Exp $
|
||||
# $NetBSD: Makefile,v 1.26 2009/04/29 12:47:23 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= irssi-icb-0.14
|
||||
PKGREVISION= 12
|
||||
PKGREVISION= 13
|
||||
CATEGORIES= chat
|
||||
MASTER_SITES= http://www.irssi.org/files/plugins/icb/
|
||||
DISTFILES= ${DISTNAME}.tar.gz ${IRSSI_DISTFILE}
|
||||
|
@ -22,9 +22,12 @@ DEPENDS+= irssi>=${IRSSI_VERSION}:../../chat/irssi
|
|||
GNU_CONFIGURE= yes
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
SHLIBTOOL_OVERRIDE= # empty
|
||||
|
||||
CONFIGURE_ARGS+= --with-irssi=${WRKDIR}/${IRSSI_DISTNAME}
|
||||
CONFIGURE_ARGS+= --with-glib-prefix=${BUILDLINK_PREFIX.glib2}
|
||||
CONFIGURE_ARGS+= --disable-glibtest
|
||||
|
||||
INSTALLATION_DIRS+= share/doc/irssi
|
||||
|
||||
|
@ -37,5 +40,5 @@ post-extract:
|
|||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DESTDIR}${PREFIX}/share/doc/irssi/README.icb
|
||||
|
||||
.include "../../devel/glib/buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.11 2009/01/19 10:20:03 sketch Exp $
|
||||
$NetBSD: distinfo,v 1.12 2009/04/29 12:47:23 wiz Exp $
|
||||
|
||||
SHA1 (irssi-0.8.12.tar.bz2) = 00ecca04766c51feef057b2327f67166be473fa3
|
||||
RMD160 (irssi-0.8.12.tar.bz2) = 0588e6c2df0425c4f36bd84c1621d9ad170b6a81
|
||||
|
@ -10,3 +10,4 @@ SHA1 (patch-aa) = 8249c9ae3e5ae8b6110db030ee4280aa53ca1192
|
|||
SHA1 (patch-ab) = c270c35891164c9e42696e2ffc84d1e7ffaaaa2a
|
||||
SHA1 (patch-ac) = 27f9148f68e2fb612dac51ac5d9401338e926d77
|
||||
SHA1 (patch-ad) = e07327f473c253c341d83fe9b3ce1f34667b33f2
|
||||
SHA1 (patch-ae) = 0a1c916e44d70d108ba1d3b229ff1d3d72365622
|
||||
|
|
14
chat/irssi-icb/patches/patch-ae
Normal file
14
chat/irssi-icb/patches/patch-ae
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ae,v 1.1 2009/04/29 12:47:23 wiz Exp $
|
||||
|
||||
--- configure.orig 2002-11-24 13:17:37.000000000 +0000
|
||||
+++ configure
|
||||
@@ -5892,6 +5892,9 @@ rm -f conftest*
|
||||
rm -f conf.glibtest
|
||||
|
||||
|
||||
+GLIB_CFLAGS="`pkg-config --cflags glib-2.0`"
|
||||
+GLIB_LIBS="`pkg-config --libs glib-2.0`"
|
||||
+
|
||||
# gcc specific options
|
||||
if test "x$ac_cv_prog_gcc" = "xyes"; then
|
||||
CFLAGS="$CFLAGS -Wall"
|
Loading…
Reference in a new issue