Stop installing library again.
Split parts of Makefile into Makefile.common for upcoming libunrar. Remove unnecessary patch (as discussed with upstream).
This commit is contained in:
parent
759f536d2c
commit
ecb8a115ce
5 changed files with 42 additions and 55 deletions
|
@ -1,43 +1,12 @@
|
|||
# $NetBSD: Makefile,v 1.71 2013/08/30 10:16:57 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.72 2013/09/01 08:28:08 wiz Exp $
|
||||
|
||||
DISTNAME= unrarsrc-5.0.7
|
||||
PKGNAME= ${DISTNAME:S/src//}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= archivers
|
||||
MASTER_SITES= http://www.rarlab.com/rar/
|
||||
.include "Makefile.common"
|
||||
PKGREVISION= 2
|
||||
|
||||
MAINTAINER= wiz@NetBSD.org
|
||||
HOMEPAGE= http://www.rarlab.com/
|
||||
COMMENT= Extract, view & test RAR archives
|
||||
LICENSE= unrar-license
|
||||
# From private mail addressed to pkgsrc maintainers:
|
||||
#
|
||||
# Date: Wed, 10 Sep 2008 18:27:35 +0600
|
||||
# From: Eugene Roshal <roshal@rarlab.com>
|
||||
# You can redistribute either original or modified binaries or sources.
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
NO_CONFIGURE= YES
|
||||
USE_LANGUAGES= c++
|
||||
# XXX: makefile has DOS line endings
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
MAKE_FILE= makefile
|
||||
BUILD_TARGET= all lib
|
||||
MAKEFLAGS+= CXX=${CXX:Q} CXXFLAGS=${CXXFLAGS:Q} LDFLAGS=${LDFLAGS:Q}
|
||||
# usually set in Makefile, but overridden by line above
|
||||
LDFLAGS+= -pthread
|
||||
CXXFLAGS+= -fPIC
|
||||
|
||||
WRKSRC= ${WRKDIR}/unrar
|
||||
|
||||
INSTALLATION_DIRS= bin include lib share/doc/unrar
|
||||
INSTALLATION_DIRS= bin share/doc/unrar
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/unrar ${DESTDIR}${PREFIX}/bin
|
||||
${INSTALL_DATA} ${WRKSRC}/dll.hpp ${DESTDIR}${PREFIX}/include
|
||||
${INSTALL_DATA} ${WRKSRC}/libunrar.so ${DESTDIR}${PREFIX}/lib
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} readme.txt license.txt \
|
||||
${DESTDIR}${PREFIX}/share/doc/unrar
|
||||
|
||||
|
|
36
archivers/unrar/Makefile.common
Normal file
36
archivers/unrar/Makefile.common
Normal file
|
@ -0,0 +1,36 @@
|
|||
# $NetBSD: Makefile.common,v 1.1 2013/09/01 08:28:08 wiz Exp $
|
||||
#
|
||||
# used by archivers/libunrar/Makefile
|
||||
# used by archivers/unrar/Makefile
|
||||
|
||||
DISTNAME= unrarsrc-5.0.7
|
||||
PKGNAME= ${DISTNAME:S/src//}
|
||||
CATEGORIES= archivers
|
||||
MASTER_SITES= http://www.rarlab.com/rar/
|
||||
|
||||
MAINTAINER= wiz@NetBSD.org
|
||||
HOMEPAGE= http://www.rarlab.com/
|
||||
COMMENT= Extract, view & test RAR archives
|
||||
LICENSE= unrar-license
|
||||
# From private mail addressed to pkgsrc maintainers:
|
||||
#
|
||||
# Date: Wed, 10 Sep 2008 18:27:35 +0600
|
||||
# From: Eugene Roshal <roshal@rarlab.com>
|
||||
# You can redistribute either original or modified binaries or sources.
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
NO_CONFIGURE= YES
|
||||
USE_LANGUAGES= c++
|
||||
# XXX: makefile has DOS line endings
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
MAKE_FILE= makefile
|
||||
MAKEFLAGS+= CXX=${CXX:Q} CXXFLAGS=${CXXFLAGS:Q} LDFLAGS=${LDFLAGS:Q}
|
||||
# usually set in Makefile, but overridden by line above
|
||||
LDFLAGS+= -pthread
|
||||
CXXFLAGS+= -fPIC
|
||||
|
||||
WRKSRC= ${WRKDIR}/unrar
|
||||
|
||||
DISTINFO_FILE= ${.CURDIR}/../../archivers/unrar/distinfo
|
|
@ -1,6 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2013/08/30 10:16:57 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2013/09/01 08:28:08 wiz Exp $
|
||||
bin/unrar
|
||||
include/dll.hpp
|
||||
lib/libunrar.so
|
||||
share/doc/unrar/license.txt
|
||||
share/doc/unrar/readme.txt
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.50 2013/08/30 10:16:57 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.51 2013/09/01 08:28:08 wiz Exp $
|
||||
|
||||
SHA1 (unrarsrc-5.0.7.tar.gz) = 7d1cd96d29695e90df4aaef426e7068b241e2528
|
||||
RMD160 (unrarsrc-5.0.7.tar.gz) = fd3a3ba33e1250e0b9680138a22241a26ee5722e
|
||||
Size (unrarsrc-5.0.7.tar.gz) = 208034 bytes
|
||||
SHA1 (patch-dll.hpp) = 2572dd8023790b887c5e06a5aeb6f6ea3756499c
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-dll.hpp,v 1.1 2013/08/30 10:16:58 wiz Exp $
|
||||
|
||||
NetBSD doesn't define _UNIX.
|
||||
|
||||
--- dll.hpp.orig 2013-08-30 09:33:40.000000000 +0000
|
||||
+++ dll.hpp
|
||||
@@ -36,7 +36,7 @@
|
||||
#define RAR_HASH_BLAKE2 2
|
||||
|
||||
|
||||
-#ifdef _UNIX
|
||||
+#if defined(_UNIX) || defined(__NetBSD__)
|
||||
#define CALLBACK
|
||||
#define PASCAL
|
||||
#define LONG long
|
Loading…
Reference in a new issue