Added devel/ocaml-core_kernel, standard library overlay (kernel)
This commit is contained in:
parent
2ec99d04ae
commit
ecfe1e4aae
14 changed files with 1508 additions and 0 deletions
4
devel/ocaml-core_kernel/DESCR
Normal file
4
devel/ocaml-core_kernel/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Core is an industrial-strength alternative to the OCaml standard library.
|
||||
It was developed by Jane Street, which is the largest industrial user of OCaml.
|
||||
|
||||
Core_kernel is the system-independent part of Core.
|
39
devel/ocaml-core_kernel/Makefile
Normal file
39
devel/ocaml-core_kernel/Makefile
Normal file
|
@ -0,0 +1,39 @@
|
|||
# $NetBSD: Makefile,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
GITHUB_PROJECT= core_kernel
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
DISTNAME= ${GITHUB_PROJECT}-0.12.0
|
||||
PKGNAME= ocaml-${DISTNAME}
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=janestreet/}
|
||||
|
||||
MAINTAINER= jaapb@NetBSD.org
|
||||
HOMEPAGE= https://github.com/janestreet/core_kernel/
|
||||
COMMENT= OCaml standard library overlay (kernel)
|
||||
LICENSE= mit
|
||||
|
||||
USE_LANGUAGES= # none
|
||||
OCAML_USE_DUNE= yes
|
||||
|
||||
.include "../../mk/ocaml.mk"
|
||||
.include "../../devel/ocaml-base/buildlink3.mk"
|
||||
.include "../../devel/ocaml-base_bigstring/buildlink3.mk"
|
||||
.include "../../devel/ocaml-base_quickcheck/buildlink3.mk"
|
||||
.include "../../devel/ocaml-bin_prot/buildlink3.mk"
|
||||
.include "../../devel/ocaml-fieldslib/buildlink3.mk"
|
||||
.include "../../devel/ocaml-jane-street-headers/buildlink3.mk"
|
||||
.include "../../devel/ocaml-jst-config/buildlink3.mk"
|
||||
.include "../../devel/ocaml-ppx_assert/buildlink3.mk"
|
||||
.include "../../devel/ocaml-ppx_base/buildlink3.mk"
|
||||
.include "../../devel/ocaml-ppx_hash/buildlink3.mk"
|
||||
.include "../../devel/ocaml-ppx_inline_test/buildlink3.mk"
|
||||
.include "../../devel/ocaml-ppx_jane/buildlink3.mk"
|
||||
.include "../../devel/ocaml-ppx_sexp_conv/buildlink3.mk"
|
||||
.include "../../devel/ocaml-ppx_sexp_message/buildlink3.mk"
|
||||
.include "../../devel/ocaml-sexplib/buildlink3.mk"
|
||||
.include "../../devel/ocaml-splittable_random/buildlink3.mk"
|
||||
.include "../../devel/ocaml-stdio/buildlink3.mk"
|
||||
.include "../../time/ocaml-time_now/buildlink3.mk"
|
||||
.include "../../devel/ocaml-typerep/buildlink3.mk"
|
||||
.include "../../devel/ocaml-variantslib/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
1336
devel/ocaml-core_kernel/PLIST
Normal file
1336
devel/ocaml-core_kernel/PLIST
Normal file
File diff suppressed because it is too large
Load diff
13
devel/ocaml-core_kernel/buildlink3.mk
Normal file
13
devel/ocaml-core_kernel/buildlink3.mk
Normal file
|
@ -0,0 +1,13 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
BUILDLINK_TREE+= ocaml-core_kernel
|
||||
|
||||
.if !defined(OCAML_CORE_KERNEL_BUILDLINK3_MK)
|
||||
OCAML_CORE_KERNEL_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.ocaml-core_kernel+= ocaml-core_kernel>=0.12.0
|
||||
BUILDLINK_PKGSRCDIR.ocaml-core_kernel?= ../../devel/ocaml-core_kernel
|
||||
|
||||
.endif # OCAML_CORE_KERNEL_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -ocaml-core_kernel
|
15
devel/ocaml-core_kernel/distinfo
Normal file
15
devel/ocaml-core_kernel/distinfo
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: distinfo,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
SHA1 (core_kernel-0.12.0.tar.gz) = 0a59c7bbeebc989cdf27a008dedc4c36e3bc8e20
|
||||
RMD160 (core_kernel-0.12.0.tar.gz) = 6df1da75542c54ed23e8ad395789cb6a856b80ab
|
||||
SHA512 (core_kernel-0.12.0.tar.gz) = 5ebc2920fa414ab18d3809293795269d8aab3014ed3c352459fae417f483d0da7f1b6f345c352de9fb32e4b73463675b0deddeaa75eea4e5f031ead7531f3475
|
||||
Size (core_kernel-0.12.0.tar.gz) = 610557 bytes
|
||||
SHA1 (patch-balanced__reducer_src_dune) = 5065641884813a984f85f67594fbf60ea5faeeaa
|
||||
SHA1 (patch-binary__packing_src_dune) = 2b7fb6be2bac5ba28043cb338c970b8fa1983084
|
||||
SHA1 (patch-int__set_src_dune) = a96d6689a50ff2aef5079264287b6f58ab88da78
|
||||
SHA1 (patch-moption_src_dune) = 3c860d1cf58417121a71e029dcab44a396b2c713
|
||||
SHA1 (patch-src_dune) = 74e8df33879d6820ae9c88757fd9f7afa122c056
|
||||
SHA1 (patch-thread__pool__cpu__affinity_src_dune) = f914f6b933ef512e35c25777e73da239084986ca
|
||||
SHA1 (patch-thread__safe__queue_src_dune) = 69faa705502a7e21695e33acbfebf498d84f1e15
|
||||
SHA1 (patch-unpack__buffer_src_dune) = 5c0f6a76952c8c7f6b995a635212f446b55d5931
|
||||
SHA1 (patch-uopt_src_dune) = 51752b2d0fecdd6d19b253187066cc17e91fde29
|
|
@ -0,0 +1,10 @@
|
|||
$NetBSD: patch-balanced__reducer_src_dune,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
Remove unknown argument
|
||||
--- balanced_reducer/src/dune.orig 2019-02-19 14:45:16.000000000 +0000
|
||||
+++ balanced_reducer/src/dune
|
||||
@@ -1,2 +1,2 @@
|
||||
(library (name balanced_reducer) (public_name core_kernel.balanced_reducer)
|
||||
- (libraries base) (preprocess (pps ppx_jane -check-doc-comments)))
|
||||
\ No newline at end of file
|
||||
+ (libraries base) (preprocess (pps ppx_jane)))
|
|
@ -0,0 +1,10 @@
|
|||
$NetBSD: patch-binary__packing_src_dune,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
Remove unknown argument
|
||||
--- binary_packing/src/dune.orig 2019-02-19 14:45:16.000000000 +0000
|
||||
+++ binary_packing/src/dune
|
||||
@@ -1,2 +1,2 @@
|
||||
(library (name binary_packing) (public_name core_kernel.binary_packing)
|
||||
- (preprocess (pps ppx_jane -check-doc-comments)) (libraries core_kernel))
|
||||
\ No newline at end of file
|
||||
+ (preprocess (pps ppx_jane)) (libraries core_kernel))
|
10
devel/ocaml-core_kernel/patches/patch-int__set_src_dune
Normal file
10
devel/ocaml-core_kernel/patches/patch-int__set_src_dune
Normal file
|
@ -0,0 +1,10 @@
|
|||
$NetBSD: patch-int__set_src_dune,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
Remove unknown argument
|
||||
--- int_set/src/dune.orig 2019-02-19 14:45:16.000000000 +0000
|
||||
+++ int_set/src/dune
|
||||
@@ -1,2 +1,2 @@
|
||||
(library (name int_set) (public_name core_kernel.int_set)
|
||||
- (preprocess (pps ppx_jane -check-doc-comments)) (libraries core_kernel))
|
||||
\ No newline at end of file
|
||||
+ (preprocess (pps ppx_jane)) (libraries core_kernel))
|
10
devel/ocaml-core_kernel/patches/patch-moption_src_dune
Normal file
10
devel/ocaml-core_kernel/patches/patch-moption_src_dune
Normal file
|
@ -0,0 +1,10 @@
|
|||
$NetBSD: patch-moption_src_dune,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
Remove unknown argument
|
||||
--- moption/src/dune.orig 2019-02-19 14:45:16.000000000 +0000
|
||||
+++ moption/src/dune
|
||||
@@ -1,2 +1,2 @@
|
||||
(library (name moption) (public_name core_kernel.moption)
|
||||
- (preprocess (pps ppx_jane -check-doc-comments)) (libraries core_kernel))
|
||||
\ No newline at end of file
|
||||
+ (preprocess (pps ppx_jane)) (libraries core_kernel))
|
18
devel/ocaml-core_kernel/patches/patch-src_dune
Normal file
18
devel/ocaml-core_kernel/patches/patch-src_dune
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-src_dune,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
Remove unknown argument
|
||||
--- src/dune.orig 2019-02-19 14:45:16.000000000 +0000
|
||||
+++ src/dune
|
||||
@@ -11,9 +11,9 @@
|
||||
(c_library_flags (:include rt-flags))
|
||||
(c_names bigstring_stubs md5_stubs array_stubs gc_stubs time_ns_stubs
|
||||
version_util_fallback_stubs heap_block_stubs)
|
||||
- (preprocess (pps ppx_jane -check-doc-comments)) (preprocessor_deps config.h)
|
||||
+ (preprocess (pps ppx_jane)) (preprocessor_deps config.h)
|
||||
(js_of_ocaml (javascript_files strftime.js runtime.js)))
|
||||
|
||||
(rule (targets explicit_dependencies.ml explicit_dependencies.mli)
|
||||
(deps %{workspace_root}/bin/gen-explicit-dependencies.sh)
|
||||
- (action (bash "%{deps} jane_street_headers")))
|
||||
\ No newline at end of file
|
||||
+ (action (bash "%{deps} jane_street_headers")))
|
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-thread__pool__cpu__affinity_src_dune,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
Remove unknown argument
|
||||
--- thread_pool_cpu_affinity/src/dune.orig 2019-02-19 14:45:16.000000000 +0000
|
||||
+++ thread_pool_cpu_affinity/src/dune
|
||||
@@ -1,3 +1,3 @@
|
||||
(library (name thread_pool_cpu_affinity)
|
||||
(public_name core_kernel.thread_pool_cpu_affinity) (libraries core_kernel)
|
||||
- (preprocess (pps ppx_jane -annotated-ignores -check-doc-comments)))
|
||||
\ No newline at end of file
|
||||
+ (preprocess (pps ppx_jane)))
|
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-thread__safe__queue_src_dune,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
Remove unknown argument
|
||||
--- thread_safe_queue/src/dune.orig 2019-02-19 14:45:16.000000000 +0000
|
||||
+++ thread_safe_queue/src/dune
|
||||
@@ -1,3 +1,3 @@
|
||||
(library (name thread_safe_queue) (public_name core_kernel.thread_safe_queue)
|
||||
- (preprocess (pps ppx_jane -check-doc-comments))
|
||||
- (libraries core_kernel uopt))
|
||||
\ No newline at end of file
|
||||
+ (preprocess (pps ppx_jane))
|
||||
+ (libraries core_kernel uopt))
|
|
@ -0,0 +1,10 @@
|
|||
$NetBSD: patch-unpack__buffer_src_dune,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
Remove unknown argument
|
||||
--- unpack_buffer/src/dune.orig 2019-02-19 14:45:16.000000000 +0000
|
||||
+++ unpack_buffer/src/dune
|
||||
@@ -1,2 +1,2 @@
|
||||
(library (name unpack_buffer) (public_name core_kernel.unpack_buffer)
|
||||
- (preprocess (pps ppx_jane -check-doc-comments)) (libraries core_kernel))
|
||||
\ No newline at end of file
|
||||
+ (preprocess (pps ppx_jane)) (libraries core_kernel))
|
10
devel/ocaml-core_kernel/patches/patch-uopt_src_dune
Normal file
10
devel/ocaml-core_kernel/patches/patch-uopt_src_dune
Normal file
|
@ -0,0 +1,10 @@
|
|||
$NetBSD: patch-uopt_src_dune,v 1.1 2019/03/19 10:07:47 jaapb Exp $
|
||||
|
||||
Remove unknown argument
|
||||
--- uopt/src/dune.orig 2019-02-19 14:45:16.000000000 +0000
|
||||
+++ uopt/src/dune
|
||||
@@ -1,2 +1,2 @@
|
||||
(library (name uopt) (public_name core_kernel.uopt) (libraries core_kernel)
|
||||
- (preprocess (pps ppx_jane -check-doc-comments)))
|
||||
\ No newline at end of file
|
||||
+ (preprocess (pps ppx_jane)))
|
Loading…
Reference in a new issue