Update to tela-1.32.
BUG FIXES - t-functions using ellipsis argument (...) crashed Tela (this was due to the "deep" copy object array feature introduced in previous version 1.31, cure was to introduce another internal type KShallowObjectArray which is now used in Tprg::execute() in prg.C) - memory leak in object arrays (object.C:Tobject::setsize, deep clear was missing) (also this bug existed only in version 1.31, not before, because object array semantics was changed from shallow copy to deep copy in 1.31). USER-VISIBLE CHANGES - new diag() function contributed by Ch.Spiel which allows a second input argument specifying the super- or sub-diagonal (the default zero meaning the main diagonal), this function is compatible with Matlab's and also compatible with the old diag() function (std.ct) - added global symbol NaN if compiler supports NaN's (ieee754.h header is present and working) (tela.C)
This commit is contained in:
parent
06a12e13b1
commit
ed13d53eb4
3 changed files with 29 additions and 16 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.6 2001/04/14 21:43:57 jtb Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2001/04/24 23:43:02 jtb Exp $
|
||||
|
||||
DISTNAME= tela-1.31
|
||||
DISTNAME= tela-1.32
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ftp://ftp.funet.fi/pub/sci/math/tela/ \
|
||||
ftp://sumppu.fmi.fi/pub/tela/
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/19 08:45:45 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/04/24 23:43:03 jtb Exp $
|
||||
|
||||
SHA1 (tela-1.31.tar.gz) = f47b2d3b8f1b370e9d063a39f6ebb03cedc70782
|
||||
Size (tela-1.31.tar.gz) = 1837898 bytes
|
||||
SHA1 (tela-1.32.tar.gz) = faa3aa1197c96f1d6e0ee09dde10a7b8d17f84f4
|
||||
Size (tela-1.32.tar.gz) = 1845073 bytes
|
||||
SHA1 (patch-aa) = 2a2033c3d3bddbfcfaebb189223fc320fb82c4cc
|
||||
SHA1 (patch-ab) = dc651797e20749605fea7c2eb78054a9be6752a2
|
||||
SHA1 (patch-ac) = abc92a9e69daa5744fb046608943aecfec34d633
|
||||
SHA1 (patch-ac) = 0388b60f99712e33de82663560c7044c5af92c55
|
||||
SHA1 (patch-ad) = 1276a6d1ef5876376a4dcd9a1dacfd7e09f106fd
|
||||
SHA1 (patch-ae) = ad36a0b3d6d9e4e48e3e266ea9d88c6d3e5d918d
|
||||
SHA1 (patch-af) = a126910bd70b2f1fbde2f4609cace499795d0e0c
|
||||
|
|
|
@ -1,23 +1,36 @@
|
|||
$NetBSD: patch-ac,v 1.2 2001/04/09 03:55:20 jtb Exp $
|
||||
$NetBSD: patch-ac,v 1.3 2001/04/24 23:43:03 jtb Exp $
|
||||
|
||||
--- tela.C.orig Thu Mar 8 07:20:04 2001
|
||||
--- tela.C.orig Tue Mar 20 14:41:02 2001
|
||||
+++ tela.C
|
||||
@@ -14,7 +14,7 @@
|
||||
@@ -13,7 +13,7 @@
|
||||
#include "d.y.h"
|
||||
#include "d.l.h"
|
||||
#include "version.H"
|
||||
#include <signal.h>
|
||||
-#include <values.h>
|
||||
+//#include <values.h>
|
||||
//#include <unistd.h>
|
||||
extern "C" {
|
||||
#include "readline/chardefs.h"
|
||||
@@ -30,9 +30,7 @@
|
||||
// On some Linux versions the libf77.so refers to external symbol MAIN__ which is supposed
|
||||
// to be the Fortran main program. Since we do not have a Fortran main program here, we define it here.
|
||||
// Hope it doesn't conflict with anything else.
|
||||
#if HAVE_IEEE754_H == 1
|
||||
# include <ieee754.h>
|
||||
@@ -45,9 +45,9 @@
|
||||
// MAIN__ which is supposed to be the Fortran main program. Since we
|
||||
// do not have a Fortran main program here, we define it here. Hope
|
||||
// it doesn't conflict with anything else.
|
||||
-#ifdef LINUX
|
||||
+// #ifdef LINUX
|
||||
int MAIN__;
|
||||
-#endif
|
||||
+// #endif
|
||||
}
|
||||
|
||||
char *VersionString = VERSION;
|
||||
@@ -229,8 +229,8 @@
|
||||
return 0.0;
|
||||
}
|
||||
#else
|
||||
- real zero = 0.0;
|
||||
- real result = zero/zero;
|
||||
+ Treal zero = 0.0;
|
||||
+ Treal result = zero/zero;
|
||||
return result;
|
||||
#endif
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue