Update to 3.7.1. Changes build procedure substantially.
Bug fixes, plus: Changes from 3.7 to 3.7.1 Released November 19, 2005 New Features: * Add tool to align two or more FITS images and create motion movies. * Add Control-m keyboard shortcut to add any view to the Movie loop. * Upgrade to higher resolution Earth image. * Put user annotations in a scrolled list to accommodate lengthy collections. * Add Moonrise and Moonset to collection of Step size controls. * Image gallery lookups now search against all names of data base objects. Changes from 3.6.4 to 3.7 Released August 1, 2005 New Features: * Data o Includes Hubble GSC 2.2.0.1 catalog, 450 million stars complete to M18.5. o New and updated catalogs: Messier, IC, NGC, COVBS, SKY2000, HYPERLEDA, Supernova, WDSC, Open clusters, Henry-Draper, Pleiades and asteroids. o YBS replaced with Sky 2000 to magnitude 6.5. o Can now display Gallery image directly from Data Index. * Earth View o Display satellite orbits in space. o Zoom in to see better geography, or out to see high orbits. o Quick-set button to set equator rotation. o Display of surface footprint is now optional. o Expanded range mouse panning allows continuous rotation. * Sky View o Save and restore sets of eyepiece definitions. o Save and restore sets of eyepiece Sky positions. o Constellation figure definitions now stored in editable files. o WCS solver invoked automatically if header has seed but no solution. o Shortcut button to set display aspect ratio to match image. o FITS file blinking via new Movie frame function. * User Annotation o Anchor locations are now based on the view's world coordinates. o Sets of annotations may be saved and loaded from files. * Other o Collect any number of View, NAAG or Plot frames into a movie, save as set of PNG files. o Many tweaks for improved INDI support, including display FITS BLOBs.
This commit is contained in:
parent
35efbd75c5
commit
ed3f6f344f
4 changed files with 39 additions and 32 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.37 2006/05/10 14:42:52 gdt Exp $
|
||||
# $NetBSD: Makefile,v 1.38 2006/05/10 16:45:35 gdt Exp $
|
||||
|
||||
DISTNAME= xephem-3.6.4
|
||||
PKGREVISION= 2
|
||||
DISTNAME= xephem-3.7.1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.clearskyinstitute.com/xephem/ \
|
||||
ftp://iphcip1.physik.uni-mainz.de/pub/xephem/
|
||||
|
@ -18,22 +17,17 @@ NO_BIN_ON_FTP= ${RESTRICTED}
|
|||
NO_BIN_ON_CDROM= ${RESTRICTED}
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/GUI/xephem
|
||||
USE_IMAKE= yes
|
||||
USE_TOOLS+= perl:run
|
||||
USE_TOOLS+= gmake perl:run
|
||||
|
||||
LIBSRC1= ${WRKDIR}/${DISTNAME}/libastro
|
||||
LIBSRC2= ${WRKDIR}/${DISTNAME}/libip
|
||||
LIBSRC3= ${WRKDIR}/${DISTNAME}/liblilxml
|
||||
LIBSRC4= ${WRKDIR}/${DISTNAME}/libjpegd
|
||||
BUILD_TARGET= # empty
|
||||
BUILD_DIRS= ${LIBSRC1} ${LIBSRC2} ${LIBSRC3} ${LIBSRC4} ${WRKSRC}
|
||||
INSTALL_DIRS= ${WRKSRC}
|
||||
BUILD_ENV+= X11_LDFLAGS=${X11_LDFLAGS:Q}
|
||||
|
||||
.if ${MACHINE_ARCH} == "arm" || ${MACHINE_ARCH} == "arm32"
|
||||
GCC_REQD+= 2.95.3
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/xephem ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/xephem.man ${PREFIX}/${PKGMANDIR}/man1/xephem.1
|
||||
${SED} s,@PREFIX@,${PREFIX}, ${FILESDIR}/XEphem.ad > ${WRKDIR}/XEphem
|
||||
${INSTALL_DATA} ${WRKDIR}/XEphem ${PREFIX}/lib/X11/app-defaults
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/xephem/tools
|
||||
|
@ -42,4 +36,5 @@ post-install:
|
|||
${CHOWN} -R ${SHAREOWN} ${PREFIX}/share/xephem
|
||||
|
||||
.include "../../mk/motif.buildlink3.mk"
|
||||
.include "../../mk/x11.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,12 +1,16 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2006/02/16 15:15:18 yyamano Exp $
|
||||
@comment $NetBSD: PLIST,v 1.7 2006/05/10 16:45:35 gdt Exp $
|
||||
bin/xephem
|
||||
lib/X11/app-defaults/XEphem
|
||||
${IMAKE_MAN_DIR}/xephem.${IMAKE_MAN_SUFFIX}
|
||||
man/man1/xephem.1
|
||||
share/xephem/auxil/HAReyfigs.csf
|
||||
share/xephem/auxil/README
|
||||
share/xephem/auxil/SOHO_512_20030809_0719_eit_304.gif
|
||||
share/xephem/auxil/analemma.plt
|
||||
share/xephem/auxil/annotation.ano
|
||||
share/xephem/auxil/astorb2edb.pl
|
||||
share/xephem/auxil/classicfigs.csf
|
||||
share/xephem/auxil/dearth.gif
|
||||
share/xephem/auxil/eyepieces.epl
|
||||
share/xephem/auxil/eyepieces.eyp
|
||||
share/xephem/auxil/favorites.fav
|
||||
share/xephem/auxil/jupiter.9910
|
||||
|
@ -32,7 +36,7 @@ share/xephem/auxil/wmm.cof
|
|||
share/xephem/auxil/xephem_sites
|
||||
share/xephem/auxil/xephem_skyhist
|
||||
share/xephem/catalogs/Messier.edb
|
||||
share/xephem/catalogs/YBS.edb
|
||||
share/xephem/catalogs/SKY2k65.edb
|
||||
share/xephem/fifos/Makefile
|
||||
share/xephem/fifos/README
|
||||
share/xephem/fits/Abell426.fts
|
||||
|
@ -68,6 +72,7 @@ share/xephem/help/png/external-input.png
|
|||
share/xephem/help/png/favorites.png
|
||||
share/xephem/help/png/fieldstars.png
|
||||
share/xephem/help/png/gallery.png
|
||||
share/xephem/help/png/imreg.png
|
||||
share/xephem/help/png/indiconfig.png
|
||||
share/xephem/help/png/indicontrol.png
|
||||
share/xephem/help/png/internet-update.png
|
||||
|
@ -88,6 +93,7 @@ share/xephem/help/png/mars-more-info.png
|
|||
share/xephem/help/png/mars.png
|
||||
share/xephem/help/png/moon-more-info.png
|
||||
share/xephem/help/png/moon.png
|
||||
share/xephem/help/png/movie.png
|
||||
share/xephem/help/png/naag.png
|
||||
share/xephem/help/png/network-setup.png
|
||||
share/xephem/help/png/obslog.png
|
||||
|
@ -131,12 +137,14 @@ share/xephem/help/png/sky-view-where-tb.png
|
|||
share/xephem/help/png/sky-view.png
|
||||
share/xephem/help/png/solsys.png
|
||||
share/xephem/help/png/solver.png
|
||||
share/xephem/help/png/stepsize.png
|
||||
share/xephem/help/png/sun-view.png
|
||||
share/xephem/help/png/syslog.png
|
||||
share/xephem/help/png/trails.png
|
||||
share/xephem/help/png/uranus-more-info.png
|
||||
share/xephem/help/png/uranus.png
|
||||
share/xephem/help/png/valid-html401.png
|
||||
share/xephem/help/png/wcssolver.png
|
||||
share/xephem/help/xephem.html
|
||||
share/xephem/lo/lodb.xml
|
||||
@exec ${MKDIR} %D/share/xephem/tools
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.7 2005/05/20 13:17:11 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.8 2006/05/10 16:45:35 gdt Exp $
|
||||
|
||||
SHA1 (xephem-3.6.4.tar.gz) = c0d262b5c95b91cab841e5b32dafa36ed9834e1b
|
||||
RMD160 (xephem-3.6.4.tar.gz) = 2c784e7e10a2faac1f53e157cd3216be77c2f31d
|
||||
Size (xephem-3.6.4.tar.gz) = 10022695 bytes
|
||||
SHA1 (patch-aa) = 735179176b04d7a21f410714e9a1c596ed949274
|
||||
SHA1 (xephem-3.7.1.tar.gz) = e6567b358c3b00f696e71eace20f4f5226bab011
|
||||
RMD160 (xephem-3.7.1.tar.gz) = 7debeb25b9e76b3e796ae5349d84d6b36ae04e54
|
||||
Size (xephem-3.7.1.tar.gz) = 12986819 bytes
|
||||
SHA1 (patch-aa) = ea4d59efc966e41487357cd511b3e737dbd971d3
|
||||
|
|
|
@ -1,13 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.5 2005/02/25 17:45:19 drochner Exp $
|
||||
$NetBSD: patch-aa,v 1.6 2006/05/10 16:45:35 gdt Exp $
|
||||
|
||||
--- Imakefile.orig 2004-04-18 09:00:57.000000000 +0200
|
||||
+++ Imakefile
|
||||
@@ -78,7 +78,7 @@ OBJS = \
|
||||
SRCS = $(OBJS:.o=.c)
|
||||
--- Makefile.orig 2005-11-18 08:43:09.000000000 -0500
|
||||
+++ Makefile
|
||||
@@ -32,9 +32,9 @@ endif
|
||||
# for linux and Apple OS X
|
||||
CC = gcc
|
||||
CLDFLAGS = -g
|
||||
-CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I$(MOTIFI) -I/usr/X11R6/include
|
||||
-LDFLAGS = $(LIBLNK) $(CLDFLAGS) -L$(MOTIFL) -L/usr/X11R6/lib
|
||||
-XLIBS = $(MOTIFL)/libXm.a -lXp -lXt -lXext -lSM -lICE -lXmu -lX11
|
||||
+CFLAGS = $(LIBINC) $(CLDFLAGS) -O2 -Wall -I/usr/X11R6/include
|
||||
+LDFLAGS = $(LIBLNK) $(CLDFLAGS) $(X11_LDFLAGS)
|
||||
+XLIBS = $(MOTIFLIB) -lXp -lXt -lXext -lSM -lICE -lXmu -lX11
|
||||
LIBS = $(XLIBS) $(LIBLIB) -lm
|
||||
|
||||
XCOMM Sometimes you need -lXp after -lXm
|
||||
- XMLIB = -lXm
|
||||
+ XMLIB = ${MOTIFLIB}
|
||||
DEPLIBS = $(DEPXMLIB) $(DEPXTOOLLIB) $(DEPXLIB)
|
||||
EXTRA_INCLUDES = -I../../libastro -I../../libip -I../../liblilxml -I../../libjpegd
|
||||
LOCAL_LDFLAGS = -L../../libastro -L../../libip -L../../liblilxml -L../../libjpegd
|
||||
# MKS Enterprise toolkit
|
||||
|
|
Loading…
Reference in a new issue