Update to 0.8.12
* Add a set of patches to re-introduce irssi-config which was removed in this release. We need this file for chat/irssi-icb to work. An upstream bug has been opened about this. http://bugs.irssi.org/?do=details&task_id=537&histring=icb From the CHANGELOG: Rewrite SSL connection/handshake code. Remove support for glib 1.x. Do not send our hostname to the server (bug #488). Improve completion for /SET. Various improvements to the help files. Make alt/meta+arrow keys work in recent versions of xterm (bug #496) Fix DCC get when file size is 0 (bug #494). Fix logging lines with no target to all logs, broken in 0.8.11.
This commit is contained in:
parent
6a5bf38050
commit
ed6e55643d
7 changed files with 92 additions and 17 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile.common,v 1.6 2007/06/08 11:53:48 wiz Exp $
|
||||
# $NetBSD: Makefile.common,v 1.7 2007/10/13 16:27:14 adrianp Exp $
|
||||
|
||||
# Specific distribution information.
|
||||
IRSSI_VERSION= 0.8.11
|
||||
IRSSI_VERSION= 0.8.12
|
||||
IRSSI_DISTNAME= irssi-${IRSSI_VERSION}
|
||||
IRSSI_EXTRACT_SUFX= .tar.bz2
|
||||
IRSSI_DISTFILE= ${IRSSI_DISTNAME}${IRSSI_EXTRACT_SUFX}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.8 2006/01/17 21:45:52 veego Exp $
|
||||
@comment $NetBSD: PLIST,v 1.9 2007/10/13 16:27:14 adrianp Exp $
|
||||
bin/irssi
|
||||
include/irssi/config.h
|
||||
include/irssi/irssi-version.h
|
||||
|
@ -68,7 +68,6 @@ include/irssi/src/fe-common/core/module.h
|
|||
include/irssi/src/fe-common/core/printtext.h
|
||||
include/irssi/src/fe-common/core/themes.h
|
||||
include/irssi/src/fe-common/core/translation.h
|
||||
include/irssi/src/fe-common/core/utf8.h
|
||||
include/irssi/src/fe-common/core/window-activity.h
|
||||
include/irssi/src/fe-common/core/window-items.h
|
||||
include/irssi/src/fe-common/core/windows-layout.h
|
||||
|
@ -131,6 +130,7 @@ share/doc/irssi/special_vars.txt
|
|||
share/doc/irssi/startup-HOWTO.html
|
||||
share/examples/irssi/irssi.conf
|
||||
share/irssi/config.h
|
||||
share/irssi/help/accept
|
||||
share/irssi/help/action
|
||||
share/irssi/help/admin
|
||||
share/irssi/help/alias
|
||||
|
|
|
@ -1,8 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.25 2007/06/08 11:53:48 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.26 2007/10/13 16:27:14 adrianp Exp $
|
||||
|
||||
SHA1 (irssi-0.8.11.tar.bz2) = e6433e6d622a1ed09be4323105174433fd72516f
|
||||
RMD160 (irssi-0.8.11.tar.bz2) = 0ae3e2ba144783df3dd517be659b325e8bcf5354
|
||||
Size (irssi-0.8.11.tar.bz2) = 933075 bytes
|
||||
SHA1 (patch-aa) = 94c29684a93d65aa9ab0f3f1f0812d1cb7e89194
|
||||
SHA1 (patch-ab) = a7528069f04de51c82e35d858dd3ec09d07a591b
|
||||
SHA1 (irssi-0.8.12.tar.bz2) = 00ecca04766c51feef057b2327f67166be473fa3
|
||||
RMD160 (irssi-0.8.12.tar.bz2) = 0588e6c2df0425c4f36bd84c1621d9ad170b6a81
|
||||
Size (irssi-0.8.12.tar.bz2) = 935918 bytes
|
||||
SHA1 (patch-aa) = 3333b23ae2b2c3f8f3ef246502badf1b263103c6
|
||||
SHA1 (patch-ab) = 287fd013349b3b6761d08f69ff8aeb8820d65b8c
|
||||
SHA1 (patch-ae) = 975777ae62374aa50ad76e83ed857927e8f3cbe8
|
||||
SHA1 (patch-af) = 47b399f9549ef9772f40bd5e7d27344bffe1cebe
|
||||
SHA1 (patch-ag) = 4716b80fa1db0edb3e68b527396fcce03de06f47
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.4 2006/03/04 06:34:13 wiz Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2007/10/13 16:27:15 adrianp Exp $
|
||||
|
||||
--- src/fe-text/tparm.c.orig 2005-10-19 04:13:29.000000000 +0200
|
||||
--- src/fe-text/tparm.c.orig 2007-10-06 10:40:39.000000000 +0100
|
||||
+++ src/fe-text/tparm.c
|
||||
@@ -247,7 +247,7 @@ char *tparm(const char *str, ...) {
|
||||
argcnt = 0;
|
||||
pos = 0;
|
||||
termcap = 1;
|
||||
- while (*sp != '\0') {
|
||||
+ while ((sp != NULL) && (*sp != '\0')) {
|
||||
+ while ((*sp != '\0') && (sp != NULL)) {
|
||||
switch(*sp) {
|
||||
case '\\':
|
||||
if (scan_for) {
|
||||
|
|
|
@ -1,13 +1,51 @@
|
|||
$NetBSD: patch-ab,v 1.7 2007/06/08 11:53:48 wiz Exp $
|
||||
$NetBSD: patch-ab,v 1.8 2007/10/13 16:27:15 adrianp Exp $
|
||||
|
||||
--- Makefile.in.orig 2007-04-25 18:15:07.000000000 +0000
|
||||
--- Makefile.in.orig 2007-10-06 10:41:44.000000000 +0100
|
||||
+++ Makefile.in
|
||||
@@ -259,7 +259,7 @@ sysconfdir = @sysconfdir@
|
||||
@@ -40,8 +40,8 @@ host_triplet = @host@
|
||||
DIST_COMMON = README $(am__configure_deps) $(noinst_HEADERS) \
|
||||
$(pkginclude_HEADERS) $(srcdir)/Makefile.am \
|
||||
$(srcdir)/Makefile.in $(srcdir)/config.h.in \
|
||||
- $(srcdir)/irssi-version.h.in $(srcdir)/irssi.spec.in \
|
||||
- $(top_srcdir)/configure \
|
||||
+ $(srcdir)/irssi-config.in $(srcdir)/irssi-version.h.in \
|
||||
+ $(srcdir)/irssi.spec.in $(top_srcdir)/configure \
|
||||
$(top_srcdir)/src/perl/common/Makefile.PL.in \
|
||||
$(top_srcdir)/src/perl/irc/Makefile.PL.in \
|
||||
$(top_srcdir)/src/perl/textui/Makefile.PL.in \
|
||||
@@ -60,7 +60,8 @@ mkinstalldirs = $(install_sh) -d
|
||||
CONFIG_HEADER = config.h
|
||||
CONFIG_CLEAN_FILES = src/perl/common/Makefile.PL \
|
||||
src/perl/irc/Makefile.PL src/perl/ui/Makefile.PL \
|
||||
- src/perl/textui/Makefile.PL irssi-version.h irssi.spec
|
||||
+ src/perl/textui/Makefile.PL irssi-version.h irssi-config \
|
||||
+ irssi.spec
|
||||
SOURCES =
|
||||
DIST_SOURCES =
|
||||
RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
|
||||
@@ -252,7 +253,7 @@ sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
@BUILD_PLUGINS_TRUE@PLUGINS = plugins
|
||||
ACLOCAL_AMFLAGS = -I .
|
||||
SUBDIRS = src docs scripts
|
||||
-confdir = $(sysconfdir)
|
||||
+confdir = $(datadir)/examples/@PACKAGE@
|
||||
conf_DATA = irssi.conf
|
||||
themedir = $(datadir)/irssi/themes
|
||||
theme_DATA = default.theme colorless.theme
|
||||
@@ -269,6 +270,7 @@ EXTRA_DIST = \
|
||||
irssi.spec.in \
|
||||
$(conf_DATA) \
|
||||
$(theme_DATA) \
|
||||
+ irssi-config.in \
|
||||
irssi-icon.png \
|
||||
syntax.pl \
|
||||
findsyntax.pl
|
||||
@@ -331,6 +333,8 @@ src/perl/textui/Makefile.PL: $(top_build
|
||||
cd $(top_builddir) && $(SHELL) ./config.status $@
|
||||
irssi-version.h: $(top_builddir)/config.status $(srcdir)/irssi-version.h.in
|
||||
cd $(top_builddir) && $(SHELL) ./config.status $@
|
||||
+irssi-config: $(top_builddir)/config.status $(srcdir)/irssi-config.in
|
||||
+ cd $(top_builddir) && $(SHELL) ./config.status $@
|
||||
irssi.spec: $(top_builddir)/config.status $(srcdir)/irssi.spec.in
|
||||
cd $(top_builddir) && $(SHELL) ./config.status $@
|
||||
|
||||
|
|
21
chat/irssi/patches/patch-af
Normal file
21
chat/irssi/patches/patch-af
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-af,v 1.5 2007/10/13 16:27:15 adrianp Exp $
|
||||
|
||||
--- configure.orig 2007-10-06 10:41:38.000000000 +0100
|
||||
+++ configure
|
||||
@@ -27055,7 +27055,7 @@ VERSION_TIME=`head -n 2 $srcdir/ChangeLo
|
||||
|
||||
|
||||
|
||||
-ac_config_files="$ac_config_files Makefile src/Makefile src/core/Makefile src/irc/Makefile src/irc/core/Makefile src/irc/dcc/Makefile src/irc/notifylist/Makefile src/irc/proxy/Makefile src/irc/flood/Makefile src/fe-common/Makefile src/fe-common/core/Makefile src/fe-common/irc/Makefile src/fe-common/irc/dcc/Makefile src/fe-common/irc/notifylist/Makefile src/fe-none/Makefile src/fe-text/Makefile src/lib-config/Makefile src/lib-popt/Makefile src/perl/Makefile src/perl/common/Makefile.PL src/perl/irc/Makefile.PL src/perl/ui/Makefile.PL src/perl/textui/Makefile.PL scripts/Makefile scripts/examples/Makefile docs/Makefile docs/help/Makefile docs/help/in/Makefile irssi-version.h irssi.spec"
|
||||
+ac_config_files="$ac_config_files Makefile src/Makefile src/core/Makefile src/irc/Makefile src/irc/core/Makefile src/irc/dcc/Makefile src/irc/notifylist/Makefile src/irc/proxy/Makefile src/irc/flood/Makefile src/fe-common/Makefile src/fe-common/core/Makefile src/fe-common/irc/Makefile src/fe-common/irc/dcc/Makefile src/fe-common/irc/notifylist/Makefile src/fe-none/Makefile src/fe-text/Makefile src/lib-config/Makefile src/lib-popt/Makefile src/perl/Makefile src/perl/common/Makefile.PL src/perl/irc/Makefile.PL src/perl/ui/Makefile.PL src/perl/textui/Makefile.PL scripts/Makefile scripts/examples/Makefile docs/Makefile docs/help/Makefile docs/help/in/Makefile irssi-version.h irssi-config irssi.spec"
|
||||
|
||||
|
||||
cat >confcache <<\_ACEOF
|
||||
@@ -27735,6 +27735,7 @@ do
|
||||
"docs/help/Makefile") CONFIG_FILES="$CONFIG_FILES docs/help/Makefile" ;;
|
||||
"docs/help/in/Makefile") CONFIG_FILES="$CONFIG_FILES docs/help/in/Makefile" ;;
|
||||
"irssi-version.h") CONFIG_FILES="$CONFIG_FILES irssi-version.h" ;;
|
||||
+ "irssi-config") CONFIG_FILES="$CONFIG_FILES irssi-config" ;;
|
||||
"irssi.spec") CONFIG_FILES="$CONFIG_FILES irssi.spec" ;;
|
||||
|
||||
*) { { echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
|
14
chat/irssi/patches/patch-ag
Normal file
14
chat/irssi/patches/patch-ag
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ag,v 1.1 2007/10/13 16:27:15 adrianp Exp $
|
||||
|
||||
--- /dev/null 2007-10-13 14:51:24.000000000 +0100
|
||||
+++ irssi-config.in 2007-10-13 14:51:59.000000000 +0100
|
||||
@@ -0,0 +1,9 @@
|
||||
+PROG_LIBS="@PROG_LIBS@"
|
||||
+COMMON_LIBS="@COMMON_LIBS@"
|
||||
+
|
||||
+PERL_LINK_LIBS="@PERL_LINK_LIBS@"
|
||||
+PERL_FE_LINK_LIBS="@PERL_FE_LINK_LIBS@"
|
||||
+PERL_LINK_FLAGS="@PERL_LINK_FLAGS@"
|
||||
+
|
||||
+CHAT_MODULES="@CHAT_MODULES@"
|
||||
+irc_MODULES="@irc_MODULES@"
|
Loading…
Reference in a new issue