* rancid: fail on error opening nvram:
* rancid: skip ASA 5520 configuration author line
* control_rancid: for svn stupidity, run update (yes update) and commit
  after setting svn:ignore, else . is out of date.
* rancid: filter auto "rogue ap" configuration
* alogin: adjust match of active alarms msg at login
* jrancid: patch for master/backup matching on EX series
* rancid: update cisco WAE identity string match
* {xr}rancid: summarize DirSlotN() bytes free as GB, else MB.
* rancid: filter sflog from DirSlotN() for IOS on cisco 10k
* fnrancid: update recent fortinet software
* rancid: ignore show flash on IOS XE
* rancid: copy the dhcp database filter to ShowFlash()
* clogin: Fix pasto in IOS terminal width command.
* hlogin: -r missing from usage o/p
* clogin: add -r and passphrase/identfile from cloginrc
* francid: remove system uptime line on CER 3000

2.3.5
* alogin: respond to active alarms msg at login
* *rancid: update for grammar deprecated in perl 5.12
* *login: handle noenable value consistently, '1' to turn it on
* configure: look for -n <count> option to ping, for Windows ping (over
  cygwin)
* rancid: missed case fpr accepting '>' prompt, rather than just '#'
* xrrancid: filter sequences from ipv4/6 access-lists
* zrancid: force terminal type vt100 so as not to confuse Linux
* francid: filter system uptime on new Brocades
* rancid: filter ASA time-based license noise
* rancid: filter command in WriteTerm if echoed
* configure: specifically look for ping in /sbin & /usr/sbin & fix typo
  in test operator
* rancid: handle a few IOS serial number formatting variants
* hpuifilter: change filtering to avoid use of string functions due to a
  Debian bug.  Should be faster too.
* rancid: adjust show inventory matches for variables WS
* nxrancid: show environment clock and show core vdc-all are not valid
  commands on all platforms
This commit is contained in:
pettai 2011-01-24 14:54:57 +00:00
parent c83d1af2de
commit ed83de0243
4 changed files with 12 additions and 23 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.3 2010/07/19 11:22:25 pettai Exp $
# $NetBSD: Makefile,v 1.4 2011/01/24 14:54:57 pettai Exp $
#
DISTNAME= rancid-2.3.4
DISTNAME= rancid-2.3.6
CATEGORIES= net
MASTER_SITES= ftp://ftp.shrubbery.net/pub/rancid/
@ -51,8 +51,8 @@ MESSAGE_SUBST+= RC_USER=${RC_USER}
SUBST_CLASSES+= paths
SUBST_FILES.paths= ${WRKSRC}/etc/lg.conf.sample.in
SUBST_FILES.paths+= ${WRKSRC}/etc/rancid.conf.sample.in
SUBST_STAGE.paths= post-extract
SUBST_SED.paths= -e 's,@ENV_PATH@,${PREFIX}/sbin:/bin:/usr/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/sbin,'
SUBST_STAGE.paths= post-extract
SUBST_SED.paths= -e 's,@ENV_PATH@,${PREFIX}/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin,'
OWN_DIRS_PERMS+= ${VARBASE}/rancid ${RC_USER} ${RC_GROUP} 0755

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2010/07/25 20:27:33 pettai Exp $
@comment $NetBSD: PLIST,v 1.4 2011/01/24 14:54:57 pettai Exp $
bin/agmrancid
bin/alogin
bin/arancid
@ -16,6 +16,7 @@ bin/erancid
bin/f10rancid
bin/f5rancid
bin/flogin
bin/fnlogin
bin/fnrancid
bin/francid
bin/hlogin
@ -70,6 +71,7 @@ man/man1/erancid.1
man/man1/f10rancid.1
man/man1/f5rancid.1
man/man1/flogin.1
man/man1/fnlogin.1
man/man1/fnrancid.1
man/man1/francid.1
man/man1/hlogin.1
@ -128,3 +130,4 @@ share/doc/rancid/rancid.conf.sample
share/doc/rancid/rtrfilter
share/examples/rancid/lg.conf.sample
share/examples/rancid/rancid.conf.sample
@pkgdir etc/rancid

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.2 2010/07/19 11:22:25 pettai Exp $
$NetBSD: distinfo,v 1.3 2011/01/24 14:54:57 pettai Exp $
SHA1 (rancid-2.3.4.tar.gz) = 7be67dbf6ae7a270e53d030cda1903b63a9e555f
RMD160 (rancid-2.3.4.tar.gz) = 68fb3a8f74d6fe7796308e45f9b558bb28290d90
Size (rancid-2.3.4.tar.gz) = 368120 bytes
SHA1 (patch-aa) = effca21e1e9ecb39f0c31a8555ac7cca10046a46
SHA1 (rancid-2.3.6.tar.gz) = d6f47f7733435681ca9c34fadbcc965ac6b7567f
RMD160 (rancid-2.3.6.tar.gz) = 8bfaa861b4b8f64e1c2a889605488621b0dcb042
Size (rancid-2.3.6.tar.gz) = 372836 bytes

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/03/12 23:39:16 pettai Exp $
--- configure.orig 2009-12-13 00:37:15.000000000 +0100
+++ configure 2009-12-13 00:37:29.000000000 +0100
@@ -6212,7 +6212,7 @@
# since organized religion; see if -U 4 works.
${_diff}/diff -U 4 /dev/null /dev/null > /dev/null 2>&1
if test $? -ne 0; then
- if test "${ADIFF}" == "" ; then
+ if test "${ADIFF}" = "" ; then
ADIFF="${_diff}/diff"
ADIFF_CMD="diff -c -4"
fi