One more fix for assumption about POSIX accept(). PKGREVISION++
This commit is contained in:
parent
6e62c313f0
commit
edb533c4af
3 changed files with 15 additions and 5 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.4 2015/02/20 09:32:07 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2015/02/23 22:27:37 fhajny Exp $
|
||||
#
|
||||
|
||||
PKGNAME= stud-0.3p53
|
||||
PKGREVISION= 3
|
||||
PKGREVISION= 4
|
||||
CATEGORIES= security
|
||||
MAINTAINER= jym@NetBSD.org
|
||||
HOMEPAGE= http://github.com/bumptech/stud
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2015/02/20 09:32:07 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.3 2015/02/23 22:27:37 fhajny Exp $
|
||||
|
||||
SHA1 (bumptech-stud-0.3-51-g0b88039.tar.gz) = fad22d9cf008b7db8f30d8d7ca0a6fcc177714de
|
||||
RMD160 (bumptech-stud-0.3-51-g0b88039.tar.gz) = 66a186e1095fd127945802ab681f5948ee1d4011
|
||||
|
@ -6,4 +6,4 @@ Size (bumptech-stud-0.3-51-g0b88039.tar.gz) = 41000 bytes
|
|||
SHA1 (patch-Makefile) = c0794c6ebb3bdc3d55b473acec674a9f98b03ffb
|
||||
SHA1 (patch-configuration.c) = 886226a104f84bac6902bb8a8593d37a25653563
|
||||
SHA1 (patch-stud.8) = a6b36ab6ac8c65cbc70172a9c230b22965cbdc3d
|
||||
SHA1 (patch-stud.c) = aae56a212de51dfec4c31a9f4318818a79a51dfd
|
||||
SHA1 (patch-stud.c) = a33ccb6adc85ea545db3372201b8f50733d79222
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: patch-stud.c,v 1.2 2015/02/20 09:32:07 fhajny Exp $
|
||||
$NetBSD: patch-stud.c,v 1.3 2015/02/23 22:27:37 fhajny Exp $
|
||||
|
||||
SunOS fixes as per https://github.com/bumptech/stud/pull/71.
|
||||
SSL fixes as per https://github.com/bumptech/stud/pull/130.
|
||||
Fix for POSIX accept() that can also return ECONNABORTED.
|
||||
|
||||
--- stud.c.orig 2012-08-10 23:40:19.000000000 +0000
|
||||
+++ stud.c
|
||||
|
@ -68,6 +69,15 @@ SSL fixes as per https://github.com/bumptech/stud/pull/130.
|
|||
shutdown_proxy(ps, SHUTDOWN_SSL);
|
||||
}
|
||||
}
|
||||
@@ -1312,7 +1335,7 @@ static void handle_accept(struct ev_loop
|
||||
break;
|
||||
|
||||
default:
|
||||
- assert(errno == EINTR || errno == EWOULDBLOCK || errno == EAGAIN);
|
||||
+ assert(errno == EINTR || errno == EWOULDBLOCK || errno == EAGAIN || errno == ECONNABORTED);
|
||||
break;
|
||||
}
|
||||
return;
|
||||
@@ -1751,24 +1774,16 @@ void daemonize () {
|
||||
exit(0);
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue